Dauer Bremstest?

  • Moin,


    da unsere Roboter zu dicht am Schutzzaun stehen, möchte ich per Safe Operation einen sicheren Zellbereich definieren. Dafür muss ich auch den sicheren Referenzschalter zur Justageüberprüfung verwenden (habe ich noch nicht gemacht, liest sich in der Anleitung aber erstmal relativ einfach und ist ja nur 1x nach Hochfahren der Steuerung notwendig).


    Etwas mehr Bedenken habe ich beim Bremstest: Dieser ist scheinbar auch zwingend erforderlich?? Wenn ich es richtig verstanden habe, benötigt der Roboter für jede Achse 10° Bewegungsspielraum an einer definierten Position. Wie lange dauert so ein Bremstest? Die Taktzeit der Anlage beträgt 5 Sekunden, und die Bewegung des betreffenden Roboters geht bestimmt auch über 2-3 Sekunden. Es gibt also nur eine sehr kurze Stillstandszeit.


    Noch kritischer wäre es beim zweiten Roboter: Hier könnte es sogar sein, dass der Roboter durchgängig in Bewegung ist oder nur ganz kurze Wartezeiten hat.


    Wenn der Bremstest also nicht kalt sofort bei Anlagenstart stattfinden soll und ich nicht unbedingt 1h Warmfahren will, muss der Bremstest im Prozess erfolgen. Deshalb die Frage nach der Dauer und dem genauen Ablauf dieses Tests.


    Vielen Dank im Voraus und euch allen ein schönes Wochenende!


    h_robot

  • Hallo h_robot

    der Bremsentest braucht defaultmäßig alle 46h ca 30 Sekunden für den Bremsentest.


    Eine eigene Position für den Bremsentest ist nicht zwingend erforderlich, meistens gehts aus der Grundstellung raus.


    Du kannst den Bremsentest aber auch per Eingang von der SPS starten, somit kannst du den Bremsentest zu einem geeigneten Zeitpunkt starten.


    Grüße

  • Servus,

    du kannst den Intervall für den Bremsentest selbst festlegen. Wir haben ihn auf 168 Std. festgelegt => 1 mal pro Woche wird er gemacht, am Montag beim Anfahren der Anlage.

    Können den Maschinentakt bei uns wegen dem Bremsentest nicht unterbrechen.

    Der Hersteller der Anlage mus sowieso eine Risikobeurteilung machen => nach der kann er auch festlegen das ein anderer Intervall ausreicht.

    Sollte der Roboter mit einem Mitarbeiter agieren (Beladeschublade, SafeStandStill etc.) dann würde ich bei der Defaulteinstellung bleiben.


    BTW: Wir machen den Bremsentest mit kaltem Roboter und hatten bis dato keine Probleme damit.


    Gruss

    Martl

  • Hi!


    Danke für Eure bisherigen Antworten!


    Kurz zum Einsatzzweck/Anwendung des Roboters: Es geht um eine Automatisierung im Uni-Versuchsfeld. Wenn die Anlage gerade nicht benötigt wird, werden die Robotersteuerungen i.d.R. auch ausgeschaltet.


    Wenn versuche gefahren werden ==> alles einschalten, dann dauert eine Versuchsreihe etwa bis zu 8 Stunden (dabei werden dann etwa 500....2.000 Teile produziert), das Ganze muss dann unterbrechungsfrei und mit gleichbleibender Taktzeit von 5s sein.


    Danach wäre auch Zeit für den Bremstest, bringt aber vermutlich nichts, weil wir die Robotersteuerungen nach der Versuchsserie ausschalten.


    Die Anlage steht manchmal auch einige Wochen still und manchmal werden 5 Tage hintereinander versuche gefahren (jeweils mit Abschaltung der kompletten Anlage zu Feierabend)


    Da ich wohl (lt. KUKA-Anleitung Safe Operation) den Bremstest zwingend innerhalb der ersten zwei Stunden durchführen muss, da es ansonsten zu einem Stopp kommt, muss ich den Bremstest wohl kalt oder nach einer Warmlaufphase vor Versuchsbeginn durchführen.


    @Martl: Oder bezieht sich das von Dir beschriebene Intervall auch auf die von KUKA angegebenen 2 Stunden nach Einschalten?


    Habt ihr für den o.g. Anwendungsfall des Roboters eine praktische Lösungsmöglichkeit, wie und wann der Bremstest durchgeführt wird und wie das Intervall sein könnte?


    Wenn ich alles einschalte muss ich ja auf jeden Fall den Referenzschalter anfahren. Dann könnte ich doch auch gleich den Bremstest einleiten und habe dann erstmal Ruhe, oder?


    Bremstest in der Grundstellung geht aber nicht, weil die Grundstellung nur per LIN-Bewegung in zwei Richtungen exakt verlassen werden kann.


    h_robot

  • ... Wenn ich alles einschalte muss ich ja auf jeden Fall den Referenzschalter anfahren. Dann könnte ich doch auch gleich den Bremstest einleiten und habe dann erstmal Ruhe, oder?

    ...

    Genau so wird das gemacht.

    Einfach nicht so kompliziert denken.

    Ihr müsst euch da erst Gedanken machen wenn die Versuchsreihen länger als 36 Stunden dauern sollen.

  • Moin zusammen,


    zur ersten Antwort vom Robonator eine Frage:

    der Bremsentest braucht defaultmäßig alle 46h ca 30 Sekunden für den Bremsentest.


    Ich habe den Bremstest mal per externem Signal angefordert. Am KCP erscheint dann auch die Meldung (KSS27004 Bremsentest erforderlich).


    Dann habe ich BrakeTestReq aus dem cell.src heraus aufgerufen => Roboter verfährt in die programmierte Start- und dann in die programmierte Endposition => Dann Meldung (KSS27012 Bremsentest erfolgreich durchgeführt).


    Von der Startposition wurden keine weiteren automatischen Bewegungen durchgeführt, schon gar nicht beschleunigte der Roboter auf 100%, wie in der Dokumentation beschrieben. Es hat auch keine 30 Sekunden gedauert.


    Wurde der Bremsentest wirklich durchgeführt, oder war die Meldung KSS27012 dann schon aufgrund der Tatsache gekommen, dass theoretisch kein Bremstest erforderlich ist, obwohl ich einen angefordert habe?


    Oder geht der Bremsentest so schnell, dass man davon nichts sieht und auch die in der Dokumentation beschriebenen Freiräume von +/- 10° pro Achse eher eine sehr, sehr weite Reserve für den Fall ist, dass eine Bremse wirklich defekt ist? D.h. bewegt sich der Roboter in der Testposition bei intakten BRemsen normal gar nicht?


    Grüße,

    h_robot

  • Guten Morgen h_robot.


    Jetzt kommt es auf deine KSS Version an.

    Vor KSS 8.5 sah der Bremsentest so aus, dass er in die Startpos fuhr, dann jede Achse der Reihe nach 1x links in die Bremse, 1x rechts in die Bremse und nochmals 1x links in die Bremse verfuhr. Da siehst du dann auch die 10° Verfahrweg jedes Mal. Danach fuhr er wieder in die Endpos.


    Seit KSS 8.5 sieht der Bremsentest anders aus um den Verschleiß an den Bremsen zu minimieren. Dort fährt der Roboter ebenfalls in die programmierte Startpos, dann verfährt jede Achse der Reihe nach um ca 10° aus der Startpos und wieder zurück um die Haftreibung der Achse zu ermitteln. Dann schließt er die Bremse der einzelnen Achsen und gibt impulsmäßig Strom auf den Motor (was man auch hören kann) und überwacht ob der Motor durch die Bremse rutscht. Danach fährt er wieder zurück in die Endpos.



    Also solltest du auf jeden Fall während des Bremsentest eine Bewegung sehen oder etwas hören.


    Mich irritiert etwas, dass der Bremsentest erfolgreich angezeigt wird, obwohl wie du erklärst der Roboter in die Startpos und direkt wieder zurück in die Endpos fährt.


    Hast du mal versucht, das Braketestreq.src direkt anzuwählen und abzufahren?

    Das funktioniert auch, wenn keine Bremstentestanforderung ansteht.


    Grüße

  • Hast du mal versucht, das Braketestreq.src direkt anzuwählen und abzufahren?

    ja, habe ich in AUT gestartet, aber es zeigt sich die gleiche Reaktion. Ich muss bestätigen, dass ich den Bremstest händisch durchführe, dann aber mit Zusatimmung und Start gedrückt lassen. Der Roboter fährt dann in die Start- und Stopposition, aber es keine von dir beschriebenen Bewegungen.....


    Grüße

  • Hallo h_robot

    Das weiß ich aber des war nicht meine Frage.

    Ich schließe draus, dass du kein SafeOperation drauf hast? Hast du dann den Treiber für den Bremsentest selbst einkommentiert?


    Ansonsten ruf doch einfach bei de Hotline von kuka an.

    Ich wäre mit den jetzigen Fakten mit meinem Latein am Ende.


    Grüße

  • Ansonsten ruf doch einfach bei de Hotline von kuka an.

    Ich wäre mit den jetzigen Fakten mit meinem Latein am Ende.

    Oder h_robot müsste Doku lesen.

    Blick in "Bedien- und Programmieranleitung für Systemintegratoren".

    Hat heute 18 Seiten drin betreffend Bremsentest und beantwortet eigentlich alle Fragen.


    Das wichtigste hier: Was für KSS er hat und ob überhaupt welche Achsen aktiviert sind.


    Ab KSS 8.5 kannst Du nun sogar Achsen übergeben, dass Du sie einzeln testen kannst und nicht alle auf's mal musst. Für kurze Pausen.

    Weiter gibt's Programm, wo Du die vom Bremsentest ausgenommenen Bremsen, zum Bsp. abkoppelbare, auch testen kannst.

    Manche Maenner bemuehen sich lebenslang, das Wesen einer Frau zu verstehen. Andere befassen sich mit weniger schwierigen Dingen z.B. der Relativitaetstheorie.

  • Guten Morgen zusammen!

    Welche KSS hast en du?

    Hast du SafeOperation drauf bzw. wurde wenn ja das Optionspaket nachgerüstet?

    Ich habe die KR C V8.3.37 mit SafeOperation 3.2.4. SafeOperation war von Anfang an mit bei Auslieferung installiert, da auch so bestellt.


    Hintergrund, wofür SafeOperation eingesetzt werden soll: Roboter steht etwas dicht am Zaun. Es sollen also nur die Achsen sicher begrenzt werden. Keine Verwendung der X13-Schnittstelle, keine Safety über Bus o.ä. und auch keine Reduzierten Geschwindigkeiten oder sonstige Funktionalitäten aus SafeOperation.


    Übrigens: Die Justagereferenzierung funktioniert, dies habe ich schon in cell.src einbauen können.


    Ich schließe draus, dass du kein SafeOperation drauf hast? Hast du dann den Treiber für den Bremsentest selbst einkommentiert?

    Ne, daran habe ich nichts verändert. Bei einem AGILUS ohne SafeOperation habe ich den Bremstest auch mal in WorkVisual aktiviert, und dort funktioniert es auch einwandfrei. Bremstest lässt sich aus cell.src starten und wird dann auch wirklich ausgeführt.


    Bei betreffenden o.g. Roboter wird "Bremstest erzwungen" auch in der Sicherheitskonfiguration angezeigt, jedoch erscheint keine Anforderungsmeldung im Meldungsfenster. Und er lässt sicheben wie schon beschrieben nicht ausführen. Roboter fährt einfach nur in Start- und Endposition des Bremstests und gibt Fertigmeldung aus, obwohl nichts passiert ist. Auch bei externer Anforderung nicht. (Bei externer Anforderung steht die Notwendigkeit des Bremstests jedoch im Meldungsfenster).


    Oder h_robot müsste Doku lesen.

    Blick in "Bedien- und Programmieranleitung für Systemintegratoren".

    Hat heute 18 Seiten drin betreffend Bremsentest und beantwortet eigentlich alle Fragen.

    Steht in der Doku für meine KSS Version leider nicht drin. Auch das Menü aus dem von Dir gezeigten Screenshot finde ich nicht.


    Danke für Eure Hilfsbereitschaft!! :-)

  • .....Auch das Menü aus dem von Dir gezeigten Screenshot finde ich nicht.

    Bei V8.3 gibt's dieses nicht. Darum immer so wichtig, Softwareversion anzugeben.


    Wenn Du einen Blick riskierst in die Datei BrakeTestReq.src:

    Du sagst, Abfrage kommt, Startpos fährt er, danach direkt auf Endpos,

    dann hat er Probleme beim Ausführen des blau markierten Bereiches im Screenshot.


    Er wertet hier vor allem die Variable BitfieldAxesInTest aus. Ist Bitfeld der Achsen, die er Testen soll.

    Diese ist definiert hier:


    Sollte 63 (B111111) sein für alle 6 Achsen. Bei 0 hättest Du exakt Dein Effekt.


    Weiter ist wichtig, dass der Treiber nicht auskommentiert ist hier:


    Und wenn Du schon am prüfen wärst, könntest Du noch vorgegebenes Flag und Interrupt auf Konflikte mit Deinem Prog prüfen.



    Gruss SJX

    Manche Maenner bemuehen sich lebenslang, das Wesen einer Frau zu verstehen. Andere befassen sich mit weniger schwierigen Dingen z.B. der Relativitaetstheorie.

  • Danke, SJX!!


    Hier scheint wirklich ein Prblem vorzuliegen. Ich frage mich aber auch etwas, wo die ganzen Schritte, die Du mir jetzt genannt hast eigentlich dokumentiert sind? Ist das von KUKA gedacht, dass man das selbst anpasst und von denen irgendwo beschrieben? Oder woher weißt Du das alles? Ich habe zwar mal einen 2-Wöchigen Programmierlehrgang im KUKA College absolviert, aber das hat sowas natürlich überhaupt nicht beinhaltet.....


    Also erstmal (falls relevant): BrakeTestReq.src kann ich mir nur in WorkVisual ansehen. Auf dem KCP sehe ich nur den leeren Fold perform brake test, sonst kann ich keine Folds öffnen und sehe den eigentlichen Quellcode nicht.....


    Die Datein sehen fast alle wie bei Dir aus, mit der Ausnahme: Das Bitfield stehtr auf 0, BrkTst also für alle Achsen deaktiviert. Die Datei wird bei mir aber als automatisch generiert und Schreibgeschützt angezeigt. Kann sie nicht verändern....


    Hier auch meine Ordnerstruktur: Gibt es hier auch weitere Erklärungen von KUKA, wie die Ordner zusammenhängen? Teilweise gleiche Dateinamen mit unterschiedlichem Inhalt einmal in Mada-MotionDrivers und einmal direkt in MotionDrivers.... Irgendwie sehr unübersichtlich. Was kann hier nicht stimmen?



    h_robot

  • ….Oder woher weißt Du das alles?

    Jugend forscht, Bayerisch (neu chinesisch) denken und viel :kopfkratz::kopfkratz::kopfkratz::beerchug::beerchug::beerchug:

    Ich kenne dies ein bisserl von den externen Achsen, wo man früher mit dem auch schon gespielt hat.


    Hab heute noch dies gefunden. Scheint bekannt Dein Problem. Welche WoV Version verwendest Du?

    Re: Bremsentest bei 8.3.38 wird nicht ausgeführt



    Auf dem KCP sehe ich nur den leeren Fold perform brake test, sonst kann ich keine Folds öffnen und sehe den eigentlichen Quellcode nicht.....

    Hat mit einem Steuerzeichen in der Falte zu tun.

    pasted-from-clipboard.png


    ...Gibt es hier auch weitere Erklärungen von KUKA, wie die Ordner zusammenhängen? Teilweise gleiche Dateinamen mit unterschiedlichem Inhalt einmal in Mada-MotionDrivers und einmal direkt in MotionDrivers.... Irgendwie sehr unübersichtlich.....

    Erklärungen dazu gibt's meines Wissens nicht. Wurde eingeführt mit KRC4- Generation und V8.x.x.


    Die Datei wird bei mir aber als automatisch generiert und Schreibgeschützt angezeigt. Kann sie nicht verändern....

    Ist leider so, WoV funktioniert halt so. Wenn man den Bug gefunden hat, ist es dann noch so, dass man WoV noch überlisten muss.


    Das ursprüngliche Active Projekt der Auslieferung und das Basis-Projekt hatten auch schon eine "0" drin ?

    Was hast Du als "Ursprungsprojekt" für Dein aktuelles aktives Projekt genommen ? Selber was gemacht in WoV und nachher zusammengeführt oder ?

    Neuestes WoV wäre die V6.0.9.

    Manche Maenner bemuehen sich lebenslang, das Wesen einer Frau zu verstehen. Andere befassen sich mit weniger schwierigen Dingen z.B. der Relativitaetstheorie.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now