Bremsentest bei 8.3.38 wird nicht ausgeführt

  • Moin,


    ich habe bei einem KR16 mit 8.3.38 die Safe eingerichtet und im WV unter zusätzliche Steuerungseinstellungen den Haken bei "Bremsentest erzwingen" gesetzt. Sichere Überwachung ist natürlich aktiv. Jedoch verlangt er von sich nie einen Bremsentest und ich weiß absolut nicht warum. Gibt es evtl noch eine interne Variable, die dafür verantwortlich sein kann? Justagereferenzierung wird ganz normal nach jedem Steuerungsneustart angefordert wie es sein soll. Über einen Tipp wäre ich mehr als dankbar.

  • AD
  • Guten Morgen irProgrammierer.


    Schau mal unter C->KRC->Roboter->Config->User->Common->MotionDrivers->motiondrv.ini
    ob bei "Other Drivers"


    BRAKE_TEST,mdrBrakeTest.o


    steht bzw. ob es auskommentiert ist.


    -Sollte es auskommentiert sein, so kommentier es einfach wieder ein.
    -Sollte dort nicht BRAKE_TEST,mdrBrakeTest.o stehen, so schreib es rein.


    Das ist der Treiber für den Bremsentest.


    Solltest du ein der 2 Punkte durchgeführt haben, den Roboter mit Kaltstart+Datein neu einlesen neu starten, dann sollte es tun.


    Noch zur Info:
    Der Bremsentest wird nicht nach jedem Neustart der Steuerung durchgeführt, sondern nach Ablauf seines Timers, der in der Regel 46h beträgt.


    Grüße

  • Moin,
    Bremsentest händisch anwählen und Safe aktiv klingt irgendwie doppelt gemoppelt.
    Der Bremsentest ist für Safe notwendig, insofern..
    Vielleicht hilft es auch, auf der Steuerung Safe einmal zu deaktivieren, dann Neustart mit allen Haken und danach Safe wieder zu aktivieren.
    Alles in allem scheint das ein Bug in WoV zu sein.

    never touch a running system

    Edited once, last by Otto Sieben ().

  • Hi, hier Ausschnitt aus Doku:


    Wenn der Bremsentest aktiv ist, dann fordern folgende Ereignisse einen
    Bremsentest an:
    # Eingang $BRAKETEST_REQ_EX von extern, z. B. von einer SPS (externe
    Anforderung)
    # Robotersteuerung startet mit Kaltstart (interne Anforderung)
    # Funktionstest des Bremsentests (interne Anforderung)
    # Bremsentest-Zykluszeit ist abgelaufen (interne Anforderung)


    Die Zykluszeit beträgt 46 h. Sie ist abgelaufen, wenn die Antriebe insgesamt
    46 h in Regelung waren. Die Robotersteuerung fordert dann einen Bremsentest
    an und gibt folgende Meldung aus: Bremsentest erforderlich. Der Roboter
    lässt sich weitere 2 Stunden verfahren. Danach stoppt er und die Robotersteuerung
    gibt folgende Quittiermeldung aus: Prüfzyklus für Bremsentestanforderung
    nicht eingehalten. Nach dem Quittieren kann der Roboter jeweils
    weitere 2 Stunden verfahren werden.

  • Das habe ich auch in der KUKA DOku gelesen. Ich habe die Anlage jeden Abend ausgeschaltet und morgens wieder an, die Referenzfahrt wurde dann angefordert, der Bremsentest jedoch nicht. Diese "internen Anforderungen" scheinen sich bei mir gar nicht zu melden. :(

  • Moin,
    jetzt hast Du schon mehrfach geschrieben, dass es nicht geht.
    Hast Du denn schon mal den von mir vorgeschlagenen Weg versucht?
    Das Ergebnis wäre für die weitere Fehlersuche hilfreich.


    Wie bereits von freelancer beschrieben, kommt eine interne Bremsentestanforderung nur nach Kaltstart, bei Ausschalten ins Hibernate läuft lediglich der interne Zähler weiter, bei Wiedereinschalten erfolgt in dem Fall nur eine Anforderung für die Justagereferenzierung.

    never touch a running system

    Edited once, last by Otto Sieben ().

  • Hallo,


    kann den Antworten der Kollegen nur zustimmen.
    Der Bremsentest gehört zum Basispaket (KSS) den könntest du auch wenn du möchtest bei jedem Roboter ohne Safe Option aktivieren. Aktivieren wäre wie die Kollegen beschrieben haben.
    (die 2 Zeilen BRAKE_TEST,mdrBrakeTest.o oder halt mit Vorsicht zu geniessen WoV)


    Wenn du Kaltstart aktivierst und neu startest, muss Anforderung Bremsentest da stehen, ansonsten nochmal WoV übersetzen und neu einspielen.


    Es gab noch ein Problem bei KSS<8.3.39 und WoV >=5.0.8 da wurde die Variable BitfieldAxesActivated in der Datei KRC\Roboter\Config\User\Common\Mada\MotionDrivers\mdrBrakeTest.ini auf 0 gesetzt.
    Das hatte zur Folge das zwar ins Kuka Bremsentest Programm gesprungen wurde, aber dann keine einzige Achse getestet wurde und Bremsentest als erfolgreich gemeldet wurde. BitfieldAxesActivated =63 bei 6 Achsen


    Vielleicht auch mal die sichere Überwachung deaktivieren und wieder aktivieren. Aber alles am Roboter direkt.


    VG

  • Moin,
    hast probiert mit Kaltstart?
    Es gab noch eine Variable, wo man binär Achsen auswählen könnte, für welche Bremsentest aktiv ist.
    Kann morgen in meiner Notizen vom Lergang nachgucken, sonst keine Idee.
    Was sagt Kuka-Hotline?


    edit: habe Antwort vom Kollege übersehen :)
    BitfieldAxesActivated

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now