ABB ASEA IRB 6/2

  • hey


    Ja also mein Plan war es nun meinen Kabelsalat noch einmal als aller erstes vor dem Zuge zu überprüfen und wirklich jede kabelnummer raus schreiben und dazu schreiben von wo nach wo es geht und quasi wofür.... ich glaube darin liegt der Fehler.


    Ich habe die leise Vermutung dass das alles mit dem großen Kabelsalat zutun hat der in dem Schrank unten auf dem Boden liegt, da ich erstmal probieren wollte ob alles klappt bevor ich so viel Geld und Arbeit investiere.


    Aber ich bin da guter Dinge und werde das in Angriff nehmen das schweißgerät und die Positionierer ordentlich mit vernünftigen Steckern zu bestücken.


    Mir ist dort mit Sicherheit irgendwo ein Fehler unterlaufen, weil sonst wären doch mit Sicherheit die anderen Parameter auch weg oder kaputt?


    Vielleicht tut es das schweißgerät auch nicht mehr? Also testen kann ich es ja leider schlecht.... also anschalten kann ich es aber ob es schweißt kann ich nicht beurteilen da dass ja alles vom Robotersystem gesteuert wird.


    Oder was meinst du?


    Grüße

  • Das ist das Operatorpanel für Stationswechsel einzuleiten und Start Stop des Roboters. Ein Labod steckt hier nicht drin. Evtl. Direkt unten im Tisch?


    U jetze :beerchug:

    Manche Maenner bemuehen sich lebenslang, das Wesen einer Frau zu verstehen. Andere befassen sich mit weniger schwierigen Dingen z.B. der Relativitaetstheorie.

  • Moin,


    Da bin ich schon wieder 😅

    Ich versuche gerade die Belegungen am Plug B zu machen (für das Schweißgerät)


    Habe auch eigentlich alle Kabel soweit bis auf :


    Kabel 108 geht auf Nr.40 auf DSQC 122

    Kabel 125 geht auf Nr.8 auf DSQC 122

    Kabel 110 geht auf Nr.6 auf D14.137.X80

    Kabel 103 geht auf Nr.13 auf DSQC 138

    Kabel 104 geht auf Nr.12 auf DSQC 138

    Kabel 85 geht auf Nr.30 auf DSQC 138

    Kabel 97 geht auf das KA7


    Die Kabel habe ich so verfolgt bis dahin wo Sie enden. Die hatte ich nicht angeschlossen am Anfang weil diese nirgends auf den Zeichnungen von der Steckerbelegung zu sehen waren. Vielleicht liegt da schon der Hase im Pfeffer 🤔


    Ich schaue in den zeichnung soeben nach aber finde nichts wirklich passendes....




    Grüße

  • Plug B müsste korrespondieren mit der Belegung des Steckers an der A32.

    Schaltplan aus Buch hast Du mal gepostet. Da siehst Du die Funktionen der Belegung.

    Weiter hast Du mal eine I/O-Liste Roboter-seitig gepostet.

    Mit diesen beiden Belegungen und den schon verdrahteten Belegungen solltest dies evtl. hinkriegen.


    Bei Kabel 110 bist Du sicher X80? Wenn X90, wäre es 0V für die + / - 15V Speisung der beiden Analog-Ausgänge.


    Hab selber keine Pläne mehr für deas Welding Equipment.


    Evtl. kannst Du mal "RoboWeld" im " https://www.robot-forum.com " ankicken. Der könnte evtl. noch was haben S2 / IRB6 / MHA 160LC / LAH 500R / A32 / MED44R.


    Gruss SJX

    Manche Maenner bemuehen sich lebenslang, das Wesen einer Frau zu verstehen. Andere befassen sich mit weniger schwierigen Dingen z.B. der Relativitaetstheorie.

  • Ok ich glaube am besten warte ich auf die Industriestecker die ich gekauft habe um dann direkt alles richtig zu verkabeln bevor ich das ganze nun noch 3 mal mache ^^

    Habe hierfür Harting Multipin Stecker gekauft, die sind nicht ganz so klein wie die anderen Stecker bei den ganzen Kabeln... und die haben Schraubklemmen und müssen nicht gecrimpt werden.


    wenn ich dann damit nicht zurecht kommen sollte werde ich den RoboWeld mal anhauen, vielen Dank schon mal für den Tipp.


    Gruß

  • moin,


    Was mir gerade einfällt.... was ist denn ein Labod und woran erkenne ich den und wo könnte der sitzen?


    Also Tische hatte ich ja nicht die musste ich selber bauen. Ich hatte lediglich die Positionierer.


    Grüße

  • Labod waren alte Gleichstrom-Antriebsverstärker. Waren eine Kombination aus Netzteil separat, Verstärker separat, und kleines Rack mit Einschubkarten.

    Waren früher verbaut im sogenannten Orbit-Steuerschrank. Schwarzes Gehäuse, ca 20cm hoch, ca. 6cm breit, ca. 20cm tief. Leider kein Photo mehr gefunden des Verstärkers. Control Rack, Bild: https://surplus.motionconstrai…s-8307bs-342427-00b-used/



    Wieso Thema Labod-Modul?

    Du hast Schaltpläne dieser Module gepostet.

    Heisst nicht, dass Du hast! Deine Doku ist ja was und eben doch nichts.


    2 Drehachsen werden ja, wie es wirklich aussieht, von dem Antriebsverstärker der 6. Achse der S2 angesteuert.

    Ob Du sonst noch was hast, wie ein Interchange (Stationswechsel), weiss ich nicht.


    Aus dem Standardprogramm von ESAB Schweden sind Deine Positionierer vermutlich nicht (Orbit A,B,C,D,H,L,R)

    Manche Maenner bemuehen sich lebenslang, das Wesen einer Frau zu verstehen. Andere befassen sich mit weniger schwierigen Dingen z.B. der Relativitaetstheorie.

  • Nabend,


    ok ne sowas habe ich tatsächlich nicht.


    Also ich habe noch ein Diagramm gefunden wo die Verkabelung von dem Schweißgerät drauf ist....

    ich werde morgen mal ein zwei Kopien davon anhängen und dann auch eine Liste einfügen auf der ich meine Verkabelung aufführe.

    Du könntest dir das ja dann eventuell mal anschauen und deine Meinung dazu äußern bzw wenn du dann weißt welches Kabel wo aufgelegt wird wäre ich äußerst dankbar.

    Das ein oder andere hat aber auf jedenfall schon funktioniert.


    Achso dort steht auch etwas zu den Common Drive antrieben drauf also Anschluss technisch.


    grüße

  • Moin

    so ich füge hier mal alles bei was von ESAB zusammen in einem Heft lag, vielleicht bringt uns das weiter.

  • Auf der Datei Scannen 004 habe ich drauf geschrieben welches Kabel ich womit verbunden habe.


    Also Datei Scannen009 mit dem ESAB A32 Drahtvorschubkoffer.




    Kabel am Roboter PLUG B

    98 = -15V TO ROBOT

    91= +15V TO ROBOT

    90= 0V ( ELECTRONICS)

    89= REF WIRE FEED

    88= 0V (ELECTR. ROBOT)

    87= REF WELD POW SOURCE

    110=

    45=

    89/85= EM STOP TO ROBOT

    64 (kabel im Roboter nicht vorhanden) = EM STOP TO ROBOT

    103=

    104=

    101=

    102= WELDING CURRENT

    99= INHIBIT PROCESS

    96= GAS

    86=

    100= INHABIT WEAVING

    94=

    93= SPATTER CLEANING
    151= WELD POW SOURCE

    108=

    105/106=

  • Typische Meldung, wenn Du Instruktion einfügen willst, wo die Zeile und vorallem die nachfolgende schon belegt ist.

    Nur am Ende des Progs generiert er dir automatisch eine neue freie Zeile.

    Wenn Du was einfügen willst z.B. zwischen 5 und 10, musst Du zuerst eine freie Zeile einfügen aus dem f>f Menü.


    Wen ich mal Zeit habe schaue ich mal nach der Verdrahtung. Braucht Zeit. Ist nicht gleich selbsterklärend und passt sicher auch nicht alles zusammen.

    Schaltpläne waren immer so ne Sache bei den Leuten aus Laxa im nirgendwo in Schweden......


    Gruss SJX

    Images

    Manche Maenner bemuehen sich lebenslang, das Wesen einer Frau zu verstehen. Andere befassen sich mit weniger schwierigen Dingen z.B. der Relativitaetstheorie.

  • Ah ok, klar klingt logisch....


    Dann stellt sich mir nur die Frage wie ich ein komplett neues Programm schreibe denn ich habe schon einiges auaprobiert also wie es im S3 Programmieren drin steht in dem Buch hab es aber noch nicht geschafft.


    Wollte nämlich schon Mal einfach ein wenig Rum probieren aber es ist mir etwas komplizierter als die roboter mit denen ich Mal gearbeitet habe. Also was heißt komplizierter... Ich denke Mal es ist genauso einfach, nur ist es eine andere Steuerung und wenn man weiß wie dann ist es leicht.


    Grüße

  • Alles gut habe es schon gefunden und auch schon Mal aus Spaß ein Programm geschrieben und siehe da funktioniert 😁😁 supi dann werde ich Mal ein wenig lernen!


    Ich hoffe dass ich nun auch noch das mit dem Schweißgerät und den positionierern hinbekomme und dann kann es los gehen 😁 Dank deiner super Hilfe 💪👍


    Das mit den Kabeln Guck dir in Ruhe an das bedarf glaube ich auch ein wenig Zeit.



    Die einzige Frage die ich noch hätte wäre wie ich die Geschwindigkeit zwischen den Schweißprozessen also quasi die normale Verfahrgeschwindigkeit veränder? Auf "V%" also Velocity wird die Geschwindigkeit ab 100% nicht mehr schneller aber der roboter selber kann definitiv viel schneller....


    Gibt es da noch eine Einstellung wo man die maximalen mm/s verändern kann ? Oder sowas


    Grüße

  • So als Bsp. von dazumals, wie der Grundaufbau des Progs beginnt.


    PROGRAMM 0


    10 KOMMENTAR HOMEPOSITION FAHREN

    20 V=1000.0 MAX=2500.0

    30 TCP 1

    40 KOORDV 0

    50 POS V=100.0% REFPUNKT AUS

    60 ROBOT KOORD

    70 POS V=100.0% ZONE_1

    80 RETURN


    Zeile 10 möglich auch ein Kommentar zu Schreiben für was das Prog ist.

    Zeile 20 vorderes V gibt Speed bei Override 100 vor, MAX. ist bei Override 400. PHG MUSS eingelegt sein in PHG-Fach! Sonst reduzierter Speed.

    Zeile 30 Tool Center Point aktivieren, bei Dir wäre dies schlussendlich Drahtspitze

    Zeile 40 nichts anderes als Koordinatenverschiebung ausschalten

    Zeile 50 möglicher eingeschalteter Referenzpunkt, wo sich Folgepositionen darauf beziehen könnten, ausschalten

    Zeile 60 Achsspezifisches Verfahren

    Zeile 70 Normaler Punkt mit Geschwindigkeitsbezug auf Zeile 20. geteacht übers Positionsmenü links oben. Normal fürs Hin-und Wegfahren von den Schweissnähten.

    Zeile 80 Rücksprung / Verlassen des Progs.



    Gruss SJX

    Manche Maenner bemuehen sich lebenslang, das Wesen einer Frau zu verstehen. Andere befassen sich mit weniger schwierigen Dingen z.B. der Relativitaetstheorie.

  • Hallo Ennsen,


    hab mal versucht Deine offenen Punkte zu benamsen anhand Deiner Unterlagen.

    Es gibt zwar Widersprüche, vor allem mit Zeichnung Kabel Plug B / Plug F und deren Bezeichnungen.

    Schaltplan 411393 sollte mindestens was Verdrahtung und Funktionszuordnung passen, Steckerbezeichnungen an der A32 sind sicher nicht Standard.

    Hoffe es hilft Dir.





    Manche Maenner bemuehen sich lebenslang, das Wesen einer Frau zu verstehen. Andere befassen sich mit weniger schwierigen Dingen z.B. der Relativitaetstheorie.

  • hey,


    Ok habe das alles mal geprüft und geändert....


    Also bei inhinit Weaving und Process, leuchtet jeweils eine Lampe auf der DSDX110 , Lampe 11 und 12 sobald am schweißgerät betätigt wird.


    Wo soll ich WELD. EQUIPMENT READY anschließen?


    108 und 105/106 verstehe ich nicht....


    Wo habe ich GAS WATER FLOW am A32?


    Ist bei 88 0V (24V-SYST) gemeint oder 0V ( ELECTR.) ROBOT ?


    Hätte sonst auf 90 und 88 0V (Electronics)


    Wo im Roboter bekomme ich die 24V her? Für das schweißgerät.


    Ich kann nicht ganz bei allen Anschlüssen folgen da du andere Bezeichnungen genommen hast als auf dem A32 Plan stehen....


    Grüße

  • Ah sorry,


    hab da etwas durcheinander gebracht...



    aber die Fragen bleiben trotzdem noch :D


    88 und 90 müssen noch mit "0V (ELECTRONICS)" und " 0V (24V-SYST)" verbunden werden... Oder ist das hierbei egal wer wo aufgelegt wird? Weil von beiden Kabeln aus 0V kommen ?



    "WELD EQUIPMENT READY" auf welches Kabel am Plug B?


    Und dann noch über welches Kabel kommen "+24V FROM ROBOT"


    Und Nummer 108 verstehe ich nicht.


    An 105/106 habe ich nun "0V (ELECTR. )ROBOT"


    Vielen Dank für deine Hilfe:D


    Grüße

    Edited once, last by Ennsen ().