CycleOn Problem

  • Hallo zusammen,


    ich hab folgendes Problem.
    ich stoppe über die SPS ein Programm, der Roboter bleibt stehen, der CycleOn kommt jedoch erst mit einer Verzögerung von ca. 2 Sekunden.
    Durch diese Verzögerung habe ich ein Überwachunsgsproblem in der SPS.
    Ich habe mit dem Eingang der SPS probiert, den Roboter mit Stop, SoftStop, und QuickStop zu stoppen, jedoch ist kein unterschied festzustellen...
    Ich habe nun bei anderen Robotern nachgeschaut, wenn die ein Stoppsignal bekommen, dann kommt der CycleOn sofort! (QuickStop ist dort programmiert)


    Wenn ich am FlexPendant die Stopptaste drücke, wärend ein Programm läuft, ist es dass gleiche Problem!


    Wenn ich ein Programm stoppen will dann sofort, und nicht mit 2 Sekunden Verzögerung...


    An was liegt dass, das der CycleOn verspätet kommt? Gibt es irgend eine Systemvariable o.ä.??



    Danke schon mal
    Gruß

    Edited once, last by lutze ().

  • KUKA Handwerk
    Anzeige

  • Wenn ich am FlexPendant die Stopptaste drücke, wärend ein Programm läuft, ist es dass gleiche Problem!


    Was hast Du für eine RW-Version? Die letzten 5.1X waren etwas trödelig in dieser Hinsicht. Da kam es manchmal auf die Last an, die das System sonst so hatte. Beim Flex-Pendant möglichst alle Fenster schließen (ausser Produktion) hat mir da schon mal weitergeholfen (ungelogen!). RobotStudio auch abklemmen.
    Dann gibts da m. W. tatsächlich eine Systemvariable, welche die Rechenlast beeinflusst, indem die Auflösung des Pfades verändert wird (was sich natürlich auf die Bahngenauigkeit auswirken sollte). Mit letzterer habe ich aber keine Erfahrung.


    Grüße,
    Michael

  • Hi,


    verwendest Du evtl. eine Ereignisroutine für das Stop-Event?
    Dieses könnte ggf. das Stoppen des Programms verzögern.


    Mfg
    Micky

    Probleme kann man niemals mit derselben Denkweise lösen, durch die sie entstanden sind. (Albert Einstein)

  • Der Fehler war, dass in der Ereignissroutine 2 Stop-Events programmiert waren, diese aber nirgends im System aufgerufen wurden!


    Danke für eure Antworten.


    MfG

  • Äh - Vorsicht bitte (wenn ich Dich jetzt nicht falsch verstehe). Ereignisroutinen auf das "Stop"-Event haben ja eben den Sinn, nirgends im System aufgerufen werden zu müssen, sondern nur bei einem "Stop" - wodurch auch immer - vom System getriggert zu werden.
    Und wenn sowas programmiert wurde, dann hat sich wahrscheinlich der, der das programmierte, etwas dabei gedacht. Nicht, dass jetzt was kaputtrepariert wurde....


    Grüße,
    Michael

  • Gedacht wurde dabei glaube ich nichts...
    Mein Vorgänger hat von einer anderen Steuerung alles Mögliche kopiert...


    Jetzt ist jedenfalls alles i.O.. also sollte es schon so passen.


    mfg

Hilfe und Support für ABB Roboter Programmierung, Konfiguration, Inbetriebnahme finden Sie hier im ABB Roboter Forum. ABB Rapid Programmierung ist einfach, die Roboterforum Community hilft sehr gerne.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now