Screenmaker - eigener Screen reagiert träge

  • Guten Morgen,


    ich habe auf einem IRB 2600-20/1.65 Type B einen selbst erstellten Screen laufen. Wenn dieser einige Zeit geöffnet ist, wird das Felxpendant extrem träge und es dauert ewig bis z.B. die Meldung für den wechsel in den Automatik-Modus kommt. Auch wenn man auf einen Button drückt oder eine andere Seite des Screens öffnen will dauert es. Schließt man den Screen einmal und öffnet ihn wieder ist es wieder für eine ganze Zeit lang in Ordnung. Hat evtl. jemand das gleiche problem, oder evtl. eine Lösung?


    Michael

  • AD
  • was ist denn genau drauf auf dem Screen?
    Welche Robotware Version nutztst du?

  • Hi,

    wir nutzen Robotware 6.07.1011

    Auf dem Screen sind NumericUpDown Felder, DataEditor Felder, Checkboxes und Buttons

    Der Screen besteht aus 31 "Bildschirmen" bzw. 31 Seiten.

    Folgende Funktion können wir damit erledigen.:

    Programme wechseln/Laden

    Bearbeitungsstationen/Greifpunkt korrigieren/nachstellen

  • Gibtes die Möglichkeit zwischen Bildschirmen hin und her zu springen?
    Ich hatte das Problem auch schon mal und das Problem war, dass wenn man zwischen Bildschirmen hin und her wechselt der erste nicht geschlossen wird und sogar wieder als neues Fenster geöffnet wird wenn man wieder auf ihn "springt".

    Wenn man den Bildschirm immer schließt und z.B. auf ein Hauptmenü zurück kommt und von dort aus wieder weiter navigiert geht es. War bei mir zumindest damals so.

  • Gibtes die Möglichkeit zwischen Bildschirmen hin und her zu springen?
    Ich hatte das Problem auch schon mal und das Problem war, dass wenn man zwischen Bildschirmen hin und her wechselt der erste nicht geschlossen wird und sogar wieder als neues Fenster geöffnet wird wenn man wieder auf ihn "springt".

    Wenn man den Bildschirm immer schließt und z.B. auf ein Hauptmenü zurück kommt und von dort aus wieder weiter navigiert geht es. War bei mir zumindest damals so.

    Ja, die Möglichkeit gibt es. Bei verschiedenen Screens, die wieder auf den Startscreen verweisen habe ich Screen.close return to Main-Screen drin.

  • Ok bei mir war es so, dass ich damals direkt eine andere Seite geschlossen hatte. Versuch mal oft zwischen Seiten hin und her zu springen und dann einen Dialog anzeigen zu lassen, so hatte ich damals verifiziert dass es an der Anzahl der geöffneten Seiten lag. Und wie gesagt ich habe dann immer nur das Close verwendet und ab da hatte ich keine Probleme mehr.

    Hast du dir im Verlauf schon mal die CPU Auslastung des Panels angeschaut?

  • Wie schaue ich mir die CPU-Auslastung an?

    Also ich kann sagen, das es auftritt, wenn die Screens lange geöffnet sind. bzw. wenn Sie geöffnet sind wird ja auch zwischen den Screens gewechselt.

    Wenn ich Sie einmal komplett schließe "x" oben rechts. und dann wieder neu öffne ist wieder alles gut.

  • Die CPU Auslastung findest du unter den System Infos unter Softtwareressources im Reiter System und RAPDID.

    Wenn du willst kannst du mir das Projekt auch gerne mal schicken, dann schau ich ob ich etwas finden kann.

Hilfe und Support für ABB Roboter Programmierung, Konfiguration, Inbetriebnahme finden Sie hier im ABB Roboter Forum. ABB Rapid Programmierung ist einfach, die Roboterforum Community hilft sehr gerne.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now