Kinematik erstellen

  • Guten Morgen Zusammen,


    ich muss in RS für eine Simulation ein Roboter-Portal aus 3 Achsen erstellen und einen Positionierer aus 3 Achsen.

    Dazu benötige ich ein 2. Drive-Modul. Mit dem 2. Modul, befindet sich die Steuerung bei Neustart sofort in Systemfehler, Egal wie viele externe Achsen ich anwähle.

    Zudem habe ich das Problem, dass ich nicht alle 3 Achsen in einer Kinematik erstellen kann, da sonst RS abstürtzt. Also erstelle ich anstatt 2 externe Achsen 4 Stück und verbinde die.

    Beim Erstellen einer "virtuellen Steuerung aus Layout" kann ich die externen Achsen nicht auswählen: "Diese Kombination wird nicht unterstützt"....


    Zudem erhalte ich beim Versuch eine Achse zu bewegen, immer wieder den Fehler: "Der Fehler war außerhalb des Arraybereichs"


    Ich hoffe es ist verständlich was ich meine.


    Habt ihr ebenfalls solche Erfahrungen gemacht und Tipps oder Trick 17 für mich?


    Vielen Dank im Voraus für eure Hilfe!


    PS: RW: 6.08; RS: 2019 + 2020


    EDIT:

    Scheinbar hatte ich einen Bug in der Steuerung mit 2 Drive Modulen.

    Beim jetzigen Versuch eine Steuerung mit 2 Drive Modulen über den Installationsmanager zu erstellen, wurde mir die Meldung ausgegeben, dass dies nur mit MultiMove möglich wäre.


    Also auch hier nochmal die Frage: Wie erstelle ich eine Steuerung mit 2 Drive Modulen, jedoch nur einem Robi?


    Danke

    Edited once, last by LB. ().

  • KUKA Handwerk
    Anzeige
  • Ja, bei zwei Drive-Modulen muss die Option MulitMove mit aktiviert werden. Müsstest dann noch entscheidenn welche der beiden Varianten du benötigst.

    Ansonsten könnte man es auch evtl. so lösen dass du das Portal als zusammenhängende Kinimatik definierst, was dann dem Manipulator entspricht.

    Die drei Achsen des Positioniers werden dann als externe Achsen, welches das Drive-Modul ansteuern kann, definiert.

    So hättest du nur ein Drive-Modul und benötigst kein zweites. Allerdings wäre dann wohl der Positionierer keine zusammenhängede Kinematik mehr.

  • Danke für deine schnelle Hilfe.


    Ich habe das Portal neu erstellt. Beim Versuch die 1. Achse zu bewegen, wird mir der Fehler "Exception: Der Index war außerhalb des Arraybereichs" angezeigt.

    Weißt du, woran das liegen könnte?

  • Nein, leider nicht. Ich hatte mal vor längerer Zeit mich auch an der Erstellung von Kinematiken versucht. Musste es dann aber, da andere Projekte wieder wichtiger wurden, aufgeben und habe es nicht weiter verfolgt.

  • Ansonsten könnte man es auch evtl. so lösen dass du das Portal als zusammenhängende Kinimatik definierst, was dann dem Manipulator entspricht.

    Die drei Achsen des Positioniers werden dann als externe Achsen, welches das Drive-Modul ansteuern kann, definiert.

    So hättest du nur ein Drive-Modul und benötigst kein zweites. Allerdings wäre dann wohl der Positionierer keine zusammenhängede Kinematik mehr.

    Guten Morgen,


    könntest du bitte nochmal erläutern wie genau du das meinst?:rolleyes:


    Danke!


    LG

Hilfe und Support für ABB Roboter Programmierung, Konfiguration, Inbetriebnahme finden Sie hier im ABB Roboter Forum. ABB Rapid Programmierung ist einfach, die Roboterforum Community hilft sehr gerne.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now