Benötige ich das 616-1 PC-Interface, um 2 IRC5 mit PickMaster zu verwalten?

  • Hallo sehr geehrte Damen und Herren,



    ich hätte eine hoffentlich einfache Frage, es geht um die Realisierung eines Projektes in PickMaster mit 2 IRC5 (für je 1 IRB360 FlexPicker), 1 Förderband, einem Visionsystem bestehend aus einer Basler Scout sca1300-32gc und natürlich dem Computer, über welchen das ganze Laufen soll.


    Die 2 Roboter + Steuerungen wurden von meiner Hochschule vor längerer Zeit gebraucht gekauft und ich bin der erste der diese nun auch gemeinsam Betreiben muss, da diese davor nur für Vorführungen einfacher Pick and Place Anwendungen genutzt wurden.


    Da ich beide IRC5 nicht über den Service-Port verbinden kann, sondern immer nur einen muss ich über den internen Lan Anschluss (siehe Bild 1) gehen, richtig?


    Dieser funktioniert allerdings nicht, auch mit angepasster IP, Subnetz etc., gelesen habe ich das ich dafür eine Erweiterung 616-1 PC-Interface benötige?


    Auf Bild 2 sind die in meiner Steuerung aktivierten Module zu sehen.


    Jetzt meine generelle Frage, benötige ich um eine PickMaster Linie mit 2 IRC5 zu betreiben dieses besagte 616-1 PC-Interface oder wie richte ich anderweitig mein Netzwerk ein?


    Ich entschuldige meine Unwissenheit es ist das erste Mal, dass ich vergleichbares realisieren muss und viele Dinge sind neu für mich. Deshalb sind auch gern Basis Tipps gesehen, falls ich in anderen Teilen Falsch liege.


    RobotWare Version: 5.13.2039.02

    PickMaster Version 3.56

    Robotstudio Version: 22.2.10013.1


    Edit:
    Man benötigt die Option "Prepared for PickMaster" was man zusammen mit den Lizenzen für PickMaster bekommt.

  • AD
  • Hallo zusammen,

    ich hab das gleiche Problem. ich finde die Steuerung nicht, wenn ich es über den WAN-Port versuche. Die Option PC-Interface ist auf der Steuerung installiert.


    Was muss ich denn noch tun, damit RobotStudio die Steuerung über den WAN-Port findet?


    Grüße

  • Danke :)  DS186


    Robonator hast du denn 616-1 PC-Interface als zusätliche option freigeschaltet ?


    Falls du auch PickMaster verwenden möchtest gibt es scheinbar eine andere option welche genutzt werden muss: "642-1 Prepared for PickMaster".


    Steht natürlich in den Vorraussetzung für PickMaster und ich habs einfach ignoriert/übersehen oder was auch immer.


    Ich werde nochmal Rückmeldung geben sollte mein Problem damit gelöst werden.

  • ArneSt

    Der Hintergrund bei mir ist, ich möchte aus Gründen der Fernwartung RobotStudio auf dem Anlagen-PC installieren. Roboter und PC hängen beide im Profinet. Dann würde ich mich von der Firma aus via TeamViewer auf den Anlagen PC verbinden und dort mit RobotStudio auf die Steuerung zugreifen.

    Profinet ist bei mir auf den WAN-Port parametriert.


    Ich kann zwar vom Anlagen-PC aus die Steuerung via IP anpingen, RS findet die Steuerung aber nicht.

  • ArneSt

    Der Hintergrund bei mir ist, ich möchte aus Gründen der Fernwartung RobotStudio auf dem Anlagen-PC installieren. Roboter und PC hängen beide im Profinet. Dann würde ich mich von der Firma aus via TeamViewer auf den Anlagen PC verbinden und dort mit RobotStudio auf die Steuerung zugreifen.

    Profinet ist bei mir auf den WAN-Port parametriert.


    Ich kann zwar vom Anlagen-PC aus die Steuerung via IP anpingen, RS findet die Steuerung aber nicht.

    Hast du die IP-Einstellungen für WAN-Port in der Boot-Anwendung (X-Start) korrekt konfiguriert? Hast du in RobotStudio alle entsprechenden Möglichkeiten unter "Steuerung hinzufügen" probiert?

  • Hast du die IP-Einstellungen für WAN-Port in der Boot-Anwendung (X-Start) korrekt konfiguriert? Hast du in RobotStudio alle entsprechenden Möglichkeiten unter "Steuerung hinzufügen" probiert?

    Ich habe die Einstellung der IP des WAN's nicht über den X-Start, sonderm im RS gemacht.


    Ich alle Möglichkeiten probiert, leider ohne Erfolg.

  • Starte mal die Boot-Anwendung und schau sicherheitshalber nach, ob auch dort alles passt. Ich würde jetzt mal davon ausgehen, aber sicher ist sicher. Mit einem korrekt konfigurierten WAN-Port und dem PC im selben Netz sollte es eigentlich funktionieren. Das mache ich bei vielen Anlagen nicht anders.

  • Starte mal die Boot-Anwendung und schau sicherheitshalber nach, ob auch dort alles passt. Ich würde jetzt mal davon ausgehen, aber sicher ist sicher. Mit einem korrekt konfigurierten WAN-Port und dem PC im selben Netz sollte es eigentlich funktionieren. Das mache ich bei vielen Anlagen nicht anders.

    Danke schonmal für die Unterstützung.



    Das sind die aktuellen Einstellungen der Boot-Anwendung.

    Diese IP hier hat aber nix mit der IP der Profinet-Schnittstelle zu tun, oder versteh ich es gerade falsch?

  • Hier musst du den unteren Punkt aktivieren und die passende IP-Adresse eingeben. Also in deinem Falle die Profinet-IP. Dann klappts auch..

    Dadurch lauscht die Steuerung dann auch auf dem "richtigen" Port.

    Ich hab passend umgestellt, leider ohne Erfolg :(

  • So, wie versprochen. In der Boot-Anwendung musst du für den WAN-Port, wie bereits von Potte1604 geschrieben, eine feste IP-Adresse einstellen. Da du PROFINET und Fernzugriff im selben Netz hast, musst du für den WAN-Port eine IP-Adresse eintragen, welche im Bereich deines PROFINET-Netzwerks liegt, z.B. 192.168.214.51 für den WAN-Port.


    Nach Neustart der Steuerung wird unter Konfiguration > Communication > IP Setting automatisch ein entsprechender Eintrag für das Public Network angelegt.



    Für dein PROFINET musst du dann einen Eintrag mit IP-Adresse und Subnetz jeweils 0.0.0.0 und Interface WAN erstellen. Genau diesen Eintrag musst du dann im EA-Konfigurator für dein PROFINET verwenden.


    pasted-from-clipboard.png


    Die IP-Adresse für das PROFINET muss nun automatisch durch deine PLC zugewiesen werden und muss entsprechend im selben Bereich liegen, wie deine IP-Adresse für den WAN-Port. Mit dem Beispiel von oben wäre das eine Adresse im Bereich 192.168.214.xxx, z.B. .50.

  • Man muss übrigens nicht unbedingt die Boot-Anwendung starten.


    Am Panel unter Systemeinstellungen > Einstellungen > Netzwerk kommt man auf die selbe Kofiguration.

  • Guten Morgen,

    vielen Dank für diese ausführliche Anleitung.

    Ich teste es und werde dann berichten.


    frohes Programmieren :D


  • Guten Morgen,

    ich hab es nun umgesetzt und ich finde die Steuerung nun über Profinet :thumbup:


    Ich bekomm nach dem Neustart der Steuerung aber nun die Meldung, dass sich die IP-Adressen des Profinet Network und des Public Networks überlappen.


    Folgendermaßen sehen meine IP's aus.


    Muss ich hier noch etwas tun?


    Grüße

  • Die Meldung wirst du los, indem du IP und Subnetz für den Eintrag PROFINET Network auf 0.0.0.0 änderst. Deine SPS muss der Robotersteuerung dann die IP-Adresse automatisch zuweisen. In STEP 7 oder TIA Portal ist das lediglich ein Häkchen in der HW-Konfiguration.

    Edited once, last by DS186 ().

  • Du Meldung wirst du los, indem du IP und Subnetz für den Eintrag PROFINET Network auf 0.0.0.0 änderst. Deine SPS muss der Robotersteuerung dann die IP-Adresse automatisch zuweisen. In STEP 7 oder TIA Portal ist das lediglich ein Häkchen in der HW-Konfiguration.

    ah, Danke.


    Hätte ich mal deinen vorherigen Post besser gelesen :D

Hilfe und Support für ABB Roboter Programmierung, Konfiguration, Inbetriebnahme finden Sie hier im ABB Roboter Forum. ABB Rapid Programmierung ist einfach, die Roboterforum Community hilft sehr gerne.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now