X, Y, Z-Achsen

  • Hallo Roboterfreunde

    Ich habe ein kleines Problem.

    Wenn ich meinen Roboter, BJ. 05 von Kuka, starte und mein Testprogramm abfahren lassen, fährt er mir die 3 Punkte bzw. Positionen nicht mehr exakt ab.

    Was ich damit sagen will, die Positionen fehlen bei allen 3 Achsen (xyz) um etwa 3-5mm. Ich bin mit meinem Roboter aber nirgends angestoßen.

    Kann mir jemand von euch bitte da weiterhelfen.

    LG Leon

  • KUKA Handwerk
    Anzeige
  • Hallo


    Ich hatte dieses Problem schon im Dezember 2020, dass mir der Roboter nicht die Punkte richtig abfährt. Da ist zufällig einer von Kuka vorbei gekommen. Mit ihm habe ich über dieses Problem gesprochen, er hat sich auch die Keilriemen angesehen. Die waren ok.

    Die Justage war auch ok. er hat gemeint, dass ich so ein Testprogramm machen soll. Danach habe ich das Testprogramm mit den 3Punkten gemacht. Der Roboter hat diese 3Punkte immer 1a abgefahren. Nur eben dieses Mal nicht. Siehe Foto.

    Der Mann von Kuka hat gemeint, dass es ev. eine Steckkarte oder so hinten beim Roboter sein könnte. Diese Karte speichert Daten.

    Auf den Fotos sieht man die Abweichungen. Im Normalfall sollte der Roboter den Stift genau zum jeweiligen Punkt fahren.

    Das mit dem Archivieren; der PC meines Roboters nimmt nur Floppy-Discs. Er hat mir die USB Speicherkarte nicht genommen. Mal sehen.

    Danke für eure Hilfe.


    lg Leon

  • Hallo,


    dein Roboter hat hinter dem seitlichen Deckel der ZH 2 Riemen und hinten an den Handachsmotoren Riemen. Mach mal den seitlichen Deckel der ZH auf. Evtl. hast du da Ölverlust nach innen => dann gehen die Riemen auch kaputt. Die hineren Riemen kann man sich anschauen wenn man die Plastikstopfen entfernt.

    Die Karte heißt RDW (Resolver Digital Wandler), wenn die spinnt hättest du den Roboter neu justieren müssen.

    Justage wurde von dir schon geprüft, oder?

    Sieht ja schon fast so aus als wäre dein BASE verschoben. Ohne Programm kann man nur die Glaskugel nehmen.

    Andere Lastdaten wären auch möglich => falsches Tool mit gleichem TCP aber anderer Last.


    Wie gesagt braucht man Glaskugel. Leider ist meine Glaskugel ist zur Reparatur.

    Evtl. hat ein anderer hier im Forum seine Betriebsbereit.;)


    Gruss

    Martl

  • Gegen Disketten ist nichts einzuwenden, und externe Floppy-Laufwerke für USB für Deinen Computer gibt's ab 15€. Wo liegt denn das Problem?

    Zweieinhalb einfache Checks reichen auch, um die Sorgen weiter einzugrenzen.

    Der erste Check wäre: sind die Abweichungen konstant - bekäme man die Punkte wieder übereinstimmend, wenn man das Testgestell verschieben würde? Wenn ja, dann ist der KUKA unschuldig an Deiner Misere.


    Und der zweite Check: wenn man um die "Stoßrichtung" des hoffentlich eingemessenen Tools dreht, bleibt dann die Fräserspitze an Ort und Stelle oder macht die irgendeine Bewegung? Wenn Letzteres, dann mag es ein Problem mit der Justage geben, was man dann mit Check No. 2komma5 rausbekäme:


    Man misst einfach ein neues Tool ein, am besten mit einer Spitze, die dort ist, wo die (zu ungenaue) Fräserspitze jetzt ist. Wenn man dann mit diesem Tool den Test 2 versucht bzw. wenn das erst gar nicht geht, weil die Abweichungen während des Einmessens zu groß sind (die angezeigten Fehlerwerte vor dem Abspeichern des Tools), nur DANN hat man ein Justageproblem.


    Ansonsten ist einfach anzunehmen, dass entweder das Gestell verrutscht ist oder das HANDwerkzeug in der Aufnahme.

    Zumindest weiß man anschließend das.


    Grüße,

    Michael

  • Servus,


    wir haben noch den Programmfehler nicht ausgeschlossen. Ohne Backup gehts auch nicht.

    Ich Tipp da schon eher fast auf ein Programmproblem.


    @ Leon: Hat der Roboter die Justage verloren => und wurde er evtl. ohen EMT/Messuhr justiert

    Aufgrund deiner Fragen gehe davon aus du hast nur rudimentär Wissen vom KUKA hast.

    Glaskugel "EIN"

    Abweichung könnte auch kommen das der Roboter auf den Vorjustagemarken justiert wurde.

    Glaskugel "AUS"


    Ist kein ABB der auf den Markierungen mit "Umdrehungszähler aktualisieren" auskommt.


    Gruss

    Martl.

  • Hallo Martl


    Ich habe 2011 einen Grundlagenkurs für KUKA Roboter in Linz gemacht. Es hat für meine Arbeit mit dem Roboter immer gereicht. Nur wenn die totalen Fachbegriffe kommen, da kenn ich mich nicht mehr aus.


    Die Justage wurde das letzte Mal 2019 gemacht(vom Servicemann). Bitte nicht lachen, aber es hat bis Dezember 2020 immer alles funktioniert. Und ich benötige den Roboter nicht jeden Tag. Sollte keine Ausrede sein.

    Das Gestell und die Halterung mit dem Fräser habe ich kontrolliert. Alles fest.

    Was meinst du mit Programmproblem? wie kann ich das kontrollieren?#


    lg Leon

  • Servus,


    hier wird nicht gelacht. ;)

    Programmierung generell:

    z.B. Baseverschiebung, autom. TCP Korrektur, man. TCP Korrektur, Punktberechnungen usw.

    Ohne Programm kann man da nichts ausschließen was zu einem vermeintlichen Fehlpositionieren des Roboters führt.

    BTW. Sockel des Roboters ist auch fest => alles schon gesehen


    Gruss

    Martl

  • Man sieht an den Bildern dass es sich auch um eine HA Maschine handeln könnte. Ist das so? Versatz in Größenordnung 3-5 mm könnte da auch von der Absolutgenauigkeit kommen. Ist die Absolutgenauigkeit an? Sind die Lastdaten im Fehlerfall noch wie sie sein sollen?


    Fubini

  • Servus,


    meistens hat der Roboter auch noch den Aufkleber dran "Absolutvermessen" wenn er nicht abgefallen ist.

    Ums genau zusagen ob der Roboter Absolut ist oder nicht und ob das Absolute aktiviert ist braucht man wieder ein Backup.

    Es müsste dem Roboter auch eine Diskette (CD) beiliegen mit den Absolutdaten.


    Gruss

    Martl

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now