Sporadisch Edit_gesana unzulässig

  • Hallo zusammen,


    Ich habe aktuell bei einem Roboter das Problem, dass wenn ich die Config Dat übertragen möchte immer angezeigt wird es ist nicht möglich und am Roboter der Fehler kommt: edit_gesana unzulässig.


    Das komische daran ist, dass wenn ich den Roboter neu gestartet habe kann ich problemlos die Config.dat übertragen. Sobald ich das Programm das erste mal durchlaufen lassen habe geht es nicht.


    Jemand ne Idee was das sein könnte?


    Es ist ein neuer Roboter, Softwarestand kann ich gerne morgen durchgeben.


    Vielen Dank im voraus :)

  • AD
  • Hi,


    das ist ganz logisch.

    Sobald ein Programm angestartet wird, wird $Config.dat gebunden und ist daher schreibgeschützt und kann daher auch nicht überschrieben werden.


    Im Navigator (als Experte angemeldet) kannst du das sehen.


    bei $config.dat ist ein Kettensymbol sichtbar - schreibgeschützt


    Allerdings musst du nicht neu starten, sondern kannst den submit zunächst stoppen und dann abwählen. Damit wird der Schreibschutz aufgehoben und du könntest überschreiben



    jetzt fehlt das Kettensymbol. Nach dem Ändern muss der submit wieder angestartet werden.


    Bei Rückfragen stehe ich gerne zur Verfügung


    mit freundlichen Grüßen


    MOM

  • Soo logisch finde ich das nicht.

    Der SPS.sub sollte auch gleich nach dem Hochlauf laufen, und die $config.dat also auch gebunden sein.

    Durch das Anstalten eines 'normalen' Programms (nicht Submitinterpreter), wie beschrieben wird normalerweise am Zustand des Submitinterpreters nichts geändert.

    Einen Versuch ist die Methode trotzdem wert, auf alle Fälle auch noch das aktuelle Programm abwählen.

  • Hi,


    du hast natürlich recht;)!


    Ich habe es nur kurz mit der KSS 8.6 angetestet (ohne das Überschreiben auszuprobieren)


    Hier ist natürlich das Kettensymbol ausschlaggebend! Du kannst ja mal nach dem Hochfahren dir das anschauen.


    Es sollten auf alle Fälle alle Programme (Submit und Robot) und keine SetInfos aktiv sein!


    mit freundlichen Grüßen


    MOM

  • Wenn vor dem Übertragen der config.dat alle aktiven Programme abgewählt wurden, dann sollte es funktionieren. Der SPS.sub muss dazu nicht abgewählt werden.


    Gruß

    Daniel

    Also ich stimme da eher MOM zu. ich wähle auch jedes Mal den Sub.sps ab damit es funktioniert. Mit angewähltem sub.sps bekommt man genau solche Meldungen.


    Grüße

  • Also ich habe hier aktuell mehrere KR C4 mit KSS 8.5 und habe dort unzählige Male die config.dat verändert und übertragen. Den SPS.sub musste ich nie händisch abwählen. Kann natürlich sein, dass der SPS.sub bei Übertragung abgewählt/gestoppt und danach neu gestartet wird.


    Gruß

    Daniel

  • Kann natürlich sein, dass der SPS.sub bei Übertragung abgewählt/gestoppt und danach neu gestartet wird.

    Das ist das Verhalten beim Übertragen eines Projekts.


    Zu Problemen kann es kommen, wenn eine Variable noch irgendwo gebunden ist. Zum Beispiel wenn die Variablen-Übersicht, oder sonstige Fenster geöffnet sind.


    Sollte nicht die Regel, sondern eher die Ausnahme sein, dass man händisch ab- und wieder anwählen muss.

  • Sollte nicht die Regel, sondern eher die Ausnahme sein, dass man händisch ab- und wieder anwählen muss.

    Ich hab au öfters mit dem Daimler-Standard Dai-Powertrain zu tun und diese versauen das System ganz ordentlich.

  • Ich hab au öfters mit dem Daimler-Standard Dai-Powertrain zu tun und diese versauen das System ganz ordentlich.

    Ja, da sind dann ausser dem config.dat auch einige weitere Dateien gebunden. Das ist eh schlechter Stil, und verhindert manchmal sogar ganz normale Änderungen, auf dem Roboter selber in einem angewählten Programm.

    Ganz böse Falle.

  • Hallo.


    um auf der sicheren Seite zu sein, sollte meine letzte Post (#4) beherzigt werden.


    Es gibt natürlich Ausnahmen, wie hier an anderer Stelle beschrieben.

    Meiner Meinung nach sollte man vom "Worst Case" und nicht vom "Best Case" ausgehen.


    Letztendlich liegt die Entscheidung bei euch


    mit freundlichen Grüßen


    MOM

  • Hallo zusammen,


    Vielen Dank für die vielen Antworten. War jetzt im Urlaub und konnte daher nicht testen :) ich probiere mal wenn die Anlage steht ob es mit abgewählten Programmen geht.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now