Digitaler Eingang von externer Quelle wird nicht angenommen

  • Hallo zusammen,

    ich habe einen UR5e und würde gerne das Signal eines KUKA Roboters als Bedingung für weitere Befehle einbinden.
    Am KUKA kann ich digitale Ausgänge schalten. 0V=FALSE / 24V=High (tatsächlich sind es 25,25V).

    Nun wollte ich den digitalen Ausgang vom KUKA direkt mit einem digitalen Eingang an der UR Steuerung verdrahten.
    Aus mir unerklärlichen Gründen erkennt die UR Steuerung aber diesen Eingang nicht. Sprich er bleibt auf FALSE.

    Die IO's von KUKA und UR haben die selbe Masse.


    Woran könnte es liegen, dass sich der UR den Eingang nicht erkennt?

    Wenn ich die 24V direkt von der UR Steuerung auf den Eingang brücke, wird ein Eingang erkannt.


    Vielen Dank im Voraus

  • Ich habe keine Glaskugel mit integriertem Messgerät, aber ein Koppelrelais oder Optokoppler wird dir sicher weiterhelfen.

    Die Abnahme von "GOTO" Anweisungen verhält sich reziprok zur Qualität einer Programmierung

  • Mit Relais oder Optokoppler wäre natürlich eine Möglichkeit, eine Umsetzung mit nur einer Leitung wäre jedoch deutlich einfacher.
    Trotzdem danke für die schnelle Antwort.

  • Digitale Eingänge bei Robotern direkt zu verdrahten stellt meist ein Problem dar.


    Um ein Koppelrelais oder Ähnliches kommt man im Regelfall nicht drum herum wenn man derartige Probleme/Phänomene vermeiden will. Es kann bei derartigen Konstruktionen immer wieder zu Effekten kommen die man nicht will - kurzum: das ganze ist dann alles andere als stabil.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now