KRC2 + Profibus + CP5613/14 lang ist's her...

  • Hallo zusammen, leider ist die SuFu nicht mehr so komfortabel (erweiterte Suche nicht mehr vorhanden) so dass ich aus der Menge an Ergebnissen (KRC2 Profibus) nicht das richtige filtern kann.


    Ich habe hier zwei gebrauchte KUKA's bekommen, KRC2. Diese sollen am Profibus mit einer SPS kommunizieren. Beide Robies sollen nur im Slavebetrieb arbeiten. Hier mal nur exemplarisch für einen der beiden Robies:

    KUKA KRC V5.5.13

    #KR200L140


    Nachdem ich in der Doku zur CP5613/14 nachgelesen habe kann ich die pfbmsl.ini wie folgt beschreiben:

    iosys.ini


    Sollte meiner Meinung nach passen. Jedoch bekomme ich die Meldung: 6503, Fehler Konfiguration E/A-Treiber PBMASL

    Wenn ich dann rekonfigurieren möchte erscheint: 102 E/A Rekonfigurierung fehlgeschlagen

    Aktuell ist der Bus noch nicht angeschlossen da die Elektrik noch nicht soweit ist. Mir ist so als müsse der Endwiederstand am Stecke "OFF" sein, richtig? Welchen Port an der CP5613/14 muss ich benutzen: X850 oder X851.


    Es wäre toll wenn mir jemand etwas Hilfestellung geben könnte. Herzlichen Dank im Voraus!

    Den Roboter "in seinem Lauf hält weder Ochs noch Esel auf!"

  • Hallo AtoK09,


    ich habe gerade mal bei einem unserer Roboter nachgeschaut. In der pfbms.ini ist bei mir der Slave Teil etwas anders.


    [SLAVE]

    MODUL_USED=1

    MODUL_ADDRESS=19

    ;START_TIME=20

    ERROR_ACTION=0

    STANDBY=1

    SLAVE_TIMEOUT=0

    CHECK_CONFIGURATION_DATA=0

    ACCEPTABLE_INPUT_LENGTH=244

    ACCEPTABLE_OUTPUT_LENGTH=244

    IO_DATA_BASE=1 --> Auch anders, bei uns wird aber word verwendet. Sollte bei dir also passen.

    CONSISTENCE=0


    Grüße

    Peter

    Wer Rechtschreibfehler findet, darf sie behalten!!!  :lol:

  • Abschlußwiderstände nur am Ende der Leitungen on. Sonst überall off.


    Der Slaveanschluß war der "untere" der beiden Ports der 5614 soweit ich mich erinnere. Also der, der mainboardseitig ist.


    Anbei die Erläuterung zum Slavemodul

    KALTSTART durchführen nach Änderung der pfbms.ini, sonst wunderst Du Dich...

    Merke: "BOOT TUT GUT"


    Wolfram (Cat) Henkel

    never forget Asimov's Laws at the programming of robots...

    "Safety is an integral part of function. No safety, no production. I don't buy a car without brakes."

    https://www.xing.com/go/invite/5634410.eb15e5

    PMs und Mails mit Anfragen wie "Wie geht das..." werden nicht beantwortet.

    Diese Fragen und die Antworten interessieren jeden hier im Forum.

  • Hallo,


    ich habe bei mir noch eine Doku gefunden. Allerdings im neuen Forum noch nicht die Möglichkeit einer PM.



    Grüße

    Thilbi

  • @p.xartax @hat mir leider nicht geholfen, danke

    WolfHenk wenn wir denn anschließen können werde ich den mainboardseitigen Port nutzen, sowie beide Schalterzustände testen. Mir war nur so, dass ich mich erinnere eben bei KUKA den auf OFF geschaltet zu lassen. Kaltstart, ja - klar ;). Die Erläuterung zum [Slave]-Teil steht ja in der pfmsl.ini! Aber durch nochmaliges lesen habe ich folgendes gesehen

    1. ; STANDBY=1 : Standby mode: ON
    2. ; The slave will stay in standby mode until a master allocates it


    Thilbi : ich habe folgende Doku:

    HARDWARE
    KR C2
    Projektierung

    Profibus CP 5613/14


    Danke erstmal an alle, bin da also noch nicht weiter!

    Den Roboter "in seinem Lauf hält weder Ochs noch Esel auf!"

  • Siehe da, muss nur die richtige Leitung ran gepatcht werden, dann läuft auch der Bus! Dank euch und schönen Feierabend...

    Fehlermeldung trat offensichtlich nur wegen nicht angeschlossener Leitung auf! Viel Rauch um nichts -.-

    Den Roboter "in seinem Lauf hält weder Ochs noch Esel auf!"

  • und wieder beweist sich: Es liegt fast immer am Elektriker!

    Wolfram (Cat) Henkel

    never forget Asimov's Laws at the programming of robots...

    "Safety is an integral part of function. No safety, no production. I don't buy a car without brakes."

    https://www.xing.com/go/invite/5634410.eb15e5

    PMs und Mails mit Anfragen wie "Wie geht das..." werden nicht beantwortet.

    Diese Fragen und die Antworten interessieren jeden hier im Forum.