16. Januar 2019, 02:51:02
Roboterforum.de - Die Industrieroboter- Anwender und Experten Community

 RV-E2 zum laufen bringen


normal_post Autor Thema:  RV-E2 zum laufen bringen  (Gelesen 1226 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

16. April 2012, 15:25:53
Gelesen 1226 mal
Offline

StEr0iD


Hallo,

ich habe zwar zuerst ins englische Forum geschrieben, sehe aber gerade, dass es auch ein deutsches Forum gibt, in dem mehr Benutzer aktiv sind.

Also ich habe folgendes Problem:
Ich soll im Rahmen einer Studienarbeit den Roboter RV-E2 zum laufen bringen.
Der Roboter stand aber eine Weile in einem Lager und wurde dann vergeben.
Jetzt hab ich ihn hier bei mir mit einer motorisierten Hand 1E-HM01, die wohl vor dem wegstellen angebaut und nicht eingerichtet wurde. Teachingbox ist auch vorhanden.

Ich habe jetzt schon die verschiedenen Handbücher durchgelesen und versucht die Z-Phasen zu erkennen und den Nullzustand (Origin) einzurichten. Bis auf das auf und zumachen der Hand ist mir bis jetzt aber nichts gelungen. (Beim Z-Phasen erkennen schreibt die Teaching-Box keine Z in die Zeile, um zu zeigen dass die bewegte Phase erkannt wurde)
Wenn ich den Roboter anschalte bekomme ich 2 unterschiedliche Fehlermöglichkeiten:
1. Er bringt die Fehler 536 (Servo sys. Error) und 1500 (Z marching is not completely)
2. 236 (Encoder error - communication) und 226 (Encoder error - initial)

Da ich gerade heute erst mit dem Roboter angefangen habe, sagen die Fehler mir überhaupt nichts und ich finde auch keine ausführliche Fehlerbeschreibung in den Heften.

Kann da jemand helfen und mir sagen, was die Ursache sein kann?
Woran erkenne ich, dass die Batterien soweit in Ordnung sind? (Bin nicht ganz sicher ob die nicht vor dem abgeben getauscht wurden)

Gut, ich hoffe ich bekomme schnelle und kompetente Hilfe von euch. ;)
Vielen Dank und schöne Grüße.
« Letzte Änderung: 16. April 2012, 15:28:13 von StEr0iD »
  • gefällt mir    Danke

16. April 2012, 16:12:07
Gelesen 1226 mal
Offline

Urmel

Global Moderator
Hallo,

irgendwelche Z-Phasen Probleme waren beim E2 ein typischer Fehler. Ich bin aber schon mit dem E4 "aufgewachsen", der hatte die meisten dieser Macken nicht mehr. Auch habe ich keine Doku zum E2 in Reichweite.

Allgemein gilt bei diesen Typen, je kleiner die Fehlernummer, desto größer das Problem. Daher würde ich mal sagen, die 2xx-Fehler sind ernster. Offenbar findet die Steuerung da mindestens einen Encoder nicht (6. Achse, weil letzte Ziffer ?)

Wenn man mir so ein Teil antragen würde, würde ich mich mit der Firma Ebner Automation in Ratingen in Verbindung setzen, die dürften sich als Servicepartner von Mitsubishi noch damit auskennen. Offiziell ist der Service für diese Serie allerdings bereits ausgelaufen, die Roboter sind seit über 10 Jahren nicht mehr verkauft worden. Der aktuelle Austauschtyp wäre der RV-3SDB.

An den Steckern der Batterien sollte man mit einem Voltmeter und entsprechend kleinen Messspitzen die Spannung kontrollieren können. Wenn sie da länger drin sind als 1 1/2 Jahre, muss man sie sicher wechseln.

Grüße

  Urmel
  • gefällt mir    Danke

25. April 2012, 13:09:22
Gelesen 1226 mal
Offline

StEr0iD


Hallo,

also ich habe mittlerweile alle Kabel usw. überprüft. eigentlich sollte die Kommunikation funktionieren.
Wo kann ich einsehen, welchen aktuellen Winkel die 6. Achse hat? Es könnte sein, dass der Arbeitsbereich überschritten ist, da die Hand keinen mechanischen Anschlag hat. Im Reference Manual steht drin, dass dann solche Encorder-Fehler auftreten können.

Grüße
  • gefällt mir    Danke

25. April 2012, 13:20:43
Gelesen 1226 mal
Offline

Urmel

Global Moderator
Also nach meinem Verständnis ist die 6. Achse mechanisch im Prinzip endlosdrehend.

Der Nullwinkel wird rein softwaremäßig durch Nullsetzen an einer bestimmten Position festgelegt. Dabei musste bei diesem alten Dingern die Steuerung aber erstmal die Z-Phase des Motors einmal gesehen haben. Also, keine Z-Phase => kein Winkel.

Was das Handbuch meint, ist wohl eher, dass man bei ausgeschaltetem bereits kalibriertem Roboter die Achse zu weit oder zu schnell überdreht und deshalb Fehler kommen.

Das sind aber alles Eigenheiten des E2, schon beim E4 gab es das nicht mehr.
  • gefällt mir    Danke

25. April 2012, 13:50:40
Gelesen 1226 mal
Offline

StEr0iD


Hallo,

die Z-Phasen hat er alle erkannt. Das bedeutet ja eigentlich, dass er die Encorder alle ansteuern kann. Aber trotzdem bekomme ich beim starten einen Fehler (226) an der 6. Achse.
Man kann ja im Joint-Modus die aktuellen Winkel einsehen. Allerdings bekomm ich die Umschaltung von den angezeigten W, S und E Gelenken nicht umgestellt auf R, P und T, wo ich ja die aktuellen Winkel sehen müsste. Wie genau stell ich das um? (Ich such am Besten nochmal im Handbuch, falls das jetzt nicht auf Anhieb geht)

Edit: Das Umschalten hat sich erledigt... Einfach eine der Achsen ansteuern ^^

Grüße und danke für die schnellen Antworten.

Nachtrag:
Offensichtlich hat irgendetwas eine Macke an der 6. Achse. Der Winkel im Joint-Modus liegt bei ca. +10000 bis +40000 und springt mal eben ohne jede Bewegung hin und her. Mal wird er größer, mal kleiner. Was kann sowas auslösen??
« Letzte Änderung: 25. April 2012, 14:01:36 von StEr0iD »
  • gefällt mir    Danke

26. April 2012, 08:44:25
Gelesen 1226 mal
Offline

Urmel

Global Moderator

Bei einem neueren Roboter hätte ich erwartet, dass dann eine Fehlermeldung kommt, aus der man schliessen kann, woran das liegt.

Der E2 war das erste Modell mit Drehstrommotoren statt Gleichstromservos. Er kam 1994 auf den Markt, die Technik ist also auf dem Stand von vor 20 Jahren. Auch wenn sehr viele E2 lange im Einsatz waren, ist es wohl auch ein Modell, aus dem die Erbauer gelernt haben, wie es besser geht.

Ich denke da kann nur jemand weiterhelfen, der regelmäßig diese Teile repariert (hat).
« Letzte Änderung: 26. April 2012, 08:50:35 von Urmel »
  • gefällt mir    Danke


Teile per facebook Teile per linkedin Teile per pinterest Teile per reddit Teile per twitter
 

über das Roboterforum

Nutzungsbedingungen Impressum Datenschutzerklärung

Sponsoren des Roboterforums

ROBTEC GmbH