22. April 2019, 10:29:19
Roboterforum.de - Die Industrieroboter- Anwender und Experten Community

 TRIGGER WHEN DISTANCE = 1 DELAY = 0 DO... kommt zu früh


normal_post Autor Thema:  TRIGGER WHEN DISTANCE = 1 DELAY = 0 DO... kommt zu früh  (Gelesen 2045 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

11. Februar 2019, 11:46:18
Gelesen 2045 mal
Offline

CHLINDE


Hallo,

kennt jemand die Situation, dass ein Triggersignal im T1 zu früh ausgelöst wird?

Folgender Programmcode:

TRIGGER WHEN DISTANCE = 1 DELAY = 0 DO I_Position=2
SPTP Typ55490222_InputS_PP CONT Vel=100 % PDAT1 Tool[1]:B-Side Base[1]:Anlage;
TRIGGER WHEN DISTANCE = 1 DELAY = 0 DO I_Position=1
TRIGGER WHEN DISTANCE = 1 DELAY = 0 DO ClampBSide_A100=TRUE
SLIN Typ55490222_InputS_WP Vel=0.1 m/s CPDAT1 Tool[1]:B-Side Base[1]:Anlage;

Ich fahre die Positionen im T1 ab. Bei Erreichen des Punktes "Typ55490222_InputS_PP" wird in manchen Fällen, also auch nicht reproduzierbar, das Signal "ClampBSide_A100" schon true gesetzt, obwohl das erst bei Erreichen des Punktes "Typ55490222_InputS_WP" erfolgen soll. Dadurch donnert der hydraulische Spanner zu und die Vorrichtung ist verbogen  :twisted:
Im AutExt-Betrieb scheinen diese Probleme nicht zu bestehen.
Kennt jemand dieses Phänomen?

Gruß

CHLINDE
  • gefällt mir    Danke

Heute um 10:29:19
Antwort #1

Werbung

Gast

11. Februar 2019, 13:14:20
Antwort #1
Offline

panic mode


  • gefällt mir    Danke

12. Februar 2019, 08:14:05
Antwort #2
Offline

CHLINDE


  • gefällt mir    Danke

13. Februar 2019, 05:13:17
Antwort #3
Offline

panic mode


  • gefällt mir    Danke

13. Februar 2019, 19:11:46
Antwort #4
Offline

Roland Keller

Administrator

Und bei welcher dieser 40 Versionen funktioniert dann der Trigger im T1-Modus nicht?
Mir ist keine Version bekannt.
  • gefällt mir    Danke
-------------
Gruß
Roland

Wie poste ich falsch?
Nachdem ich die Suche und die FAQ erfolgreich ignoriert habe, erstelle ich das gleiche Thema in mehreren Unterforen, benutze einen sehr kreativen Titel wie "Hilfe", am Besten noch mit mehreren Ausrufezeichen, und veröffentliche einen so eindeutigen Text, dass sich jeder etwas Anderes darunter vorstellt.

Ich bin wie ich bin. Die Einen kennen mich, die Anderen können mich.
Konrad Adenauer

Heute um 10:29:19
Antwort #5

Werbung

Gast

14. Februar 2019, 02:09:20
Antwort #5
Offline

panic mode


Dir vieleicht nicht aber dass ist kein Wunder... normallerweise so was kommt nur selten vor.
Ich habe's auch nicht geglaubt bis Ich es geschaft habe das Problem zu reproduzieren (durch gezielte Versuche).
Es passiert nur in bestimmten Bedingugnen und - leider nicht nur im T1.

Das Problem is mitlerweile behoben...

rede mit Kuka (und habe exakte KSS Version)
« Letzte Änderung: 14. Februar 2019, 02:38:12 von panic mode »
  • gefällt mir    Danke

14. Februar 2019, 06:26:08
Antwort #6
Online

fubini


Hallo,

Hast du mal probiert den analogen PATH-Trigger zu verwenden. Spline hat eigentlich keinen DISTANCE-Trigger mehr, sondern immer nur den PATH-Trigger. Der Bequemlichkeit für die Anwender halber, wird ein Distance Trigger beim Spline intern in einen äquivalenten PATH-Trigger umgerechnet. Da kan bei der Umrechnung durchaus was schief gehen, daher würde ich es mal mit dem entsprechenden PATH-Trigger probieren.

Fubini

22. Februar 2019, 11:36:48
Antwort #7
Offline

Mott_Hebbet


Moin,

wie ist das hier jetzt ausgegangen? Das wäre interressant zu wissen.

Grüße
Mott
  • gefällt mir    Danke
Vielen Dank für die Auskunft.

Wer Rechtschreibfehler findet, darf sie als Lohn behalten.

26. Februar 2019, 12:42:40
Antwort #8
Offline

CHLINDE



Ich werde das mal probieren!

Leider ist es tatsächlich so, dass man das Problem nicht reproduzieren kann. Es geht 10x gut und beim 11. Mal fahre ich die Position wieder an und plötzlich fährt der hydraulische Spanner schon zu, obwohl der Roboter noch voll in der Fahrbewegung ist. Dabei zerreißt es mir meistens den Prüfling und manchmal auch die Vorrichtung.
  • gefällt mir    Danke

Heute um 10:29:19
Antwort #9

Werbung

Gast

26. Februar 2019, 14:02:01
Antwort #9
Offline

SJX

Global Moderator
Hallo CHLINDE,

wieso unbedingt Trigger in dieser Situation, wenn's so wichtig ist ?
Sieht so aus, als dass Du stehen musst bei schliessen des Zylinders.
Also ganz konventionell Ausgang setzen mit Vorlaufstop nach Punkt.

Gruss SJX
  • gefällt mir    Danke
Manche Maenner bemuehen sich lebenslang, das Wesen einer Frau zu verstehen. Andere befassen sich mit weniger schwierigen Dingen z.B. der Relativitaetstheorie.


Teile per facebook Teile per linkedin Teile per pinterest Teile per reddit Teile per twitter
 

über das Roboterforum

Nutzungsbedingungen Impressum Datenschutzerklärung

Sponsoren des Roboterforums

ROBTEC GmbH