21. Februar 2019, 08:58:11
Roboterforum.de - Die Industrieroboter- Anwender und Experten Community

 T2 abschalten


veryhot_post Autor Thema:  T2 abschalten  (Gelesen 6727 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

01. März 2009, 08:46:39
Gelesen 6727 mal
Offline

$CYCFLAG


Hallo,

nach einigen "fast Unfällen" überlegen wir den T2 Betrieb zu sperren!

habt ihr damit Erfahrung? gibt es Probleme?

$CYCFLAG
  • gefällt mir    Danke

Heute um 08:58:11
Antwort #1

Werbung

Gast

01. März 2009, 09:12:02
Antwort #1
Offline

Robotnix


Hi.

Programmiere doch einfach in den sps.sub

IF ($MODE_OP==#T2) THEN
  $OV_PRO=10
ENDIF
  • gefällt mir    Danke

01. März 2009, 10:46:19
Antwort #2
Offline

Scottie


Guten Morgen
Der T2-Betrieb isteigentlich nur dafür gedacht, um Bahnen zu testen, die unbedingt die programmierte Proessgeschwinigkeit brauchen, so wie Schweißen oder Kleben. Wenn Ihr das nicht braucht, ist es überhaupt kein Problem, den T2-Betrieb zu sperren.
  • gefällt mir    Danke

02. März 2009, 11:49:16
Antwort #3
Offline

LindePaul


Hallo $CYCFLAG,

der Vorschlag von Robotnix ist bereits im System inplementiert.
Siehe $option.dat
BOOL $T2_OV_REDUCE=TRUE ;TRUE = OVERRIDEREDUZIERUNG AUF 10 % IN MODE T2

T2 komplett abschalten mittels Software:
siehe progress.ini
KUNDEN_VERSION = 3 ; 3 = KUKA  (without mode T2)

T2 komplett abschalten mittels Hardware:
es gibt ein KCP ohne T2 (Renault Version)

a+
  • gefällt mir    Danke
Wer nach allen Seiten offen ist kann nicht ganz dicht sein

02. März 2009, 12:43:26
Antwort #4
Offline

zteve


Hallo Lindepaul

Diese Option "OVERRIDEREDUZIERUNG AUF 10 % IN MODE T2" bewirkt doch eigentlich nur eine Reduzierung beim Ändern der Betriebsart auf T2, anschließend kann die Geschwindigkeit doch ohne Einschränkung auf 100% gestellt werden, oder net?  :denk:

Während der Vorschlag von Robotnix bewirkt, daß der OV immer wieder auf 10% zurückspringt.
Vorrausgesetzt der Submit-Interpreter läuft - und da sehe ich die große Schwachstelle dieser Lösung.
Achtet man im Handbetrieb nicht darauf, ob der SUB läuft, kann es zu gefährlichen Situationen kommen.   :down:

Was bewirkt eigentlich Kundenversion=5 ?

Gruß
Stefan
  • gefällt mir    Danke

Heute um 08:58:11
Antwort #5

Werbung

Gast

02. März 2009, 12:50:19
Antwort #5
Offline

LindePaul


Stefan,
gebe Dir in vollem Umfang recht  :supi:

Kundenversion=5 ; da hat man mal KUKA-Steuerungen in eine VW-Linie eingebaut :grmpf:
  • gefällt mir    Danke
Wer nach allen Seiten offen ist kann nicht ganz dicht sein

02. März 2009, 20:45:45
Antwort #6
Offline

Iceberg


Meiner Meinung nach reicht es wenn man die SAK Fahrt im Test2 Mode deaktiviert. Zumindest aus meiner Sicht als Programmierer.
Gibts da eigentlich eine Möglichkeit?
  • gefällt mir    Danke

07. März 2009, 13:27:06
Antwort #7
Offline

e-michael


Hallo zusammen,


die Gefahr besteht meiner Meinung nach nur nach "SAK - Fahrt in T2" die ja mit "T1 - Geschwindigkeit" vonstatten geht.
Hier schaltet jeder Anwender gerne den Override auf 100%, da einem sonst ja die Füße einschlafen.

Nach SAK - erreicht und weiterem betätigen der "START" - Taste saust der Kollege jetzt natürlich mit "100% T2" los.

Ich hab das so gelöst, dass er nach jedem "SAK-erreicht" in T2 den Override auf 10% absenkt (kleine Ergänzung im sps.sub).
Fährt man das Programm dann ab kann man wieder beliebig mit der Geschwindigkeit variieren.


Gruß!
Michael
« Letzte Änderung: 07. März 2009, 13:30:31 von e-michael »
  • gefällt mir    Danke

07. März 2009, 16:58:42
Antwort #8
Offline

Iceberg



hmm, was ist wenn die sub nicht läuft? dann hast das problem wenn du dich drauf verlässt kanns genau so schlimm ausgehen.
kannst du uns bitte verraten, wie du das in der sub geschrieben hast?
  • gefällt mir    Danke

Heute um 08:58:11
Antwort #9

Werbung

Gast

07. März 2009, 18:16:23
Antwort #9
Offline

Loipe


Hi so kann man das im sub lösen

If $Move_BCO And $T2 And ($OV_PRO > 10) Then
  $FLAG[500]=TRUE
Endif
If Not $Move_BCO And $Flag[500] Then
  $OV_PRO=10
  $FLAG[500]=FALSE
Endif

schönes WE

Loipe
  • gefällt mir    Danke
wer das hier liest hat zuviel zeit oder einen viel zu großen bildschirm

07. März 2009, 18:34:41
Antwort #10
Offline

zteve



Das ist wohl der größte Gefahrenherd beim Kuka teachen.
Dazu kommt noch, daß es bei gedrückter Zustimmtaste nicht möglich ist den aktuell eingestellten OV abzulesen.   :evil:



Von in der SPS.SUB programmierten Geschwindigkeitsänderungen für den Handbetrieb T2 halte ich gar nichts - dafür habe ich beim Teachen schon zu häufig verwundert festgestellt, daß die sub gar nicht läuft.

In so einem Fall möchte ich nicht in der Nähe des von Dir programmierten Roboters stehen.

Aber ich kann mir gut vorstellen, daß diese Lösung - von Kuka im System integriert - mehr Sicherheit brächte.
Auch, die Möglichkeit bei gedrückter Zustimmtaste den OV abzulesen (und einzustellen).

Das ist allerdings was für den Wunschzettel.

Gruß
Stefan
  • gefällt mir    Danke

07. März 2009, 19:09:07
Antwort #11
Offline

e-michael


Hallo.

@zteve
1. Der OV ist nur dann nicht ablesbar, wenn man beim Handverfahren die Tasten benutzt. bei aktivierter Maus oder deaktiviertem Handverfahren ist der OV sehr wohl ablesbar und auch änderbar (das hab ich mit variieren gemeint) beim abfahrend des Programms.

2. Beim manuellen Verfahren des Roboters ist sowieso der Handoverride aktiv, welchen ich nicht anfasse!
Ich setze nur den POV auf 10% nachdem SAK erreicht ist (10% ist langsamer als 100%!!).
Meine Änderung ist natürlich nicht geeignet um bei T2- Betrieb alle gebotenen Sicherheitsvorschriften zu ignorieren.

3. Versuch mal eine SAK - Fahrt ohne angewählten submit interpreter (dat jeht gar nich)

4. Zur info: Handverfahren in T2 passiert genauso nur mit sicher reduzierter Geschhwindigkeit wie in T1!!!

5. Wenn ich in T2 teache hat sowieso keiner außer mir was in der Nähe des Roboters zu suchen! Da musst du also keine Angst haben.

6. Der Sicherheitskreis des Roboters in Verbindung mit der ihn umgebenden Anlage und den Sicherheitsvorschriften sind dafür da die Sicherheit des Anwenders möglichst zu gewährleisten und nicht evtl. einträge im sps.sub.

...
@zteve
Ich muss sagen, dass ich mich selten so sehr missverstanden gefühlt habe wie jetzt im Moment.

@iceberg
Ich kann die Ergänzung gerne hier posten, allerdings erst nächste Woche, da ich das grad nicht im Kopf hab und leider auch keinen Zugriff auf den Roboter. (Der code von Loipe kommt dem aber schon ziemlich nahe glaub ich)

Gruß!
Michael

« Letzte Änderung: 07. März 2009, 19:16:51 von e-michael »
  • gefällt mir    Danke

07. März 2009, 20:05:16
Antwort #12
Offline

zteve


Hallo e-michael


zu 1. Ich beziehe mich nur auf die typische Situation, die Du - so habe ich dich verstanden - beschrieben hast:

Inbetriebnahme - teachen - ein geöffnetes Programm - Satzanwahl auf einen Verfahrpunkt meiner Wahl - Starttaste drücken - SAK-Fahrt -  Zzzzz  - POV erhöhen - SAK erreicht - Zustimmtaste noch gedrückt (POV jetzt nicht ablesbar) - jetzt kann ich bei Deinem Roboter gewohnheitsmäßig noch mal Start drücken, da ja POV=10%
Wenn Sub nicht läuft gibts ne Überraschung

zu 3. Das würde mich jetzt wundern, daß ich ohne laufende Sub keine Satzanwahl machen und diesen Punkt anfahren kann. Sollte das so sein, wäre die Lösung ok

zu 5. Meine Bedenken beziehen sich vor allem auf die Bediener (vor allem Instandhaltung), die später mit diesen Robotern arbeiten und das ursprüngliche Thema T2 sperren für Anwender

Will Dir nicht zu Nahe treten, nur meine Meinung kundtun.        :blumen:
Stelle aber erfreut fest, daß Du Dir Gedanken machst         

Gruß
Stefan
« Letzte Änderung: 07. März 2009, 20:12:17 von zteve »
  • gefällt mir    Danke

Heute um 08:58:11
Antwort #13

Werbung

Gast

07. März 2009, 20:32:17
Antwort #13
Offline

e-michael


Hallo nochmal.

Soweit ich weiß kannst du tatsächlich bei gestopptem sps.sub "keine" SAK-Fahrt machen.
Deshalb läuft der Interpreter bei erneutem drücken der"START" taste mit Sicherheit.
Falls nicht würde der Roboter nicht losfahren.

Würde hierzu aber gerne noch eine Meinung von einem Experten hören.

Und bei "meinem" Roboter kann ich bei gedrückter Zustimmtaste den POV schon ablesen, aber eben nur wenn "Maus" aktiv ist, oder Handverfahren deaktiviert ist.

Natürlich darf man sich Sicherheitstechnisch nicht auf den Submit interpreter verlassen. Das unterrschreibt dir kein Arbeitssicherheitler, aber diese Funktion erspart einem, dass man ständig den POV manuell herunterstellen muss.

Bei mir war es im T2 Betrieb ohne diese Funktion immer so, dass ich den Totmann -Taster locker rechtzeitig loslassen konnte ohne in Gefahr zu geraten. Den ein oder anderen Crash hatte ich Anfangs natürlich auch.

Gruß!
Michael

  • gefällt mir    Danke

08. März 2009, 14:35:38
Antwort #14
Offline

Iceberg



dito
ich kann mich auch nicht darann erinnern das die sps laufen muss für Satzanwahl
  • gefällt mir    Danke


Teile per facebook Teile per linkedin Teile per pinterest Teile per reddit Teile per twitter
 

über das Roboterforum

Nutzungsbedingungen Impressum Datenschutzerklärung

Sponsoren des Roboterforums

ROBTEC GmbH