18. März 2019, 22:47:22
Roboterforum.de - Die Industrieroboter- Anwender und Experten Community

[offen] Software-Endschalter KRC4


normal_post Autor Thema: [offen] Software-Endschalter KRC4  (Gelesen 1522 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

22. November 2018, 17:04:57
Gelesen 1522 mal
Offline

AndreM2012


Hi ihr Lieben,
ich hab da mal ne Frage zum o.g. Thema. Gibt es eine Situation, in der die Steuerung die ermittelten SW-Endschalter neu beschreibt? Trotzdem die Auto-Ermittlung läuft? Mir ist bisher nichts bekannt, jedoch habe ich hier den Fall.
Hatte am Mo die SWE neu gesetzt, die per calc_axis_limit ermittelt wurden. Die waren jedoch nicht iO. Kamen reihenweise die SWE. Dann habe ich sie erneut auf original zurückgesetzt und laufen lassen. Jetzt(!) bei Durchsicht habe ich wieder irgendwelche ermittelten Werte. Die decken sich jedoch nicht mit denen aus der calc_axis_limit!
D.h.
-SWE auf original gesetzt
-nun sinds andere Werte
-jedoch andere als aus calc_axis_limit ermittelt

Ist da etwas???

Ich danke euch schon mal vorab für eure Beiträge/Hilfe.

Gruß
André
  • gefällt mir    Danke

Heute um 22:47:22
Antwort #1

Werbung

Gast

23. November 2018, 08:11:40
Antwort #1
Offline

Robonator


Guten Morgen Andre.

Zieh dir ein Archiv vom Roboter und schau mit dem Computer drüber.
Such einfach in dem Arbeitsordner nach den Variablen von den Sofwareendschaltern.
Dann wirst du schnell sehen, ob diese noch irgendwo anders beschrieben werden.
Je nachdem was programmiert wurde, kann das durchaus sein!
Ich hoffe, ich konnte helfen
Grüße
  • gefällt mir    Danke

24. November 2018, 09:30:47
Antwort #2
Offline

Hermann


Genau,
standardmässig gibt es da nichts. Auch dieses Programm calc_axis_limit() ist kein Kuka Standard, kenne ich aus den Daimler Vorlagen. Da hilft nur (wie schon oben gesagt) Recherche im kompletten Programm.
  • gefällt mir    Danke

27. November 2018, 06:54:22
Antwort #3
Offline

AndreM2012


Guten Morgen! Danke euch für die schnellen Antworten. Das mit den Variablen ist mir bekannt. Komisch ist nur, das der Aufruf aus der SPS.sub nicht da ist. Auch in restlichen Programmteilen ist nichts zu finden. Dennoch haben sich die Endsxhalter verstellt. Das dürfte doch aber nicht geschehen, oder?
Grüße André 
  • gefällt mir    Danke

27. November 2018, 07:48:56
Antwort #4
Offline

Hermann


Im Prinzip korrekt.
Vermutlich hast du da irgend was übersehen.
  • gefällt mir    Danke

Heute um 22:47:22
Antwort #5

Werbung

Gast


Teile per facebook Teile per linkedin Teile per pinterest Teile per reddit Teile per twitter
 

über das Roboterforum

Nutzungsbedingungen Impressum Datenschutzerklärung

Sponsoren des Roboterforums

ROBTEC GmbH