21. Februar 2019, 09:34:20
Roboterforum.de - Die Industrieroboter- Anwender und Experten Community

 Kuka KRC2 --> Halt --> Start


normal_post Autor Thema:  Kuka KRC2 --> Halt --> Start  (Gelesen 768 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

18. September 2018, 08:34:27
Gelesen 768 mal
Offline

Seirob


Hallo,

gibt es eine Möglichkeit den Roboter im Programm über einen Befehl zu starten, ohne die Starttaste zu betätigen? :kopfkratz:
  • gefällt mir    Danke

Heute um 09:34:20
Antwort #1

Werbung

Gast

18. September 2018, 11:49:25
Antwort #1
Offline

drudge


Ja und Nein (=normalerweise sollte man das nicht tun ...)
Wieso brauchst du das?
  • gefällt mir    Danke

18. September 2018, 16:01:37
Antwort #2
Offline

Seirob


Am Programmanfang habe ich eine Abfrage eingebaut bei der der Mitarbeiter (Maschinenbediener) abgefragt was er tun soll. (Softkeytasten) Start= Programm starten, Greifer= Greiferwechselposition, Düse= Düsenausrichtung. Ich hätte es gerne dass wenn der Bediener die programmierbare Softkeytaste Start drückt der Roboter sofort anfängt zu arbeiten. Ansonste muss der Bediener jedes mal zwei mal Start drücken einmal unten und einmal die grüne Starttaste. Ist nicht so notwendig aber für manchen ist es leider verwirrend
  • gefällt mir    Danke

19. September 2018, 07:45:53
Antwort #3
Offline

drudge


hmm das heisst in dem Moment sind die Antriebe bereits ein und die Sicherheiten quittiert?
Wieso ist dann das Programm gestoppt?
Respektive wie liest du die Softkeys ein, über User-Tech, Submit oder was?

Die Lösung mit am wenigsten Widerstand von KUKA ist, dass du im Automatik extern arbeitest und am DeviceNet einen Wagokoppler packst, wo du gewisse Ausgänge auf gewisse Eingänge brückst... das ganze Starten und Stoppen ginge dann über den Submit.
Es gibt auch noch eine von KUKA nicht erlaubte Möglichkeit mit EA Softlinking ...
  • gefällt mir    Danke

25. September 2018, 10:27:08
Antwort #4
Offline

Seirob


Hi,
sorry für die Späte Antwort. Ich war unterwegs und konnte nicht antworten.
Das Programm befindet sich am Anfang und die Antriebe werden dabei gestartet. Anschließend frage ich im Prozess über ein optisches "Auge" ab ob die Teile durch den Beladeroboter in die richtige Position eingelegt worden ist. Falls ein Teil aus irgendwelchen Gründen falsch eingelegt worden ist, hält der Roboter an und meldet dieses. Danach sollte der Bediener das Teil korrekt einleigen und über die Softkeytaste diesen Fehler quittieren und der Roboter sollte nach dem Quittieren anlaufen.

Die Softkeys werden soweit ich es verstanden habe über User-Tech eingelesen!
  • gefällt mir    Danke

Heute um 09:34:20
Antwort #5

Werbung

Gast

25. September 2018, 14:06:21
Antwort #5
Offline

domi1711


Ich mache das meistens mit einer Dialogmeldung und switch case Abfrage, da kannst du die Buttons (am Touchscreen) selbst erstellen und musst das Programm nur einmal starten (ganz zu Beginn).
lg, Dominik
  • gefällt mir    Danke

17. Oktober 2018, 08:54:37
Antwort #6
Offline

drudge


Hallo domi,

das Problem ist halt, dass durch das Betreten der Zelle die Sicherheiten unterbrochen und dadurch die Roboterantriebe ausgeschaltet werden. Darum braucht es nachher einen Programmstart (grüne Taste).

Die einfachste Lösung wäre wohl:
 1. Teilekontrolle
 2. Falls nicht i.O. entsprechende Statusmeldung absetzen
 3. WHILE "Teilekontrolle nicht i.O."
      HALT (Programmstop)
    ENDWHILE
 4. Statusmeldung wieder löschen
 
Dadurch startet und quittiert der Bediener halt mit der grünen Starttaste.

greez Drudge
  • gefällt mir    Danke


Teile per facebook Teile per linkedin Teile per pinterest Teile per reddit Teile per twitter
 

über das Roboterforum

Nutzungsbedingungen Impressum Datenschutzerklärung

Sponsoren des Roboterforums

ROBTEC GmbH