25. Juni 2019, 23:49:03
Roboterforum.de - Die Industrieroboter- Anwender und Experten Community

 Greenhorn


normal_post Autor Thema:  Greenhorn  (Gelesen 2881 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

11. März 2004, 14:06:00
Gelesen 2881 mal

DuranDC

Gast
Moin,
 
 ich bin derzeitig ein Student im 2.Praxissemester.
 Neben mir steht ein KUKA KR 15/2.
 Dieser soll von mir "belebt" und ein Laborversuch fĂĽr spätere Semester entwickelt werden.
 
 Ich bin absolut neu auf dem Gebiet und habe mir schon die beim Roboter mitgelieferten Unterlagen und Dokumentationen durchgelesen.
 
 Leider wird dort nicht sonderlich auf die Programmierung (anhand von Codebeispielen) eingegangen und im Internet konnte ich bis jetzt auch nicht viel finden.
 
 Habt ihr ein paar Interessante Links und/oder könnt mir etwas weiterhelfen?
 
 Was sollte beachtet werden beim Programmieren bzw. gibt es irgendwo ein Online-Tutorial?
  • gefällt mir    Danke

16. März 2004, 05:28:00
Antwort #1
Offline

Werner Hampel

Administrator
oh. Ein Online Turtorial gibts nicht, meines Wissens nach.
 Offiziell gibts die HandbĂĽcher bei KUKA. Einfach mal anrufen und fragen: 0821 797 0.
 Studenten wird da gerne geholfen.
  • gefällt mir    Danke
Menschen brauchen Roboter, aber auch Roboter brauchen Menschen.
Roboter sichern die Arbeitsplätze und den Fortschritt der Industrieländer, da sie kostengünstig und qualitativ hochwertig produzieren.
Ohne Automatisierung mit Robotern werden unsere Produkte in Billiglohnländern hergestellt.

29. März 2004, 13:37:00
Antwort #2

DuranDC

Gast
Moin,
 
 danke, die bei Kuka sind echt gut drauf und haben sehr bei der Erstinbetriebnahme ausgeholfen. Aber wegen "Labalieren" möchte ich dir jetzt nicht nerven, weswegen ich es mal hier probiere.
 
 Also, Zwischenstand, ich habe inzwischen den Robo zum Lebenerweckt und er lässt sich auch wunderbar bedienen ĂĽber den einzelachsenmodus, weltmodus usw usw.
 
 TCP Vermessen kann ich jetzt auch, sowie die Erstjustage mit einem EMT.
 
 Oki, soweit so gut...
 
 Aber ich werde nicht aus den BĂĽchern hier schlau, was genau passiert bei A1, A2 usw. Laut der Anzeige auf dem Bedienteil hat der Robo 8 davon.
 
 Okay, ich habe auch schon herumgespielt, was da passiert. Bei A2=Ein viel das Werkzeug ab, aber es zischte verdammt, was nach A1=Aus nicht mehr der Fall war.... hilfe
  • gefällt mir    Danke

29. März 2004, 13:55:00
Antwort #3
Offline

Werner Hampel

Administrator
schön, dass der Roboter läuft. Der Rest ist auch zu schaffen.
 Die Ausgänge 1 - 8 wĂĽrde ich einfach mal durchprobieren und schauen, was passiert (Vorsichtig !). Am besten vorher elektrisch prĂĽfen. Im Roboter ist eine Klemmleiste X12 (?) auf die alle 8 Ein und 8 Ausgangs- Signale aufgelegt sind.
 Von dort aus am besten mal alles abchecken, wo die Signale hingehen. Viel Erfolg !
  • gefällt mir    Danke
Menschen brauchen Roboter, aber auch Roboter brauchen Menschen.
Roboter sichern die Arbeitsplätze und den Fortschritt der Industrieländer, da sie kostengünstig und qualitativ hochwertig produzieren.
Ohne Automatisierung mit Robotern werden unsere Produkte in Billiglohnländern hergestellt.

06. April 2004, 11:45:00
Antwort #4

DuranDC

Gast
Vilene dank erstmal, fĂĽr die Hilfe :-)
 
 Also, zur allgemeinen Freude, der Robo ist noch heil und so langsam freunde ich mit ihm sogar an :-)
 
 Ich bin jetzt dabei, ein Programm fĂĽr einen Werkzeugwechsel zu erstellen.
 
 Soweit zu gut.
 
 Jetzt macht der Kuka aber folgendes, sobald er sich das Werkzeug aus der ablage gegriffen hat und damit langsam rauafährt, er sagt kurz nach unten ab.
 Schaut nicht gefährlich fĂĽr Robo und Werkzeugablage aus, aber ist glaube ich, noch nicht so, wie es sein sollte.
 
 Kann das gewicht, was der Kuka durch das Andocken am Werkzeug dazubekommt, irgendwie berĂĽcksichtigend in dem Programm "angemeldet" bzw eingegeben werden?
  • gefällt mir    Danke

06. April 2004, 13:10:00
Antwort #5
Offline

Werner Hampel

Administrator
ja, da gibts eine Einstellung Namens Lastdaten.
 Sie finden den MenĂĽpunkt in der Nähe der TCP Daten.
 Diese können an und abgeschalten werden. Eine gute Schätzung des Gewichtes wird Ihr Problem lösen.
  • gefällt mir    Danke
Menschen brauchen Roboter, aber auch Roboter brauchen Menschen.
Roboter sichern die Arbeitsplätze und den Fortschritt der Industrieländer, da sie kostengünstig und qualitativ hochwertig produzieren.
Ohne Automatisierung mit Robotern werden unsere Produkte in Billiglohnländern hergestellt.

06. April 2004, 14:20:00
Antwort #6

DuranDC

Gast
He, danke fĂĽr die schnelle Antwort.
 
 Oki, ich habe jetzt zwei Werkzeuge definiert.
 
 Einmal Werkzeug 10 mit null Gewicht (Status: Roboter ohne Werkzeug)
 
 und Werkzeug 1 mit 4 kg (Status: Roboter mit Werkzeug)
 
 Beide Werkzeuge in das Programm mit eingebunden und er sackt immer noch (2-3 Milimeter, aber reicht, das die Werkzeugablage etwas "knackt") runter, als wenn ich da nichts verändert hätte......
  • gefällt mir    Danke

28. Juli 2004, 21:04:00
Antwort #7

REKRA75

Gast
Ist zwar schon ne Weile her, aber vielleicht wartest du ja noch auf eine Antwort.
 
 Ich glaube das Problem (Umschalten von einem Tool auf ein anderes zwischen 2 Punkten) kenne ich von KUKA´s.
 Wenn der letzte Punkt mit Wkzg1 gleich dem ersten Punkt mit Wkzg2 ist, sollte das Problem nicht mehr auftreten.
 Habe aber leider keinen KUKA in der Nähe um mal selber zu testen.
  • gefällt mir    Danke

28. Juli 2004, 21:28:00
Antwort #8
Offline

Werner Hampel

Administrator
oops, hab ich ganz ĂĽbersehen, dass da noch was offen war. Sorry.  <img border="0" title="" alt="[SchĂĽchtern]" src="images/icons/rolleyes.gif" />  
 
 Aber zum GlĂĽck bin ich ja nicht mehr der einzige hier. (-&gt; Danke Rekra75)
 
 Ich kenn das Problem auch. Das einzige, was mir da immer hilft, ist die Raumpunkte entsprechend höher oder niedriger zu teachen, wie es im Handbetrieb korrekt scheint.
 Das heisst, wenn der Roboter im Automatikbetrieb absackt, nachdem das Werkzeug aufgenommen und die korrekten Lastdaten ĂĽbernommen wurden, verändere ich die Punkte so lange, bis er nicht mehr knackt. Einfach mit GefĂĽhl oder nach dem Prinzip "Try and Error".
 Egal, obs logisch ist oder nicht. Hauptsache der Roboter fährt sanft.  <img border="0" title="" alt="[Winken]" src="images/icons/wink.gif" />
  • gefällt mir    Danke
Menschen brauchen Roboter, aber auch Roboter brauchen Menschen.
Roboter sichern die Arbeitsplätze und den Fortschritt der Industrieländer, da sie kostengünstig und qualitativ hochwertig produzieren.
Ohne Automatisierung mit Robotern werden unsere Produkte in Billiglohnländern hergestellt.

07. September 2005, 17:10:51
Antwort #9

ChrisJ

Gast
Hallo!


Diese Effekt klingt eher nach durchfahren der Sinuglarität!

Welche KUKA Software ist im Einsatz?

Kann es sein das die Achse 4, 5 und 6 in einer Flucht stehen?

Probier mal die Achse 5 beim Teachen abzuwinkeln!


GruĂź

Chris
  • gefällt mir    Danke


Teile per facebook Teile per linkedin Teile per pinterest Teile per reddit Teile per twitter
 

ĂĽber das Roboterforum

Nutzungsbedingungen Impressum Datenschutzerklärung

Sponsoren des Roboterforums

ROBTEC GmbH