25. März 2019, 04:48:13
Roboterforum.de - Die Industrieroboter- Anwender und Experten Community

[gelöst] Benötigte Bestätigungen für Programmstart Automatikmodus


normal_post Autor Thema: [gelöst] Benötigte Bestätigungen für Programmstart Automatikmodus  (Gelesen 1711 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

27. November 2018, 13:55:55
Gelesen 1711 mal
Offline

Froschkönig


Hallo ihr Lieben,

ich bin auf eine Sache gestoßen die ich bisher nicht kannte und hätte dafür gerne eine Erklärung von euch :)
$BASE= BASE_DATA[28]

LOOP
WAIT FOR $AUT
IF NOT $IN[53] THEN

WAIT FOR $IN[55]

LIN_REL{Y -100}
LIN_REL{Y 100}

ENDIF
ENDLOOP
END
Die Idee ist eigentlich das der Bediener die Tür öffnet, in die Zelle geht und anschließend wieder rausgeht, Tür schließt und quitiert. Dann noch einmal den $55 drücken und das Programm läuft wieder eine Loop durch.
Bei mir läuft es aber so ab:
Tür schließen und quitieren
- $55 drücken (Antriebe gehen ein)
Start drücken (Programm läuft weiter?? )
- $55 drücken (Loop läuft durch)
Warum starte ich mit $55 die Antriebe? Warum muss ich noch einmal extra das Programm mit "Start" starten? Und ist der Vorgang ohne externe SPS vereinfachbar?
Ich möchte eigentlich nicht das der Bediener auf dem HMI rumdrücken muss.
« Letzte Änderung: 06. Dezember 2018, 11:37:04 von Froschkönig »
  • gefällt mir    Danke

Heute um 04:48:13
Antwort #1

Werbung

Gast

29. November 2018, 14:07:05
Antwort #1
Offline

drudge


Hallo Froschkönig,

dein Problem ist, dass du für den Programmstart bei KUKA
1. entweder einen der grünen Startknöpfe auf dem KCP drücken musst
2. oder über ein digitales Eingangssignal einen Signalwechsel von low auf high generieren musst

Zweitens könntest du über den Submit realisieren indem du ein digitales Ausgangsignal physikalisch auf einen digitalen Eingang brückst ...

greez Drudge
  • gefällt mir    Danke

29. November 2018, 18:09:46
Antwort #2
Offline

panic mode


geanu... und kein AUT Modues, es muss EXT sein
  • gefällt mir    Danke

04. Dezember 2018, 14:28:43
Antwort #3
Offline

Froschkönig


Vielen Dank für eure Antworten und den Versuch zu helfen. Ich bin mir noch immer nicht ganz sicher ob ich alles verstehe.
Ich arbeite nur im Automatik-Modus da ich keine übergeordnete SPS habe.
Ich dachte anfänglich mein grüner Schalter außen an der Roboterzelle ( $IN[55] ) wäre nur ein beliebiger digitaler Eingang, glaube aber mittlerweile, dass es mehr ist. Beschriftet ist er mit "Start angefordert" und ich MUSS ihn einmal gedrückt haben damit ich überhaupt die INI Zeile mit grüner Starttaste starten kann. Und nachdem die Tür offen war und wieder quittiert wurde muss ich wiederum zuerst "Start anfordern" bevor ich Starten kann.
Ist das etwas KUKA spezifisches oder nur in meiner Zelle so? Mir fehlt da leider die jahrelange Robotik Erfahrung...
Grüße und Danke an alle die antworten!

Frosch


 
  • gefällt mir    Danke

05. Dezember 2018, 07:29:41
Antwort #4
Offline

drudge


Könnte eventuell auch die Fahrfreigabe von der SPS sein ...
Mach doch schnell ein Archiv des Roboters ... dann schau ich in die Konfiguration. Sollte kein Problem sein, heraus zu finden was der $IN[55] alles so macht. ;)

Heute um 04:48:13
Antwort #5

Werbung

Gast

05. Dezember 2018, 16:09:38
Antwort #5
Offline

Froschkönig


 alles so macht. ;)

Das ist sehr freundlich von dir. Ich bin mir so spontan aber gar nicht sicher ob ich das einfach so hergeben darf. Außerdem hat das Archiv 60MB ?!?

Im WV finde ich den besagten Eingang gar nicht. Das iritiert mich ein bisschen... Überhaupt fehlen da einige Eingänge die alle irgendwie mit Schutztür und Zutritt etc. zusammenhängen :)
« Letzte Änderung: 05. Dezember 2018, 16:11:51 von Froschkönig »
  • gefällt mir    Danke

05. Dezember 2018, 16:23:26
Antwort #6
Offline

d4nuu8


Der Eingang steht doch da. Ist halt als Byte gruppiert. Man sieht sogar dass es vom PNOZ kommt ... 

06. Dezember 2018, 11:08:53
Antwort #7
Offline

Hermann


Ja, es gibt immer wieder spezielle Programmierweisen, in denen der "Programmierer" sich die Bits selbst aus den Bytes rausklaubt, oder die Eingänge irgendwie byteweise verarbeitet. Das trägt dann nicht wirklich zur Wartbarkeit des Codes bei.
Manch einer denkt auch das sei eine besonders tolle Art des Kopierschutz. Oder ein studierter Informatiker hatte da seine Finger drin, der alles super universell und parameterierbar macht, so daß hinterher keiner mehr durchblickt.
Evtl. ist hier auch noch ein Programmteil im sps.sub beteiligt, oder eine Soft-SPS.
Ohne die Programme muss man da dann schon mal die alte verstaubte Glaskugel rauskramen, aber meine hat einen Sprung, funktioniert nicht mehr. :?
  • gefällt mir    Danke

06. Dezember 2018, 11:36:50
Antwort #8
Offline

Froschkönig


@all
Vielen Dank für die Mithilfe. Ich kam nie über einen Certified Robot Engineer raus und bring mir den Rest irgendwie nebenbei bei. Das ist leider manchmal sehr chaotisch und unstrukturiert. Meine Roboterzelle gab es schon vor mir und es gibt keine Dokumentation und aus irgend einem Grund auch keine DVD mit KUKA Unterlagen oder ähnlichem. Das Forum ist daher wirklich sehr sehr hilfreich!!! **Verbeugung**

SPS.sub :
...
;FOLD AUTOMATK


; Meldung an PNOZ, wenn Roboter in AUTOMATIK

$OUT[34] = NOT ($T1 OR $T2 OR $EXT)


; Antriebe in AUTOMATIK ggf. in wieder einschalten

IF ($OUT[34] AND NOT $IN[43] AND NOT $IN[44] AND $IN[55]) THEN

   $DRIVES_ENABLE = TRUE

ENDIF


;ENDFOLD (AUTOMATIK)
...

DA IST DAS DING!
Die SPS.sub kann ich mir wie eine SPS vorstellen die immer im Hintergrund läuft?
Warum die Bits zusammengelegt werden ist mir noch nicht ganz klar, aber man muss ja nicht alles heute verstehen. Morgen ist auch noch ein Tag.
  • gefällt mir    Danke

Heute um 04:48:13
Antwort #9

Werbung

Gast

10. Dezember 2018, 12:57:10
Antwort #9
Offline

WolfHenk


sapperlot, wer hat denn das gebastelt?
Bei KRC2 ging das wesentlich einfacher. Bin sicher, dass das noch so geht.

$OUT[34] = NOT ($T1 OR $T2 OR $EXT)Ich meine das wäre einfacher: $out[34] = $aut
Ist aber noch einfacher weil schon gemacht!!!
In der Parametrierung für Automatik Extern kann ich diese Zuweisung direkt machen...
Schreibt sich dann in \krc\steu\mada\$machine.dat etwa in Zeile 18 rein.
Sieht im Original etwa so aus:
SIGNAL $AUT $OUT[995] ;BETRIEBSART AUTOMATIK
Müsste bei Dir eben statt 995 ne 34 rein. Schon fertig. Ohne Gebibbel in der SPS.sub.
Also, der Programmierer, der Dein Original gebastelt hat, muß schon ein Könner gewesen sein....
« Letzte Änderung: 10. Dezember 2018, 13:17:44 von WolfHenk »
  • gefällt mir    Danke
Wolfram (Cat) Henkel

never forget Asimov's Laws at the programming of robots...

"Safety is an integral part of function. No safety, no production. I don't buy a car without brakes."

https://www.xing.com/go/invite/5634410.eb15e5

PMs und Mails mit Anfragen wie "Wie geht das..." werden nicht beantwortet. Diese Fragen und die Antworten interessieren jeden hier im Forum.


Teile per facebook Teile per linkedin Teile per pinterest Teile per reddit Teile per twitter
 

über das Roboterforum

Nutzungsbedingungen Impressum Datenschutzerklärung

Sponsoren des Roboterforums

ROBTEC GmbH