Roboterprofis für Ihren Erfolg
Roboterprogrammierer auf Stundenbasis engagieren
jetzt Preise und verfügbare Roboterprogrammierer anfragen

Autor Thema:  Active Status  (Gelesen 7085 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

DuranDC

  • Gast
Active Status
« am: 01. Juli 2004, 14:17:00 »
Moin,
 
 inzwischen hab ich mich sehr gut mit meinem KUKA 15/2 angefreundet *danke nochmal an euch für die Hife* und schon die ersten Programme geschrieben.
 
 So weit so gut, jetzt wollte ich das Programm, was ich im T1 und T2 Mode schon getestet hatte, auch mal im Externen Modus laufen lassen.
 
 Jetzt erzählt mir das Panel: ACTIVE--STATUS ERFORDERLICH
 
 In der Kuka-Doku steht als Abhilfe:
 Bediengerät aktiv setzen.
 
 Öhm, okay..... und wie mache ich das??? Das hab ich nirgendwo in dem 812 seitigen Dokument finden können  <img border="0" title="" alt="[Enttäuscht]" src="images/icons/frown.gif" />
  • finde ich gut    Danke, das hat mir geholfen    da stimmt was nicht

h.wagner

  • Gast
Re: Active Status
« am: 01. Juli 2004, 15:17:00 »
Hallo erstmal,
 
 Warum EXTERNER MODUS?? Meinst du vielleicht AUTOMATIK??
 
 Wenn der Schlüsselschalter rechts oben steht, bedeutet dies die Betriebsart Automatik Extern ist angewählt, auch zu erkennen an "EXT" in der Taskbar. Dann soll der Roboter von einer übergeordneten Steuerung (z.B. SPS, PC) angesteuert werden. Wenn du das brauchst findest du einiges in der DOKU zum Signalaustausch zwischen KRC und SPS incl. Signallaufdiagrammen.
 Ein Programm Start über die Start-Taste am KCP gibt dir in dem Fall die Meldung ACTIVE--STATUS ERFORDERLICH.
 
 In deinem Fall sollte der Schlüsselschalter links oben stehen, Betriebsart Automatik(Taskbar "AUT").
 Dann Programm anwählen, Antriebe einschalten, Start-Taste drücken und halten bis Roboter auf erster programmierter Position (Meldefenster: SAK erreicht), Start-Taste erneut drücken und das Prog sollte ablaufen.
 
 Wenn es noch nicht funktioniert, gib mal bekannt welche Steuerung(KRC1,KRC2,..) und welcher Softwarestand vorhanden ist.
  • finde ich gut    Danke, das hat mir geholfen    da stimmt was nicht

Offline Werner Hampel

  • Administrator
  • Forum Legende LV 3
  • *
  • Beiträge: 1592
    • ROBTEC GmbH - Roboter Systemhaus
  • Bewertet: +26
Re: Active Status
« am: 01. Juli 2004, 18:13:00 »
Die Meldung "Aktive Status erforderlich" kommt, wenn  im Automatikmodus z.B. die Starttaste oder Fehlerquittierung gedrückt wird.  Diese sind im Externen Modus blockiert. Externer Modus bedeutet, dass der Roboter die Signale zum Programmstart, Fehlerquittierung, Programmanwahl etc. über die frei konfigurierbare externe Schnittstelle bekommt.
 
 Das Programmiergerät kann man auf "aktiv" schalten, indem man z.B. Handbetrieb anwählt.
  • finde ich gut    Danke, das hat mir geholfen    da stimmt was nicht
Menschen brauchen Roboter, aber auch Roboter brauchen Menschen.
Roboter sichern die Arbeitsplätze und den Fortschritt der Industrieländer, da sie kostengünstig und qualitativ hochwertig produzieren.
Ohne Automatisierung mit Robotern werden unsere Produkte in Billiglohnländern hergestellt.

DuranDC

  • Gast
Re: Active Status
« am: 02. Juli 2004, 11:42:00 »
Ah,okay, verstehe.. oder nicht so ganz....
 
 Also, mein ursprungliches Problem ist folgendes:
 
 Ich habe ein Programm geteacht für eine Werkzeughalterung, wo der Kuka selber anhand der Sensoren später feststellen soll, ob das der 2-Fingergreifer ist oder die Schweisszange (Codierscheiben dafür auch schon besorgt und mit den vorhandenden Sensoren ausgetestet).
 
 Nun, damit der Roboter mir nicht bei der Werkzeug entnahme mir die Halterung mitnimmt, sollte er nicht schneller als 10% fahren.
 
 Kann ich im T1 oder T2 Modus ein Programm ablaufen lassen, wo der Roboter auf die im Programmerstellten Geschwindigkeiten verfährt und nicht die, die gerade am Panel per Hand voreingestellt war?
 
 Deswegen ging meine Flucht in den Automatikmodus (nicht Extern, obwohl das Panel mir nur EXT bei beiden Schalterstellungen anzeigt    <img border="0" title="" alt="[Enttäuscht]" src="images/icons/frown.gif" />   ), da ich mir dort erhoffe, das der Roboter nun in den programmierten Geschwindigkeiten fährt.
 
 @HeinzWagner: Die Steuerung ist eine VKR C1 von VW. Habs mal ausprobiert, wie du es beschrieben hast. Ic habe dann die meldung erhalten: SAK-Fahrt im Single-Step erforderlich.
 Als ich dann dennoch die Programmstart-Taste drückte, kam dann meine lieblingsmeldung: ACTIVE-Status erforderlich
  • finde ich gut    Danke, das hat mir geholfen    da stimmt was nicht

h.wagner

  • Gast
Re: Active Status
« am: 02. Juli 2004, 21:14:00 »
Hatte vor einer Woche das gleiche Problem wie du.
 Zur Vorgeschichte:
 War bei einem Kunden in der Tschechei, KR15/2 mit KRC1 ,Softwarestand V2.3.24 SP07. Habe Softwarestand V4.1.6 SP03 installiert, während der Installationsroutine fragt mich das SETUP welche Robi-Konfig vorhanden sei. Zur Auswahl stand "Office PC", "KUKA Standard", "General Motors", "ohne T2", "mit E2/E7". Habe mich zunächst für das letzte entschieden, da ich dabei an externe Achsen gedacht habe die bei dem Robi auch vorhanden waren. Nach erfolgtr Installation konnte ich keinen Automatik-Modus mehr anwählen. Die Fehlermeldung "Active-Status erforderlich" kam beim Starten eines Programms. In der Taskbar stand EXT auch bei Schlüsselschalterstellung auf Automatik.
 Was nun?? Hotline angerufen!!
 Nach kurzer Zeit kam die Frage: Ist das vielleicht ein VW-KUKA?? Da fiel dann der Groschen. Habe die Installation erneut durchgeführt mit der Auswahl "KUKA Standard" und siehe da, der Automatik Modus fuktionierte wieder(so wie weiter oben beschrieben).
 
 Tja wie hilft dir das jetzt weiter?
 
 Die VW-Software verhindert scheinbar das Starten des Programms im Automatik Modus. Sie braucht die Automatik Extern Schnittstelle. Ich weiß leider nicht ob sich die Hardware der VKRC1(VW) von der KRC1(KUKA Standard) unterscheidet. Wenn dies nicht der Fall ist besteht die Möglichkeit die KUKA Standard Software zu installieren, beispielsweise V2.2.8 (immer noch Auslieferungsstand wenn man eine neue KRC1[gegen Aufpreis] bekommt) oder V2.3.24 SP07 (wenn du den Treiber für die Siemens Profibus Master/Slave CP5613/14 brauchst). Die nötige Software musst du natürlich haben.
 
 P.S.: Denn Programm Override kannst du mit der Systemvariablen $OV_PRO im Programm direkt beschreiben.
 
 Aber Vorsichtig!!
 Füge die Zeile im Programm ein:
 $OV_PRO=15 ; 15% Programm Override
  • finde ich gut    Danke, das hat mir geholfen    da stimmt was nicht

Offline Werner Hampel

  • Administrator
  • Forum Legende LV 3
  • *
  • Beiträge: 1592
    • ROBTEC GmbH - Roboter Systemhaus
  • Bewertet: +26
Re: Active Status
« am: 03. Juli 2004, 02:22:00 »
</font>
<font size="1" face="Verdana, Helvetica, sans-serif">Zitat:</font>
<font size="2" face="Verdana, Helvetica, sans-serif">Original erstellt von DuranDC:
 <strong> Kann ich im T1 oder T2 Modus ein Programm ablaufen lassen, wo der Roboter auf die im Programmerstellten Geschwindigkeiten verfährt und nicht die, die gerade am Panel per Hand voreingestellt war?</strong></font>
<font size="2" face="Verdana, Helvetica, sans-serif">Den Override einfach auf 100% stellen, dann fährt der Roboter die Programmierten Geschwindigkeiten
 
  </font>
<font size="1" face="Verdana, Helvetica, sans-serif">Zitat:</font>
<font size="2" face="Verdana, Helvetica, sans-serif">Original erstellt von DuranDC:
 <strong> Ich habe dann die meldung erhalten: SAK-Fahrt im Single-Step erforderlich.
 Als ich dann dennoch die Programmstart-Taste drückte, kam dann meine lieblingsmeldung: ACTIVE-Status erforderlich </strong></font>
<font size="2" face="Verdana, Helvetica, sans-serif">Du must in jedem Fall im Handbetrieb einen PTP Punkt (Homeposition) angefahren haben, bevor du in Automatik gehst. Damit hast Du dann das Problem der SAK Fahrt behoben.
 Dann kommen die nächsten Probleme, nämlich Deine Automatik Extern Schnittstelle.
  • finde ich gut    Danke, das hat mir geholfen    da stimmt was nicht
Menschen brauchen Roboter, aber auch Roboter brauchen Menschen.
Roboter sichern die Arbeitsplätze und den Fortschritt der Industrieländer, da sie kostengünstig und qualitativ hochwertig produzieren.
Ohne Automatisierung mit Robotern werden unsere Produkte in Billiglohnländern hergestellt.

DuranDC

  • Gast
Re: Active Status
« am: 05. Juli 2004, 10:21:00 »
<img border="0" alt="[Merci]" title="" src="graemlins/00000670.gif" />
  • finde ich gut    Danke, das hat mir geholfen    da stimmt was nicht

Mag Netizer

  • Gast
Re: Active Status
« am: 09. Juli 2004, 10:29:00 »
Hallo Zusammen.
 
 Sollte es sich um einen "echten" V-KRC handeln, dürfte das Programmiergerät (V-KCP) eigentlich nur zwei Stellungen am Betriebswahlschalter haben. rechts oben EXT, rechts unten T1. Der Handbetrieb wird in diesem Falle durch einen (externen) Schalter auf T2 Betrieb gesetzt (E7), das Verfahren des Roboters bei offenem Schutzkreis wird durch einen weiteren Schalter ermöglicht (E2).
 
 Die Hardware der V-KRC unterscheidet sich meines Wissens in der verwendeten Sicherheitslogik. Bei der V-KRC 1 Steuerung befindet sich eine "Sicherheitskreis-Platine" auf der Forderseite des PC-Racks. Diese Platine überwacht die oben genannten Schalter E2/E7.
 
 Ich hoffe das hilft Dir noch ein wenig weiter.
 Gruß Mag
  • finde ich gut    Danke, das hat mir geholfen    da stimmt was nicht


xx
Status Bits

Begonnen von grape2k

2 Antworten
1875 Aufrufe
Letzter Beitrag 21. November 2006, 12:49:12
von grape2k
xx
Status und Turn

Begonnen von schludy

3 Antworten
3178 Aufrufe
Letzter Beitrag 17. März 2009, 13:59:27
von schludy
xx
Status SYS-X44 an SPS senden

Begonnen von Roland Keller

4 Antworten
1286 Aufrufe
Letzter Beitrag 30. Mai 2018, 10:24:48
von Roland Keller
xx
Status und Turn Angaben

Begonnen von John Silver

3 Antworten
2946 Aufrufe
Letzter Beitrag 10. März 2007, 09:08:04
von stefanM
xx
Status Key aktivieren / einschalten

Begonnen von CK1980

1 Antworten
372 Aufrufe
Letzter Beitrag 22. November 2017, 13:38:26
von SJX
 

über das Roboterforum

Nutzungsbedingungen Impressum

Seite erstellt in 0.083 Sekunden mit 52 Abfragen.

Sitemap