Roboterprofis für Ihren Erfolg
Roboterprogrammierer auf Stundenbasis engagieren
jetzt Preise und verfügbare Roboterprogrammierer anfragen

Autor Thema:  Probleme mit WinOLPC  (Gelesen 4701 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Ralf74

  • Gast
Probleme mit WinOLPC
« am: 13. August 2005, 15:43:19 »
Servus,
ich hätte da mal eine Anfrage bezüglich WinOLPC...
Ich habe bisher nur Erfahrung mit der Programmierung mit Reis Robotern und muss jetzt einen Fanuc programmieren. Es ist ein R2000iA mit einem TP Rj3b (Farbe).
Da meine Firma nicht das Geld für ein Offline Paket ausgibt, habe ich mir eine WinOLPC Version von einem Bekannten besorgt.
Nun zu meinem Problem... Wenn ich die Dateien mit WinTPE einlesen möchte meckert WinTPE das die Datei Framevar.sv nicht gelesen werden kann.
Ich hoff, dass mir jemand da helfen kann.... Ich weiss übrigens auch nicht was es mit dieser im Programm auswählbaren Vxxx Version auf sich hat...
Die Version von WinOLPC ist V6.11 Rev_A

M.f.G.
Ralf
  • finde ich gut    Danke, das hat mir geholfen    brauche Hilfe    da stimmt was nicht    Lesenswert

audi123

  • Gast
Re: Probleme mit WinOLPC
« am: 14. August 2005, 05:02:08 »
Hi Ralf,

wenn Du nicht die Masse an Fanuc-Robotern zu programmieren hast, lohnt sich sie Anschaffung von WinOLPC wirklich nicht...
Und da Du auch das iPendant zu Verfügung hast, besitzt Du ja das beste "Werkzeug" zum programmieren.

Die im Programm auswählbaren Versionen Vxxx stehen für den Softwarestand des Betriebssystems auf der Steuerung.

Ich gehe mal davon aus, dass Du mit einlesen das Öffnen der Programme meinst.

Du hast  folgende Möglichkeiten die Programme zu bearbeiten:

- direkt online aus WinTPE
  Vorteil: alle benötigten Dateien ( z.B. framevar.sv) werden online eingelesen
  Nachteil: Änderungen werden direkt an die Steuerung übertragen (keine Datensicherung mehr
  vorhanden)

- laden der Daten mit dem in WinOLPC enthaltenen File Transfer über Ethernet
- laden der Daten über die PCMCIA-Schnittstelle des Roboters auf eine MC-Card
- laden der Daten mit KFloppy über serielle Schnittstelle (Uralt-Methode mit Uralt-Steuerungen)

Nun sollte man die gesamte Sicherung in das Programmverzeichnis von
   WinOLPC\Shared\Virtual Robots\%Anlagenname% kopieren.
Dort sind auch zwei Example-Robots nach der Installation vorhanden. ( Kannst Du zum Testen auch mal ausprobieren)
Nun erscheint der Roboter auch im Menü "Datei" unter WinOLPC.
Danach Roboter auswählen.
Nun kommt bei neuen Roboterdaten die bekannte Frage mit Vxxx.
Einfach mal die unterste Version nehmen und auf den Button für WinTPE klicken.

Jetzt sollte eigentlich WinTPE starten... "Lade virtuellen Roboter usw...."

Die Fehlermeldung tritt bei mir nur manchmal auf, wenn ich versuche Daten von MC-Sicherungen zu laden.
Wie Du feststellen wirst, sind es bei Sicherung mit File Transfer weitaus mehr Dateien.
Einfach mal ein bisschen ausprobieren.


Was ich natürlich nicht für Dich hoffe, dass es am Betriebssystem des Rechners liegt.
Habe selbst auf manchen Rechnern mit XP Pro WinOLPC zwar installiert aber nicht zum laufen gebracht.
Waren auch immer Fehlermeldungen beim Starten von WinTPE, wo irgendwelche Dateien gefehlt haben oder nicht gelesen werden konnten.
Bin mir jetzt nicht ganz sicher, aber ich glaube V6.11 Rev. A ist nicht die neueste Version. (falls XP)

Hoffe ich konnte Dir ein bisschen weiterhelfen.

Dann noch viel Spaß mit dem Fanuc.

Audi123

P.S.: An alle Nicht-Bayern: Wusstet Ihr, daß bei uns am Montag Feiertag ist.... :lol: :D :mrgreen: :uglyhammer_2:
  • finde ich gut    Danke, das hat mir geholfen    brauche Hilfe    da stimmt was nicht    Lesenswert

Ralf74

  • Gast
Re: Probleme mit WinOLPC
« am: 14. August 2005, 11:35:00 »
Servus

@Audi 123    Danke für deine Antwort... Du hast das Problem schon richtig verstanden.....
Ich habe ein Backup über PCIMCIA auf eine MC - Karte gemacht....
Ich hab dann einen Roboter hinzugefügt, so wie du es auch schon beschrieben hast.
Sobald ich dann sage, das WinOLPC ein TP - Programm öffnen soll kommt die beschriebene Fehlermeldung. Ich kann das Problem umgehen, indem ich die Framevar.sv in dem Verzeichnis lösche. Dann kann ich mir alle Programme anschauen.... aber das ist ja nur ein Umgehen des Problems aber nicht die Lösung.
(ich habe es schon mit allen vorhandenen SW-Version in WinOPLC probiert...)

Ich werde deine Tips mit dem File Services mal ausprobieren....

Gruss Ralf
  • finde ich gut    Danke, das hat mir geholfen    brauche Hilfe    da stimmt was nicht    Lesenswert

Offline Sven Weyer

  • Global Moderator
  • Forum Legende LV 1
  • *
  • Beiträge: 1069
  • Bewertet: +20
Re: Probleme mit WinOLPC
« am: 15. August 2005, 14:57:42 »
Hallo Ralf74,
dein Problem tritt, so nehme ich an, nur roboterabhängig auf. Wir haben schon mehrere FANUC's auch dieser Baureihe verarbeitet. Bei manchen hat diese Framevar.sv Probleme bereitet und bei manchen die *.io Files. Dieses wiederum auch Roboter abhängig.

@audi123: Arbeite mit V5.20 RevD problemlos unter XP Prof.

Habe auch schon bei FANUC ein wenig nachgeforscht. Wenn man besagte Backups zu FANUC schickt können diese dort angeblich problemlos gelesen werden.

Nja enutze diese Software eh bloß für das Offline erstellen von Programmen demnach spiellt das nicht so eine entscheidende Rolle.


Bis denne

robotic74

P.S.: @audi123: Du wirst es nicht glauben aber es will trotzdem nicht jeder ein Bayer sein.  :mrgreen:
  • finde ich gut    Danke, das hat mir geholfen    brauche Hilfe    da stimmt was nicht    Lesenswert
Wer nichts macht macht keine Fehler!
Wer keine Fehler macht kann nichts daraus lernen!
Wer nichts lernen kann kann sich nicht weiterentwickeln!
Wer sich nicht entwickelt geht unter!

Offline rob76

  • Global Moderator
  • Forum Elite LV 4
  • *
  • Beiträge: 284
  • Bewertet: +3
Re: Probleme mit WinOLPC
« am: 21. Januar 2006, 01:46:54 »
späte antwort aber vielleicht hat noch jemand das problem.
winolpc 6.11 war die letzte version ohne kopierschutz . aktuelle version ist 6.40.
das ganze tritt auf wenn das roboterbetriebsystem höher als v6.11 ist wie die winolpc.
in deinem fall mindestens v6.30 wegen dem i-pendant.
die version die ihr bei winolpc einstellen könnt wirkt sich zum beispiel auf den karel kompiler aus.
es muss die selbe version eingestellt werden wie das betriebssystem des roboters, wenn man programme kompilieren möchte.
nun zur framevar: in der framevar.sv werden die ganzen koordinatensystem einstellungen gespeichert (user/tool/jogframe)
ihr braucht nur die framevar löschen oder umbenennen allerdings kann wintpe dann nicht mehr die koordinaten von punkten ändern.
da man mit positionen aber eh nix vernünftiges offline in wintpe machen kann sollte das kein problem sein.
oder alternativ eine legale version erwerben :mrgreen:
« Letzte Änderung: 21. Januar 2006, 01:54:00 von rob76 »
  • finde ich gut    Danke, das hat mir geholfen    brauche Hilfe    da stimmt was nicht    Lesenswert


xx
Fanuc WinOLPC Library 5.30 KAREL Compiler

Begonnen von timmey89

3 Antworten
1014 Aufrufe
Letzter Beitrag 12. Oktober 2017, 14:31:19
von ribdancer
xx
Probleme mit Orientierung

Begonnen von cosmo

8 Antworten
1911 Aufrufe
Letzter Beitrag 27. September 2013, 14:06:24
von cosmo
xx
Probleme mit LTRK vor dem falzen

Begonnen von Xylo

1 Antworten
717 Aufrufe
Letzter Beitrag 20. März 2014, 12:10:45
von Xylo
xx
Probleme mit 128MB Speicherkarten

Begonnen von Roberto

6 Antworten
2373 Aufrufe
Letzter Beitrag 19. Januar 2008, 11:18:59
von Michael USA
clip
Probleme mit USERFRAME und Koordinaten

Begonnen von mctailor

5 Antworten
1821 Aufrufe
Letzter Beitrag 04. Juli 2013, 10:56:16
von RoboKopp
 

über das Roboterforum

Nutzungsbedingungen Impressum
Sitemap