Roboterprofis für Ihren Erfolg
Roboterprogrammierer auf Stundenbasis engagieren
jetzt Preise und verfügbare Roboterprogrammierer anfragen

Autor Thema:  Problem mit uninitializierung !  (Gelesen 2558 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

roboguide

  • Gast
Problem mit uninitializierung !
« am: 28. März 2007, 09:59:42 »
Hallo,

nach 100 Mal "Call Prog" bei Serienprozess sind die begrenzte Call-Systemvariable erreichen wurden, dann krieg ich Problemm mit uninitialized Data (INTP-311)!
Außer Karel, ob ich auch Call-Systemvariable eine Möglichkeit zurücksetzen kann ?

Gruß Roboguide
  • finde ich gut    Danke, das hat mir geholfen    brauche Hilfe    da stimmt was nicht    Lesenswert

Offline rob76

  • Global Moderator
  • Forum Elite LV 4
  • *
  • Beiträge: 284
  • Bewertet: +3
Re: Problem mit uninitializierung !
« am: 28. März 2007, 23:01:06 »
das musst du mal genauer erläutern, fürchte sonst versteht hier keiner was du meinst.
kann mir eigentlich nicht vorstellen das es mit dem call zusammenhängt. bei zutief verschachtelten call's bekommst du normal probleme mit dem stack aber nicht mit uninitialisierten daten. kannst ja mal einen prog auszug hier reinstellen.
  • finde ich gut    Danke, das hat mir geholfen    brauche Hilfe    da stimmt was nicht    Lesenswert

roboguide

  • Gast
Re: Problem mit uninitializierung !
« am: 29. März 2007, 14:02:08 »
Hallo rob76,

mit dem stack hatte ich schon gedach und auch einigen Maßnahme gemacht!
meisten die Programme sieht so aus:

Job01
1: J P[1] 50% FINE ;
2: ! CALL PROG12
3: CALL PROG12  ;
4: ! MOVE TO HOME
5: CALL HOME;
/END


PROG12
1: L  P[2]  1200mm/sec  CNT100 
2: L  P[3]  1000mm/sec  CNT50 Preset(1)
3: L  P[4]  1000mm/sec  CNT100 Gun(on)
4: L  P[5]  1000mm/sec  CNT100
5: L  P[6]  1000mm/sec  CNT100
6: L  P[7]  1000mm/sec  CNT100
7: L  P[8]  1000mm/sec  CNT100
8: L  P[18]  600mm/sec  CNT100  Gun=OFF
9: L  P[19]  1000mm/sec  CNT100
/End

die Warnmeldung INTP-311 besieht aus dem Handbuch !
  • finde ich gut    Danke, das hat mir geholfen    brauche Hilfe    da stimmt was nicht    Lesenswert

Offline rob76

  • Global Moderator
  • Forum Elite LV 4
  • *
  • Beiträge: 284
  • Bewertet: +3
Re: Problem mit uninitializierung !
« am: 29. März 2007, 20:14:14 »
sieht eigentlich alles ok aus.
hier mal die original fehlerbeschreibung:

INTP-311 PAUSE (%s^4, %d^5) Uninitialized data is used
Cause: KAREL program error. Untaught or uninitialized data was used.

Remedy: Teach or initialize the data before using it.


die fehlermeldung gibt dir doch den prg name und die zeilennummer an wo er aussteigt.
genau diese zeile wäre mal interessant.
  • finde ich gut    Danke, das hat mir geholfen    brauche Hilfe    da stimmt was nicht    Lesenswert

Offline heini0707

  • Forum Elite LV 6
  • *
  • Beiträge: 346
  • Bewertet: +1
Re: Problem mit uninitializierung !
« am: 30. März 2007, 19:56:49 »
Hi,

bist du sicher, dass das Problem im PROG12 ist?
Ich würde sagen, dass du Problem mit HOME hast, ist es dein Programm oder von Fanuc?
Bei der Rj3iC gibt schon vom Haus aus so ein ähnliches Programchen wo du für Homeposition den PR1 belegen musst.
Teatche einfach den PR1 und dann starte dein JOB01.

 :dadr:
  • finde ich gut    Danke, das hat mir geholfen    brauche Hilfe    da stimmt was nicht    Lesenswert


xx
RO Problem

Begonnen von DelphiMTH

1 Antworten
975 Aufrufe
Letzter Beitrag 23. August 2013, 17:22:26
von theanni
xx
Programm Problem

Begonnen von Pat-187

7 Antworten
1700 Aufrufe
Letzter Beitrag 18. Juni 2014, 09:40:17
von Pat-187
xx
Problem bei Koordinatensystem

Begonnen von cando_o

4 Antworten
1503 Aufrufe
Letzter Beitrag 05. August 2012, 13:44:51
von cando_o
xx
Problem mit PR-Register

Begonnen von Golfsucht

10 Antworten
2721 Aufrufe
Letzter Beitrag 17. Mai 2016, 10:04:16
von rob76
xx
Problem mit FTP auf Roboguide

Begonnen von 0815hans

1 Antworten
1252 Aufrufe
Letzter Beitrag 10. August 2011, 13:01:29
von WolfHenk
 

über das Roboterforum

Nutzungsbedingungen Impressum
Sitemap