23. Mai 2019, 02:51:49
Roboterforum.de - Die Industrieroboter- Anwender und Experten Community

 Duplicate creation type mismatch Fehler


normal_post Autor Thema:  Duplicate creation type mismatch Fehler  (Gelesen 5016 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

25. Mai 2006, 12:38:15
Gelesen 5016 mal

Ania

Gast
Hallo,

Ich schreibe Programmen in KAREL. Kompiliere das Programm mit WinOLPC.
Dann ich mochte das Program in Roboguide simulieren. Ich kenne wie load das Program in Wirtual Controller aber wenn ich mache das es gibt ein Fehler:Duplicate creation TYPE mismatch. Ich weiss nicht was ist das. Ich muss die Simulation machen.

Fur Ihre hilfe vielen dank

Grusse

Ania
« Letzte Änderung: 31. Mai 2006, 10:03:15 von Werner Hampel »
  • gefällt mir    Danke

Heute um 02:51:49
Antwort #1

Werbung

Gast

28. Mai 2006, 15:53:53
Antwort #1
Offline

rob76

Global Moderator
Das kommt vor wenn die in WINOLPC eingestellte Softwareversion nicht mit der deines virtuellen Roboters übereinstimmt.

Wenn du z.B. in Roboguide einen Roboter mit Handlingtool V6.30 erzeugst muss auch das karelprog mit der Version 6.30 kompiliert werden.
  • gefällt mir    Danke

01. Juni 2006, 10:55:47
Antwort #2
Offline

mwe


Hallo,

der Fehler "Duplicate Creation ..." kommt auch dann vor, wenn sich im Roboterspeicher bereits ein Programm befindet, welches namentlich die gleichen Variablen beinhaltet. Bevor Du dein Programm in den Roboter lädtst, muss das "alte" Programm (inkl. des .VR) aus dem SELECT-Menü gelöscht werden!!!

Bitte um Rückmeldung, wenn's nicht funktioniert!!!

Gruß
mwe 
  • gefällt mir    Danke

02. Juni 2006, 07:46:41
Antwort #3

Ania

Gast
Hallo mwe,

Ja, dass ist gute idee ich wurde das probieren und ich schriebe ob dass hilfst. Ich wiesse dass die idee mit softwareversion ist gut aber es gibt ein fehler dass sagt: "Softwareversion too old".
Vielen dank

sorry for my deutsch it's quite poor:)
 :danke:
  • gefällt mir    Danke

02. Juni 2006, 07:50:05
Antwort #4
Offline

mwe


Hi Ania,

you can post your messages in english if it is easier for you.
My english is not the best but good enough for problems like yours.

Keep on compiling!!!

Greetz

mwe
  • gefällt mir    Danke

Heute um 02:51:49
Antwort #5

Werbung

Gast

02. Juni 2006, 08:06:03
Antwort #5
Offline

WolfHenk


hi
Error "Softwareversion too old" says that your robots System is too old for your Compiler: Fanucs older Karel Compilers are not reverse compatible.

Tell us what compiler version you use and what Karel-version is on your Robot

thx

  • gefällt mir    Danke
Wolfram (Cat) Henkel

never forget Asimov's Laws at the programming of robots...

"Safety is an integral part of function. No safety, no production. I don't buy a car without brakes."

https://www.xing.com/go/invite/5634410.eb15e5

PMs und Mails mit Anfragen wie "Wie geht das..." werden nicht beantwortet. Diese Fragen und die Antworten interessieren jeden hier im Forum.

02. Juni 2006, 17:59:54
Antwort #6

Ania

Gast
Hi,

There is winOLPC V6.11 and in my roboguide (6.31) I have two software versions to choose. It's 6.22 and 6.31. The same mistake appears in workcells with software version 6.22 and 6.31.

Any idea?

Thanks for any help:)
  • gefällt mir    Danke

02. Juni 2006, 21:21:51
Antwort #7
Offline

WolfHenk


try to find out the robots karel-version...

  • gefällt mir    Danke
Wolfram (Cat) Henkel

never forget Asimov's Laws at the programming of robots...

"Safety is an integral part of function. No safety, no production. I don't buy a car without brakes."

https://www.xing.com/go/invite/5634410.eb15e5

PMs und Mails mit Anfragen wie "Wie geht das..." werden nicht beantwortet. Diese Fragen und die Antworten interessieren jeden hier im Forum.

02. Juni 2006, 22:11:24
Antwort #8

Ania

Gast
Maybe this question is stupid but my adventure with Roboguide is quite short and poor
How may I check robots karel-version?
  • gefällt mir    Danke

Heute um 02:51:49
Antwort #9

Werbung

Gast

03. Juni 2006, 19:20:33
Antwort #9
Offline

Sven Weyer

Global Moderator
Hi Ania,
thanks for use this german forum.
We have also installed a english forum! www.robot-forum.com.
I think when you use this side you have mor connection on the english guy wich use robots, maybe!  :zwink:

Take care!

robotic74

P.S.: The most of the guys here knows about this side and look on this.
  • gefällt mir    Danke
Wer nichts macht macht keine Fehler!
Wer keine Fehler macht kann nichts daraus lernen!
Wer nichts lernen kann kann sich nicht weiterentwickeln!
Wer sich nicht entwickelt geht unter!

09. Juni 2006, 11:22:08
Antwort #10
Offline

mwe


Hi Ania,

as far as I know is the software version in the robot the main thing.
If you use in ROBOGUIDE a version e.g. V6.30 you can run all KAREL files compiled with WinOLPC V6.30 or higher.
I couldn't find a KAREL-Version ID on the robot.

The following software should be activated in your Controller:
KAREL Run-Time Env    J539
KAREL Cmd. Language   J650

That's it!

Regards
mwe
  • gefällt mir    Danke


Teile per facebook Teile per linkedin Teile per pinterest Teile per reddit Teile per twitter
 

über das Roboterforum

Nutzungsbedingungen Impressum Datenschutzerklärung

Sponsoren des Roboterforums

ROBTEC GmbH