ABB Roboterschulung von praxiserfahrenen Trainern
in unserem Schulungszentrum in Mainburg oder vor Ort bei Ihnen
Bediener und Expertenschulungen anfragen

Autor Thema:  Diskussion zu Kuka.CAMRob & Kuka.Milling 8kW  (Gelesen 13602 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline IrrerPolterer

  • Administrator
  • Forum Legende LV 6
  • *
  • Beiträge: 2233
  • Normale Menschen machen mir Angst.
    • 2-Connect GmbH
  • Bewertet: +68
Re: Diskussion zu Kuka.CAMRob & Kuka.Milling 8kW
« Antwort #15 am: 31. Januar 2007, 10:18:56 »
Hallo!

Hatte gestern zum ersten mal die richtigen Produktdaten und somit den ersten echten Test. Dabei traten eine Menge Probleme auf.
1. Der Robi sollte einen Kreis fahren und dieser war dann sehr...eckig...und wurde auch sehr ruckartig in Einzelschritten gefahren, obwohl ich die Punktereduzierung auf fein getellt hatte.
2. Spindel einschalten und Drehzahl setzen erfolgte nicht automatisch. Das Ausschalten schon.
3. Im Eilgang (Kommando G0) schleicht der Robi, obwohl im Job 60000mm/min angegeben wurde.

Noch ein paar andere Sachen sind aufgetreten. Aber die o.g. sind die momentan nervigsten....


  • finde ich gut    Danke, das hat mir geholfen    brauche Hilfe    da stimmt was nicht    Lesenswert
Greetings, Irrer Polterer!

Wie poste ich falsch?
Nachdem ich die Suche und die FAQ erfolgreich ignoriert habe, erstelle ich das gleiche Thema in mehreren Unterforen, benutze einen sehr kreativen Titel wie "Hilfe", am Besten noch mit mehreren Ausrufezeichen, und veröffentliche einen so eindeutigen Text, dass sich jeder etwas Anderes darunter vorstellt.

Life is a beta version. Full of bugs and no Manual.

Offline IrrerPolterer

  • Administrator
  • Forum Legende LV 6
  • *
  • Beiträge: 2233
  • Normale Menschen machen mir Angst.
    • 2-Connect GmbH
  • Bewertet: +68
Re: Diskussion zu Kuka.CAMRob & Kuka.Milling 8kW
« Antwort #15 am: 01. Februar 2007, 12:08:18 »
So die meisten Dinge sind jetzt erledigt.
2 Probleme noch:

1. Der böse Roboter will nicht automatisch das Tool wechseln, wenn er in den NC-Daten dieses Kommando bekommt. Ich muß immer vor dem Aufruf des Bin-Files per ILF sagen: LOADTOOL Tool.Nr

2. Beim automatischen Einschalten der Spindel innerhalb eines Bin-Files kommt die Meldung "Warte auf Drehzahl erreicht." Wenn ich dann "Simuliere" drücke, startet die Spindel und läuft hoch zur gewünschten Drehzahl.

Wer weiß da Rat?
  • finde ich gut    Danke, das hat mir geholfen    brauche Hilfe    da stimmt was nicht    Lesenswert
Greetings, Irrer Polterer!

Wie poste ich falsch?
Nachdem ich die Suche und die FAQ erfolgreich ignoriert habe, erstelle ich das gleiche Thema in mehreren Unterforen, benutze einen sehr kreativen Titel wie "Hilfe", am Besten noch mit mehreren Ausrufezeichen, und veröffentliche einen so eindeutigen Text, dass sich jeder etwas Anderes darunter vorstellt.

Life is a beta version. Full of bugs and no Manual.

esperanza

  • Gast
Re: Diskussion zu Kuka.CAMRob & Kuka.Milling 8kW
« Antwort #15 am: 01. Februar 2007, 12:34:19 »

Zu1.) Bei meinem Versuchsaufbau verwende ich nicht LOADTOOL vom CAMROB Programm. Mach das wie bei jedem anderen Toolwechsel bei Standardapplikationen mit Robi. D.h. hab verschiedene Tools vermessen und wähle das entsprechende aus. Werkzeugwechsel an sich geht in der Versuchszelle manuell, soll dann später aber über ein pneumatisches STandard-WErkzeugwechselsystem erfolgen.

Zu 2.) Ich mach das ganz primitiv mit Ausgang setzten zum starten bzw. stoppen der Spindel und m it "waitfor Frequenz erreicht". Funktioniert wunderbar. Hab keine Probleme

Hoffe konnte dir weiterhelfen, ansonsten melde ich doch einfach nochmal

CU
Lisa
  • finde ich gut    Danke, das hat mir geholfen    brauche Hilfe    da stimmt was nicht    Lesenswert

esperanza

  • Gast
Re: Diskussion zu Kuka.CAMRob & Kuka.Milling 8kW
« Antwort #15 am: 01. Februar 2007, 12:38:50 »

zu3.) hast du mal in dein NC-Programm geschaut ob irgendwo die Geschwindigkeit falsch ausgegeben wurde? hatte das gleiche problem. Aus irgendeinem Grund war kurz vor Bahnstart die Geschwindigkeit auf 600 mm/min und das ist im Testmodus kaum sichtbar. Musste damals das NC-Programm neu generieren und neu konvertieren. Dann ging es
  • finde ich gut    Danke, das hat mir geholfen    brauche Hilfe    da stimmt was nicht    Lesenswert

Offline IrrerPolterer

  • Administrator
  • Forum Legende LV 6
  • *
  • Beiträge: 2233
  • Normale Menschen machen mir Angst.
    • 2-Connect GmbH
  • Bewertet: +68
Re: Diskussion zu Kuka.CAMRob & Kuka.Milling 8kW
« Antwort #15 am: 01. Februar 2007, 15:22:28 »
Leider hat mir das nicht geholfen. Schade eigentlich...

Das mit den Geschwindigkeiten hab ich im Griff. War Doofheit!  :pfeif:

Aber einen automatischen Werkzeugwechsel aus dem Bin-File heraus hätte ich gern. Und das Problem mit der Spindel aus dem Bin-File heraus wäre auch schön...

 :bawling:
  • finde ich gut    Danke, das hat mir geholfen    brauche Hilfe    da stimmt was nicht    Lesenswert
Greetings, Irrer Polterer!

Wie poste ich falsch?
Nachdem ich die Suche und die FAQ erfolgreich ignoriert habe, erstelle ich das gleiche Thema in mehreren Unterforen, benutze einen sehr kreativen Titel wie "Hilfe", am Besten noch mit mehreren Ausrufezeichen, und veröffentliche einen so eindeutigen Text, dass sich jeder etwas Anderes darunter vorstellt.

Life is a beta version. Full of bugs and no Manual.

esperanza

  • Gast
Re: Diskussion zu Kuka.CAMRob & Kuka.Milling 8kW
« Antwort #15 am: 01. Februar 2007, 16:32:58 »
sorry, dass ich dir nicht weiterhelfen konnte.

Bei meinem Projekt geht es eigentlich auch mehr um Genauigkeitsuntersuchungen und um Möglichkeiten des Einsatztes zu analysieren. Um solche dinge wie Werkzeugwechsel, spindelantrieb über bin-file hab ich mich daher gar nicht groß gekümmert. Ist ein Laborprojekt bei dem der Prozess einfach nur funktionieren und implementiert werden sollte. von den komponenten her sehr einfach aufgebaut
  • finde ich gut    Danke, das hat mir geholfen    brauche Hilfe    da stimmt was nicht    Lesenswert

Offline IrrerPolterer

  • Administrator
  • Forum Legende LV 6
  • *
  • Beiträge: 2233
  • Normale Menschen machen mir Angst.
    • 2-Connect GmbH
  • Bewertet: +68
Re: Diskussion zu Kuka.CAMRob & Kuka.Milling 8kW
« Antwort #15 am: 01. Februar 2007, 18:59:39 »
Hallo,

das mit dem Toolwechsel hab ich rausbekommen. Ich habe NC Daten von 7 Bearbeitungsschritten. Wenn in Schritt 1 nur TOOL1 benötigt wird und in Schritt 2 nu TOOL2, findet kein Wechsel statt. Das muß man dann vor dem NC-File in CAMRob sagen mit CAMRob.LOADTOOL 1 oder eben CAMRob.LOADTOOL 2.
Findet in Schritt 1 ein Toolwechsel statt, wird dieser Automatisch ausgeführt.

Gut, wenn man schlaue Menschen bei KUKA kennt. Hilft einem echt weiter! :)
  • finde ich gut    Danke, das hat mir geholfen    brauche Hilfe    da stimmt was nicht    Lesenswert
Greetings, Irrer Polterer!

Wie poste ich falsch?
Nachdem ich die Suche und die FAQ erfolgreich ignoriert habe, erstelle ich das gleiche Thema in mehreren Unterforen, benutze einen sehr kreativen Titel wie "Hilfe", am Besten noch mit mehreren Ausrufezeichen, und veröffentliche einen so eindeutigen Text, dass sich jeder etwas Anderes darunter vorstellt.

Life is a beta version. Full of bugs and no Manual.

Offline Krause-LIB

  • Forum Mitglied LV 10
  • *
  • Beiträge: 99
    • Deutschsprachige RobotWorks Seite
  • Bewertet: 0
Re: Diskussion zu Kuka.CAMRob & Kuka.Milling 8kW
« Antwort #15 am: 21. Juni 2007, 12:11:13 »
Hallo Esperanza,


ich wollte mich nach dem Stand Deiner Diplomarbeit erkundigen (Ich hoffe Du hast die Arbeit erfolgreich abgeschlossen! :supi:) und bin außerdem sehr gespannt auf Deinen Erfahrungsbericht. Hast Du schon eine Idee wann Du den Erfahrungsbericht posten wirst?

Gruß Wolfgang
 
  • finde ich gut    Danke, das hat mir geholfen    brauche Hilfe    da stimmt was nicht    Lesenswert
RobotWorks
CAT Computer Aided Teaching
Vom CAD per Mausklick zur Roboterbewegung


xx
Kuka.CAMRob & Kuka.Milling 8kW

Begonnen von IrrerPolterer

2 Antworten
7700 Aufrufe
Letzter Beitrag 15. Dezember 2006, 08:48:23
von IrrerPolterer
 

über das Roboterforum

Nutzungsbedingungen Impressum
Sitemap