22. Juli 2019, 20:49:18
Roboterforum.de - Die Industrieroboter- Anwender und Experten Community

[offen] Start Roboter von SPS Probleme


normal_post Autor Thema: [offen] Start Roboter von SPS Probleme  (Gelesen 1682 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

01. August 2018, 11:15:42
Gelesen 1682 mal
Offline

kliebisch.m


Moin alle zusammen,
ich habe einen 6700 und starte über SPS den Robi. Hat jemand ein Diagramm mit dem Handshake zwischen SPS und Roboter? Ich habe einen Handle Baustein, der schein aber einen Fehler zu haben, da der Roboter ein paar mal startet, und dann wieder mal nicht (Fehler Programmübernahme Signal di_ProgNrOK=0)
Herzlichen Dank
  • gefällt mir    Danke

Heute um 20:49:18
Antwort #1

Werbung

Gast

02. August 2018, 07:49:08
Antwort #1
Offline

Hermann


Dabei wird Dir nur der ursprüngliche Programmierer weiterhelfen können.
Das Signal ist kein Systemsignal. Ist also vom Programmierer selbst gebautes Zeug.

Oder halt die Programme posten, wird aber nicht wirklich helfen, da es ja eher wie ein Blinker läuft: geht / geht nicht ... :mrgreen: 
Es wird nur eine Fehleranalyse am laufenden Gerät helfen.

  • gefällt mir    Danke

02. August 2018, 08:58:31
Antwort #2
Offline

kliebisch.m


Danke der Antwort.
Ich habe das Problem gefunden. Ein Signal kam nicht lang genug und wurde zu schnell zurückgesetzt.
  • gefällt mir    Danke

05. August 2018, 20:40:19
Antwort #3
Offline

Robiman

Global Moderator
schön das es wieder geht
bedeutet aber auch das es kein richtiges Handshake ist
  • gefällt mir    Danke

06. August 2018, 13:04:05
Antwort #4
Offline

Hermann


"Nicht lange genug" heisst nicht unbedingt dass es über eine Zeit gesteuert ist, könnte genauso gut heissen:
nicht so lange bis das Quittiersignal gekommen ist, dann wäre es schlicht und einfach ein Programmierfehler.  :zwink:
  • gefällt mir    Danke

Heute um 20:49:18
Antwort #5

Werbung

Gast


Teile per facebook Teile per linkedin Teile per pinterest Teile per reddit Teile per twitter
 

über das Roboterforum

Nutzungsbedingungen Impressum Datenschutzerklärung

Sponsoren des Roboterforums

ROBTEC GmbH