Roboterprofis für Ihren Erfolg
Roboterprogrammierer auf Stundenbasis engagieren
jetzt Preise und verfügbare Roboterprogrammierer anfragen

Autor Thema:  sporadische merker nicht beachtung ???  (Gelesen 2400 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline roboprog

  • Forum Elite LV 3
  • *
  • Beiträge: 258
    • Krauss-Maffei Automation
  • Bewertet: 0
sporadische merker nicht beachtung ???
« am: 20. Dezember 2006, 17:28:30 »
hallo zusammen habe in problem mit meinem permanenten hintergrund task an einer irc5 steuerung

habe sowas hir geschrieben funktioniert auch prima (ab und zu)

! Set Start
IF (input1 = 1) and (input2= 0)  THEN
   merker := 1;
ENDIF
   
! Reset Start
IF (input3 = 1) or (input1= 0) THEN
   merker := 0;
ENDIF

SetDO output1,merker;

das schlimme ist nur der output1 wird 1,2,3,4,5.......  mal gesetzt und dann irgendwann nicht mehr
nach einem neustart des programmes geht das dann wieder ein paar mal
nun habe ich das geschrieben


! Set Start
IF (input1 = 1) and (input2= 0)  THEN
   SetDO output1,1;
ENDIF
   
! Reset Start
IF (input3 = 1) or (input1= 0) THEN
   SetDO output1,0;
ENDIF

!SetDO output1,merker;

und das funktioniert einwandfrei
so weit so gut
jetzt brauch ich nur noch jemanden der mir das mal erklärt
ich würde nämlich gerne den merker noch wo anders verwenden aber wenn ich mir nicht sicher sein kann ob er gesetzt wird oder nicht ist das hinfällig

 :kopfkratz:

danke im voraus
Roboprog
  • finde ich gut    Danke, das hat mir geholfen    brauche Hilfe    da stimmt was nicht    Lesenswert
Die dümmsten Programmierer haben die dicksten Programme


ABB Robotertraining
günstig und verständlich mit Zertifikat
ABB Roboterschulung

Offline roboprog

  • Forum Elite LV 3
  • *
  • Beiträge: 258
    • Krauss-Maffei Automation
  • Bewertet: 0
Re: sporadische merker nicht beachtung ???
« am: 21. Dezember 2006, 13:25:02 »
weis hier niemand warum das so ist ???
  • finde ich gut    Danke, das hat mir geholfen    brauche Hilfe    da stimmt was nicht    Lesenswert
Die dümmsten Programmierer haben die dicksten Programme

Offline roboprog

  • Forum Elite LV 3
  • *
  • Beiträge: 258
    • Krauss-Maffei Automation
  • Bewertet: 0
Re: sporadische merker nicht beachtung ???
« am: 21. Dezember 2006, 16:43:50 »
hmmmm..

anscheinend nicht na gut es geht ja auch so !!

für infos bin ich trotzdem dankbar

danke und gruß
roboprog
  • finde ich gut    Danke, das hat mir geholfen    brauche Hilfe    da stimmt was nicht    Lesenswert
Die dümmsten Programmierer haben die dicksten Programme

Offline Sven Weyer

  • Global Moderator
  • Forum Legende LV 1
  • *
  • Beiträge: 1056
  • Bewertet: +17
Re: sporadische merker nicht beachtung ???
« am: 21. Dezember 2006, 18:42:03 »
Hallo roboprog,
grundsätzlich habe ich einen Verdacht. Aber Du weißt ja wie das ist mit Verdächtigungen. Diese werden in schriftlicher Form immer schnell zu Tatsachen.
Wenn es Dir möglich wäre kannst Du mir ja mal ein Backup zukommen lassen dann kann ich mir das mal genauer ansehen. So wie es jetzt gemacht ist denke ich ganz grob das es ein interenes Sytsemthema sein kann. Da Variablen geschrieben werden müssen und ich nun nicht weiss wie Dein gesamtes Hintergundprogramm aussieht ist dies halt schwer zu sagen.

Ausserdem muss ich Dich um Geduld bitten. Das Forum ist kein Allheilmittel. Nur wer sich wirklich sicher ist oder schon Erfahrungen damit gemacht hat wird und kann Dir darauf antworten. Nun da Dein Thema sehr speziell ist wirst Du hier so schnell keine 100%ig Antwort bekommen.

robotic74

E-Mail: robotic74@roboter.com
  • finde ich gut    Danke, das hat mir geholfen    brauche Hilfe    da stimmt was nicht    Lesenswert
Wer nichts macht macht keine Fehler!
Wer keine Fehler macht kann nichts daraus lernen!
Wer nichts lernen kann kann sich nicht weiterentwickeln!
Wer sich nicht entwickelt geht unter!

Offline stromer

  • Forum Elite LV 7
  • *
  • Beiträge: 366
  • Denken hilft
  • Bewertet: 0
Re: sporadische merker nicht beachtung ???
« am: 03. Januar 2007, 09:33:51 »
Ich würde auch gern mal sehen, wie Deine Hauptschleife in dieser Task aussieht. Bei den Hintergrundtasks steckt der Teufel oft im Detail  :smiley:
  • finde ich gut    Danke, das hat mir geholfen    brauche Hilfe    da stimmt was nicht    Lesenswert

Offline roboprog

  • Forum Elite LV 3
  • *
  • Beiträge: 258
    • Krauss-Maffei Automation
  • Bewertet: 0
Re: sporadische merker nicht beachtung ???
« am: 10. Januar 2007, 10:15:52 »
hallo zusammen

es tuht mir leid

ich würde euch gern den gesamten quelltext schicken
aber da würde mich mein boss in den a.... treten
firmeninterna und so !!
wir haben jetzt auch einen anderen weg gewählt wir benutzen
jetzt keine merker mehr sonder wir schalten virtuelle ausgänge und verarbeiten die dann weiter ist auch übersichtlicher zwecks zustands abfrage ........

danke und gruß

roboprog   :blumen:
  • finde ich gut    Danke, das hat mir geholfen    brauche Hilfe    da stimmt was nicht    Lesenswert
Die dümmsten Programmierer haben die dicksten Programme

Offline mischwarz

  • Forum Mitglied LV 15
  • *
  • Beiträge: 194
  • Bewertet: +5
Re: sporadische merker nicht beachtung ???
« am: 26. Januar 2007, 12:14:50 »
Hallo,

ein WaitTime 0.1 am Anfang der Schleife könnte schon das Problem lösen.Weil dadurch der HT Rechenzeit zugewiesen bekommt.
  • finde ich gut    Danke, das hat mir geholfen    brauche Hilfe    da stimmt was nicht    Lesenswert
Es gibt immer einen Weg. ( Wohin auch immer er führen mag )
mischwarz ANNO 2001

Offline GEEP

  • Forum Mitglied LV 2
  • *
  • Beiträge: 33
  • Bewertet: 0
Re: sporadische merker nicht beachtung ???
« am: 31. Januar 2007, 15:09:27 »
jaaa mit wait time 0.1   ist der fehler behoben....

ich hatte im sommer 06 das selbe problem in ner hintergrundtask.

  • finde ich gut    Danke, das hat mir geholfen    brauche Hilfe    da stimmt was nicht    Lesenswert

VivienneU

  • Gast
Re: sporadische merker nicht beachtung ???
« am: 07. Februar 2007, 19:55:07 »
[hey
  • finde ich gut    Danke, das hat mir geholfen    brauche Hilfe    da stimmt was nicht    Lesenswert


xx
Variablen als Merker deklarieren

Begonnen von Bjelzin

4 Antworten
470 Aufrufe
Letzter Beitrag 08. Februar 2017, 16:12:06
von Bjelzin
xx
S4C+ startet nicht

Begonnen von br-lr

3 Antworten
1608 Aufrufe
Letzter Beitrag 29. Juli 2011, 15:58:39
von 7seven
xx
Interrupt S4C+ funkt nicht

Begonnen von abb_robo

12 Antworten
2668 Aufrufe
Letzter Beitrag 20. September 2009, 19:33:19
von Sven Weyer
xx
Kalibrierungsposition nicht anfahrbar

Begonnen von frielex

3 Antworten
1152 Aufrufe
Letzter Beitrag 09. Januar 2014, 15:26:06
von Gerhard Reinig
xx
IRC 5 - Display reagiert nicht

Begonnen von Baruck

6 Antworten
1281 Aufrufe
Letzter Beitrag 01. August 2016, 02:03:55
von Baruck
 

über das Roboterforum

Nutzungsbedingungen Impressum
Sitemap