26. März 2019, 16:06:15
Roboterforum.de - Die Industrieroboter- Anwender und Experten Community

[offen] Screenmaker DI


normal_post Autor Thema: [offen] Screenmaker DI  (Gelesen 1339 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

11. Juli 2018, 11:04:02
Gelesen 1339 mal
Offline

MaWeTis


Hallo zusammen,

gibt es eine Möglichkeit, von der Screenmaker Oberfläche direkt einen digitalen Input zu steuern?
ich möchte auf meiner Oberfläche buttons mit "Start, Stop, Start at Main, Grundstellungsfahrt" anlegen.
Ich habe aber lediglich die Möglichkeit gefunden digitale Outputs und Variablen mit den Buttons zu ändern/steuern.

Vielen Dank für eure Hilfe!
  • gefällt mir    Danke

Heute um 16:06:15
Antwort #1

Werbung

Gast

11. Juli 2018, 11:19:40
Antwort #1
Offline

padostms


Hallo!
Musst du zur eine Steuerung verbunden sein.Auf die gewünschte schaltfläche klicken dann Aktion hinfügen ,dort kannst du die Signale und etc. festlegen.

11. Juli 2018, 11:29:43
Antwort #2
Offline

MaWeTis


Hey padostms,
vielen Dank für deine schnelle Antwort.
Ich glaube ich habe das etwas umständlich geschrieben.

Verbunden bin ich.
Ich denke ich weiß auch wie ich eine Aktion erstellen kann.

Mein Problem ist nur, dass ich wenn ich ein Start oder Stop meines Roboters auslösen will muss ich da ja  ein Eingangssignal anlegen  und dann über ein System Input lösen.
Wenn ich das über die Visualisierung machen will kann ich dort keinen digitalen input auswählen, sondern nur digitale outputs 
Ich habe hierzu einen Screenshot gemacht.

Gruß MaWeTis
  • gefällt mir    Danke

11. Juli 2018, 11:53:04
Antwort #3
Offline

padostms


Aha ok!
Du kannst dort nur Ausgänge auswählen!Eingang kann man nicht setzen.Ausser mit eine Crossconnection.Wenn du eine neue eingang machst zb eine virtuelle dann musst du über Signal lesen machen.
Wills du Pulsen?

« Letzte Änderung: 11. Juli 2018, 12:02:59 von padostms »

11. Juli 2018, 13:28:51
Antwort #4
Offline

Micky


Hallo,
bei den Systemeingängen kannst Du auch Ausgänge verwenden, leider funktioniert die Zuordnung nicht in RobotStudio.
Am besten Du erzeugst den Systemeingang in RobotStudio und verwendest einen beliebigen Eingang. Dann speicherst Du die EIO.CFG und öffnest sie mit einem TextEditor. Anschließend ersetzt du den Eingang mit dem Ausgang den Du verwenden möchtest. Nach dem Laden der EIO.CFG kann Du jetzt den Ausgang zum Schalten des Systeneingangs verwenden.
Gruß
Micky
Probleme kann man niemals mit derselben Denkweise lösen, durch die sie entstanden sind. (Albert Einstein)

Heute um 16:06:15
Antwort #5

Werbung

Gast

11. Juli 2018, 15:36:23
Antwort #5
Offline

MaWeTis


Hey,
cool! das funktioniert sogar*gg*

vielen Dank euch beiden!!
  • gefällt mir    Danke


Teile per facebook Teile per linkedin Teile per pinterest Teile per reddit Teile per twitter
 

über das Roboterforum

Nutzungsbedingungen Impressum Datenschutzerklärung

Sponsoren des Roboterforums

ROBTEC GmbH