21. Februar 2019, 18:57:49
Roboterforum.de - Die Industrieroboter- Anwender und Experten Community

 Module laden über RS232 (sio1)


normal_post Autor Thema:  Module laden über RS232 (sio1)  (Gelesen 2899 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

10. Mai 2006, 12:42:17
Gelesen 2899 mal
Offline

Roboterteufel


Hallo,

hat jemand eine Idee wie man über die serielle Schnittstelle Module übertragen kann.
Es soll bei einer S4-Steuerung funktionieren, da die Anlage bei uns mit ca. 39 Module zu geballert ist. Das programmieren macht bei so einem zugemüllten Arbeitsspeicher wirklich keinen Spass.

Danke
 :wallbash:
  • gefällt mir    Danke

Heute um 18:57:49
Antwort #1

Werbung

Gast

10. Mai 2006, 14:29:46
Antwort #1
Offline

Sven Weyer

Global Moderator
Hallo Roboterteufel,
bei uns ist das immer so eine Sache da die Jungs in der PC-Abt. damit nicht so recht klarkommen sowie es ein bestimmte Aufwand an zusätzlicher Software sowie Optionen für den roboter bedeuten. Da Du bei S4-Steuerungen keinen internen Speicher zur verfügung hast wie bei S4c oder aufwärts würde ich es mal mit der Diskette probieren. Dann über die üblichen Instruktionen die jeweiligen Module löschen oder laden im Arbeitsspeicher des Roboter. Funktioniert wesentlich sicherer als das fremdgelade über einen PC.
Solltest Du noch Tipps benötigen dann Frag einfach noch einmal nach.

robotic74
  • gefällt mir    Danke
Wer nichts macht macht keine Fehler!
Wer keine Fehler macht kann nichts daraus lernen!
Wer nichts lernen kann kann sich nicht weiterentwickeln!
Wer sich nicht entwickelt geht unter!

11. Mai 2006, 19:51:23
Antwort #2
Offline

Roboterteufel


Hallo robotic74,

das mit den Disketten habe ich schon im laufen, ABER DIE ZUVERLÄSSIGKEIT, der Disketten ist sehr beschränkt. Bei ca. 5 bis 15 Modulwechsel mit ca. 35kb suche ich nach anderen lösungen. Diese alten Möhren auf Netz umstellen zulassen, ist ein unerschwinglicher finanzieller Aufwand. Oder gibt es eine möglichkeit das Disk-Laufwerk durch ein anderes Medium auszutauschen ?

Roboterteufel
  • gefällt mir    Danke

11. Mai 2006, 20:44:30
Antwort #3
Offline

Sven Weyer

Global Moderator
Hallo
bei S4 bin ich mir da nicht so sicher. Denke Deine vorangehensweise ist nicht die schlechteste. Über die Schnittstelle könnte die bessere Wahl sein aber ich denke ohne weitere Software PC-seitig wirdst Du nicht auskommen!

robotic74
  • gefällt mir    Danke
Wer nichts macht macht keine Fehler!
Wer keine Fehler macht kann nichts daraus lernen!
Wer nichts lernen kann kann sich nicht weiterentwickeln!
Wer sich nicht entwickelt geht unter!

28. Mai 2006, 20:01:04
Antwort #4
Offline

Roboterteufel


Ja Hallo,

eine verbindung über "sio1" hab ich jetzt, ja das wars auch schon. Der Befehl "LOAD" oder "SAVE" ist ,nach meinem ermessen, so wirkungsvoll wie ein U-Boot in der Wüste. Wenn jemand ,auch nur andeutungsweise, eine Idee hat wie so ein serieller Modul-Transfer ablaufen könnte ,währe das der Mega Tipp. Ein Prog auf dem PC ist das kleinere Übel.

Besten Dank.

Roboterteufel
 :hilfe: :meld: :merci:
  • gefällt mir    Danke

Heute um 18:57:49
Antwort #5

Werbung

Gast

02. Juni 2006, 22:56:51
Antwort #5
Offline

Torsten


Hi,

Load und Save werden über die RS232 nie funktionieren. Du musst Dir für die S4 das FactoryWareInterface (sio nannte sich das mal) besorgen. Das ist eine Option für die Steuerung, die, nagel mich nicht drauf fest, ca. 800Euro, kostet. Damit lässt sich dann eine TCP-IP / Slip Verbindung zwischen einem PC und der Steuerung herstellen. Aus PC sicht wird der Roboter als Modem angesprochen.
So, nun bringt das aber auch noch nicht viel. Jetzt brauchst Du eine auf ABB's Interlink oder ROBComm basierende Windows-Software, die auf dieser Schnittstelle nach befehlen lauscht und bei bedarf  Module in der Steuerung löscht und neue nachlädt.
Wir haben sowas mal gemacht. Ist auf einer S4 schrecklich langsam (9600Baud) und nicht unbedingt zu 100% verlässlich. Wenn Du noch interesse hast...schreib mal. Ich habe da ne Doku.

ciao,
  Torsten
  • gefällt mir    Danke

05. Juni 2006, 08:58:11
Antwort #6
Offline

Roboterteufel


Hallo Torsten

an einer Doku bin ich sehr Interessiert. Wenn es Dir möglich ist mir die zukommen zu lassen ,wäre ich ein großes Stück weiter.


Besten Dank
roboterteufel
  • gefällt mir    Danke

10. Juni 2006, 11:46:12
Antwort #7
Offline

Roboterteufel


Hi Torsten,

danke für die Doku.
Beim hochladen der Mod`s reklamierte die Steuerung diese Zeile an
"SCWrite srv_Connection; " (Referenzfehler). Ich habe die Routine in der Doku nicht gefunden, oder sollte das ein Teil der Robotersoft sein ?


bis denn
Roboterteufel
  • gefällt mir    Danke

12. Juni 2006, 16:59:27
Antwort #8
Offline

Torsten


Hi,

wie in der E-Mail beschrieben, muss die Softwareoption "FactoryWare Communications" auf dem Roboter installiert sein. Ansonsten steht der Befehl SCWrite nicht zur Verfügung. Überhaupt funktioniert die ganze Geschichte ohne die Clientsoftware auf dem PC nicht.
Die PC-Software kann ich Dir schicken, schick mir einfach FTP Zugangsdaten, dann kannst Du die testen. (Für ne E-Mail ist das leider zu groß) Bei der Robotersoftware kann ich leider nicht helfen...die musst Du bei ABB besorgen.

ciao,
   Torsten
  • gefällt mir    Danke

Heute um 18:57:49
Antwort #9

Werbung

Gast

13. Juni 2006, 17:12:58
Antwort #9
Offline

Roboterteufel


Hallo,

das ding geht !!! Es funktioniert !!! Na gut, ein paar Anpassugen an unsere Bedürfnisse sind es doch noch. Aber das Ding geht.

Vielen Dank für deine Hilfe !!!! :danke: :merci: :supi:
roboterteufel
  • gefällt mir    Danke


Teile per facebook Teile per linkedin Teile per pinterest Teile per reddit Teile per twitter
 

über das Roboterforum

Nutzungsbedingungen Impressum Datenschutzerklärung

Sponsoren des Roboterforums

ROBTEC GmbH