22. Juli 2019, 20:24:26
Roboterforum.de - Die Industrieroboter- Anwender und Experten Community

[offen] IRB 120 mit Cognex IS5400


normal_post Autor Thema: [offen] IRB 120 mit Cognex IS5400  (Gelesen 537 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

09. Februar 2018, 11:54:42
Gelesen 537 mal
Offline

RoboLex


Hallo,
im Rahmen eines Schulprojekts haben wir die Aufgabe erhalten, für unseren IRB 120 von ABB mithilfe einer Cognex IS5400 Kamera, ein automatisches Bildverarbeitungssystem zu entwickeln.
Leider scheitern wir bereits bei der Herstellung der Verbindung der zwei Komponenten.
Wir haben die Kamera an das LAN Interface des IRB 120 mit folgenden Einstellungen angeschlossen:
Roboter:
Ip.: 10.48.32.4
Maske: 255.255.255.0
Gateway: 10.48.32.1
"PC-Interface" Einstellung vorhanden

Kamera:
Ip.: 10.48.32.5
Maske: 255.255.255.0
Gateway: 10.48.32.1

Wir bekommen immer den Fehler 80001, Socket Initialization failed. Möglicherweiße stimmt der Gateway nicht, da bin ich mir nicht sicher.
Wir haben ebenfalls daran gedacht, das vielleicht die LAN Buchse fehlerhaft ist, da uns aufgefallen ist, dass dort die bekannten Grün - Orangen Lichter nicht Leuchten. 
Würde sonst der Service Port eine alternative bieten und wenn ja wie wird dieser Konfiguriert? 

Ich freue mich auf eure Gedanken dazu und vielen Dank schon mal im Vorraus.

Mit freundlichen Grüßen :)





  • gefällt mir    Danke

Heute um 20:24:26
Antwort #1

Werbung

Gast

11. Februar 2018, 10:36:03
Antwort #1
Offline

Hermann


Serviveport geht gar nicht.
Als Gateway sollte man die eigene IP-Adresse eintragen, wenn es kein echtes Gateway gibt (da gehe ich mal von aus, wenn Ihr die Kamera direkt an den Port angeschlossen habt).
Wenn die Kamera wirklich direkt mit einem Kabel auf der Steuerung hängt (ohne zwischengeschalteten Switch), dann mal mit einem Cross-Kabel versuchen (dann leuchten vielleicht auch die LEDs), oder einen Switch zwischenschalten.
Und normalerweise immer mit angeben: Steuerungsversion und Softwareversion
  • gefällt mir    Danke

17. Februar 2018, 13:24:05
Antwort #2
Offline

RoboLex


Vielen Dank für die Antwort.

Ich werde die fehlenden Daten die Tage aktualisieren.

Also quasi bei beiden Geräten als Gateway die Ip des Roboters.?
  • gefällt mir    Danke

17. Februar 2018, 13:40:27
Antwort #3
Offline

Hermann


Gateway ist eigentlich unnötig, da das Subnet nicht verlassen wird. Aber eine Adresse eintragen, die es im betreffenden Netzwerk nicht gibt ist definitiv keine gute Idee.
  • gefällt mir    Danke


Teile per facebook Teile per linkedin Teile per pinterest Teile per reddit Teile per twitter
 

über das Roboterforum

Nutzungsbedingungen Impressum Datenschutzerklärung

Sponsoren des Roboterforums

ROBTEC GmbH