Roboterprofis für Ihren Erfolg
Roboterprogrammierer auf Stundenbasis engagieren
jetzt Preise und verfügbare Roboterprogrammierer anfragen

Autor Thema:  Fehlerverhalten der S4c-Steuerung  (Gelesen 2140 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Sven Weyer

  • Global Moderator
  • Forum Legende LV 1
  • *
  • Beiträge: 1056
  • Bewertet: +17
Fehlerverhalten der S4c-Steuerung
« am: 09. Dezember 2005, 09:21:28 »
Hallöchen,
wollte mich einmal umhören zu einem Thema was S4c betrifft.
Wir haben eine Anlage in welcher wir einen neuen Typen hinzufügen. Nun kommt es im Programm zu einer logischen Änderung des Ablaufes. Dabei wird eine boolsche speichernde Variable (global deklariert) auf TRUE gesetzt in einer Routine welche sich im gleichen Modul befindet wie die Deklaration der Variablen. Dies ist ein Systemmodul und als NOSTEPIN fixiert.
Nun kommt es vor das der Roboter bei der Abarbeitung durch diese Routine läuft und die Abarbeitung stoppt. Wo durch der Stopp ausgelöst wir weiß ich nicht. Die Variable wird nirgens weiter verwendet. Wenn ich die Variable aber ausserhalb dieser Routine setze funktioniert dies. Es werden aber noch andere boolsche Variablen in dieser Routine gesetzt. Die betreffende Variable befindet sich sonst nirgends in dem Programm.

Ich persönlich stehe da vor einem Rätsel. Wenn jemand die Idee hat es könnte ein Interrupt oder eine Ereignisroutine sein muß ich diesen entäuschen.
Ist alles nicht vorhanden. Die elogs geben auch nichts gescheites aus. :bawling:

Wenn jemand ebenfalls dieses Phänomen beobachtet hat möge er sich doch bitte einmal melden.


Bis denne

robotic74

P.S.: Roboter läuft mit der Boot-Version O.S.3.2/24!

« Letzte Änderung: 09. Dezember 2005, 09:23:45 von robotic74 »
  • finde ich gut    Danke, das hat mir geholfen    brauche Hilfe    da stimmt was nicht    Lesenswert
Wer nichts macht macht keine Fehler!
Wer keine Fehler macht kann nichts daraus lernen!
Wer nichts lernen kann kann sich nicht weiterentwickeln!
Wer sich nicht entwickelt geht unter!


ABB Robotertraining
günstig und verständlich mit Zertifikat
ABB Roboterschulung

Offline Werner Hampel

  • Administrator
  • Forum Legende LV 3
  • *
  • Beiträge: 1583
    • ROBTEC GmbH - Roboter Systemhaus
  • Bewertet: +23
Re: Fehlerverhalten der S4c-Steuerung
« am: 09. Dezember 2005, 22:21:42 »
hmm, wie heisst denn die Variable ?

Hast schon mal versucht, die umzubenennen ?

Ist die maximale Anzahl an Variablen erreicht ? (wenns sowas gibt ?)

 :kopfkratz:
  • finde ich gut    Danke, das hat mir geholfen    brauche Hilfe    da stimmt was nicht    Lesenswert
Menschen brauchen Roboter, aber auch Roboter brauchen Menschen.
Roboter sichern die Arbeitsplätze und den Fortschritt der Industrieländer, da sie kostengünstig und qualitativ hochwertig produzieren.
Ohne Automatisierung mit Robotern werden unsere Produkte in Billiglohnländern hergestellt.

Offline Sven Weyer

  • Global Moderator
  • Forum Legende LV 1
  • *
  • Beiträge: 1056
  • Bewertet: +17
Re: Fehlerverhalten der S4c-Steuerung
« am: 10. Dezember 2005, 09:36:48 »
Hallo Werner,
es sind nicht all zuviele Variablen deklariert. Mit dem umbenennen habe ich es noch nicht getestet. Vielleicht ist es das.

Werd ich mal testen.

robotic74
  • finde ich gut    Danke, das hat mir geholfen    brauche Hilfe    da stimmt was nicht    Lesenswert
Wer nichts macht macht keine Fehler!
Wer keine Fehler macht kann nichts daraus lernen!
Wer nichts lernen kann kann sich nicht weiterentwickeln!
Wer sich nicht entwickelt geht unter!

mod-poser

  • Gast
Re: Fehlerverhalten der S4c-Steuerung
« am: 14. Dezember 2005, 19:28:42 »
Hi,
ich glaube nicht, daß der Programmstop direkt mit dem Beschreiben der Pers zu tun hat.
Entferne mal das NOSTEPIN, dann siehst Du auch , wo der pc stehen bleibt.

Gruß
msc
  • finde ich gut    Danke, das hat mir geholfen    brauche Hilfe    da stimmt was nicht    Lesenswert

Offline Sven Weyer

  • Global Moderator
  • Forum Legende LV 1
  • *
  • Beiträge: 1056
  • Bewertet: +17
Re: Fehlerverhalten der S4c-Steuerung
« am: 14. Dezember 2005, 19:35:02 »
Hallöchen,
haben das Problem soweit es geht erörtert.
Ein ändern der PERS in eine VAR brachte den eigentlichen Erfolg. Es wird in nächtser Zeit noch weitere Entwicklungsschritte diesbezüglich geben.
Infos werden folgen!!


robotic74
  • finde ich gut    Danke, das hat mir geholfen    brauche Hilfe    da stimmt was nicht    Lesenswert
Wer nichts macht macht keine Fehler!
Wer keine Fehler macht kann nichts daraus lernen!
Wer nichts lernen kann kann sich nicht weiterentwickeln!
Wer sich nicht entwickelt geht unter!

Offline Knut81

  • Stammgast LV 4
  • *
  • Beiträge: 19
  • Bewertet: 0
Re: Fehlerverhalten der S4c-Steuerung
« am: 09. Oktober 2009, 11:01:25 »
Hallo,
wir haben einen alten IRB 2400 von ABB mit S4Cplus Steuerung bekommen un dversuchen ihn jetzt zum laufen zu bringen. Ist das erste mal, dass ich mit ABB zu tun habe.
Ich habe ein Problem mit den Sicherheitskreisen.
Und zwar sind die beiden NOT-AUS-Kreise und die beiden Sicherheitskreise AS noch geöffnet. Sicherheitskreise GS sind geschlossen.
Kann  mir jemand sagen an welchen Klemmen ich diese evtl. mal zum Testen überbrücken kann?
Oder wie ich nun am besten vorgehe.
 :hilfe:
  • finde ich gut    Danke, das hat mir geholfen    brauche Hilfe    da stimmt was nicht    Lesenswert


xx
ABB S3 Steuerung

Begonnen von maddin

9 Antworten
4356 Aufrufe
Letzter Beitrag 07. Mai 2008, 01:48:20
von Patrick
xx
ABB S3 Steuerung M92/M93

Begonnen von Bodo

3 Antworten
2063 Aufrufe
Letzter Beitrag 17. Juli 2006, 12:04:39
von Rauschi
xx
ABB IRC 5 Steuerung

Begonnen von Sven Weyer

3 Antworten
2529 Aufrufe
Letzter Beitrag 06. November 2006, 17:21:21
von stromer
xx
Fernwartung S4C Steuerung

Begonnen von HarryH

5 Antworten
1487 Aufrufe
Letzter Beitrag 27. Juni 2012, 16:28:23
von Roboterteufel
xx
Dokumentation für S3 Steuerung

Begonnen von Alter Schwede

3 Antworten
916 Aufrufe
Letzter Beitrag 16. Juli 2013, 14:02:32
von ROB01
 

über das Roboterforum

Nutzungsbedingungen Impressum
Sitemap