20. Januar 2019, 19:16:28
Roboterforum.de - Die Industrieroboter- Anwender und Experten Community

 Einstellung TCP bei Trallfa ME502


normal_post Autor Thema:  Einstellung TCP bei Trallfa ME502  (Gelesen 1956 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

14. Februar 2006, 07:48:55
Gelesen 1956 mal

automatix

Gast
Hallo!

Ich habe hier ein mehr oder weniger kleines Problem beim Editieren des TCP für eine Sprühpistole, vielleicht kann mir ja jemand helfen...

Also, ich habe hier einen etwas älteren Robi, - einen Trallfa ME502 HW mit einer C5.3A-Steuerung und RobTalk 3.8.3 - und will den TCP einer Lackierpistole editieren. Laut Anleitung ist ja das Koordinatensystem des TCP zunächst mal so orientiert, daß die X-Achse gerade aus dem Arm herausläuft, die Y-Achse (Blickrichtung auf den TCP von vorne und alle Winkel des Hollow Wrist auf "0" ) nach rechts und die Z-Achse nach oben verläuft, oder? Meine Pistole zeigt nach rechts und ist in einem Winkel von 60° zur Y-Achse angebracht.

Ich habe nun bei TCP 1 folgendes eingegeben (Sprühabstand 0, also müßte der neue TCP direkt an der Nadel liegen):
X=290
Y=44
Z=0
a=0
b=60
c=0

Die Werte habe ich anhand der CAD-Zeichnung von Pistole und Pistolenhalter ermittelt.

Mit diesen Werten und eingestelltem TCP 1 positioniert der Robi korrekt, also stimmt die Vedrehung des Koordinatensystems schon mal. Allerdings habe ich ein Problem bei der Orientierung: Wenn ich um die Y-Achse orientiere, funktioniert alles, aber die anderen beiden Richtungen passen überhaupt nicht... Der Robi "eiert" um irgendeinen Drehpunkt herum, den ich nicht mal vernünftig lokalisieren kann.

Hat jemand eine Idee, woran das liegen könnte? Habe schon so ziemlich alles ausprobiert, was mir so einfällt, allerdings ohne wirklichen Erfolg...

Gruß,

Automatix
  • gefällt mir    Danke

Heute um 19:16:28
Antwort #1

Werbung

Gast

14. Februar 2006, 17:23:41
Antwort #1
Online

Werner Hampel

Administrator
also ich hatte mal so einen Lackierroboter und das mit dem TCP hat da gar net hingehaun.
Ging mir ganz genau so.
Habe sogar mit dem Roboter eingemessen und in einer Orientierung hat er absolut unlogisches gemacht.
Ich habs dann so akzeptiert und einfach geteacht.
Die Ergebnisse waren jedenfalls einwandfrei.
  • gefällt mir    Danke
Menschen brauchen Roboter, aber auch Roboter brauchen Menschen.
Roboter sichern die Arbeitsplätze und den Fortschritt der Industrieländer, da sie kostengünstig und qualitativ hochwertig produzieren.
Ohne Automatisierung mit Robotern werden unsere Produkte in Billiglohnländern hergestellt.

16. Februar 2006, 06:28:24
Antwort #2

automatix

Gast
Hallo, Werner!

Gut zu hören, daß ich nicht der Einzige bin, der bei diesem "Gerät" Probleme hat bzw. hatte.

Ich denke, ich werd`s wohl machen müssen wie Du und nicht weiter über die Sache mit dem TCP nachdenken, aber gefallen tut mir`s nicht wirklich...

Vielleicht findet sich ja hier doch noch ein "Trallfa-Spezialist" mit einer Idee... :-)
  • gefällt mir    Danke


Teile per facebook Teile per linkedin Teile per pinterest Teile per reddit Teile per twitter
 

über das Roboterforum

Nutzungsbedingungen Impressum Datenschutzerklärung

Sponsoren des Roboterforums

ROBTEC GmbH