22. Juli 2019, 21:18:44
Roboterforum.de - Die Industrieroboter- Anwender und Experten Community

[offen] Brauch dringend Hilfe ABB IRC 5


normal_post Autor Thema: [offen] Brauch dringend Hilfe ABB IRC 5  (Gelesen 1715 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

23. Oktober 2017, 23:20:56
Gelesen 1715 mal
Offline

uwitzsch




Hallo mein Name ist Uwe, ich arbeite seit fast 15 Jahren an einen ABB Roboter (M2000 S4CPlus). Ich erstelle Programme für Schweißapplikationen. Seit einigen Wochen habe ich noch einen ABB IRB 2600 IRC5 dazu bekommen. Ebenfalls als Schweißroboter. Die Schweißausrüstung ist in beiden Fällen von Fronius. Die neue Anlage ist mit CMT ausgerüstet.
Zu meinen eigentlichen Anliegen
Mitten im Automatikbetrieb ist die Anlage stehen geblieben, mit der Fehlermeldung
E/A Signal diFR1TochColisn also Kollision, der Roboter stand kurz vor einer Schweißnaht im freien Raum. Keine Anzeichen für eine Kollision zu erkennen. Nach einigen erfolglosen Versuchen die Störung zu beseitigen, habe ich den Eingang simuliert. Der Roboter konnte manuell bewegt werden. Bin im Programm ein paar Zeilen zurück gegangen PZ auf Cursor, Anlage läuft.
Nach ca. 1 Stunde Roboter steht wieder vor einer Schweißnaht mit denselben Fehlermeldungen. Gleiche Prozedur, leider kein Erfolg.  Steuerung neu gestartet, nach dem drücken der Motoreneintaste, wieder E/A Signal diFR1TochColisn. Signal erneut simuliert Roboter lässt sich nicht bewegen Fehlermeldung:
Meldung 40277 Rückgängig abgebrochen Die Programmabarbeitung wurde während der Verarbeitung der UNDO Anweisung angehalten. UNDO wurde nicht vollständig ausgeführt. Während UNDO angehalten wurde, wurde die Routine MoveToSafe ausgeführt.
Habe schon alles möglich probiert, mehrmalig die Anlage neu gestartet ausgeschalten eingeschalten, keine Reaktion.
Wird wohl darauf hinaus laufen, dass mein Chef eine Serviceanforderung machen muss, oder hat von euch einer einen Lösungsvorschlag.
Ist jetzt 23:20 Uhr ich habe Nachtschicht bis 6 Uhr und wäre für jede Hilfe dankbar.
  • gefällt mir    Danke

Heute um 21:18:44
Antwort #1

Werbung

Gast

24. Oktober 2017, 00:59:55
Antwort #1
Offline

Sven Weyer

Global Moderator
Moin,
ich kenne mich jetzt mit Schweißapplikationen ja nicht aus, aber die Steuerung gibt ja schon einen Hinweis auf einen Eingang.
Seit Ihr diesem Thema einmal nach gegangen?
Womit ist dieser Eingang verbunden? diFR1TouchColisn eventuell mit einer Kollisionsdose am Roboterflansch Achse 6?
Was macht denn dieser Eingang wäre für mich die erste entscheidende Frage!
Unter Umständen hat sich ja etwas gelockert etc. somit sind Beschleunigung und Abbremsrampen auch in der Lage eine Kollisionsdose auszulösen, frei im Raum. ;-)
Kann dazu nur raten aber ein weiß ich mit Sicherheit, ein Aus- und Einschalten der Steuerung wird dein Problem nicht lösen.

Gruß
Sven
  • gefällt mir    Danke
Wer nichts macht macht keine Fehler!
Wer keine Fehler macht kann nichts daraus lernen!
Wer nichts lernen kann kann sich nicht weiterentwickeln!
Wer sich nicht entwickelt geht unter!

24. Oktober 2017, 05:42:11
Antwort #2
Offline

uwitzsch


Hallo Sven


Danke für deine Antwort. Das Problem E/A Signal diFR1TochColisn besteht aus irgendwelchen Gründen nicht mehr. Abschaltdose und Signal sind OK. Roboter lässt sich auch manuell bewegen. Sobald ich eine Anforderung über Vorwärts, Rückwärts oder Start gebe kommen immer wieder dieselben Fehlermeldungen. Der Roboter reagiert auf Motoren ein Stoppt aber sofort wieder. Eine Anforderung über Roboter in Grundstellung fahren führt zu demselben Ergebnis.
Meldung 40277 Rückgängig abgebrochen
Meldung 40233 Abarbeitungsfehler
MfG Uwe
  • gefällt mir    Danke

25. Oktober 2017, 03:51:55
Antwort #3
Offline

Sven Weyer

Global Moderator
Moin Uwe,
das hört sich recht nach einer übergeordneten Abschaltung des Roboter an.
Habt Ihr Zugriffsbeschränkungen was die Bedienung des Roboters betrifft?
Ohne ein vernünftigen Blick ins Programm lässt sich da schwer was sagen.
Kannst Du bitte noch einmal genau beschreiben, Schritt für Schritt was Ihr genau macht.
Ab Start von Main bis zu Euren genannten Fehlermeldungen.

Gruß
Sven
  • gefällt mir    Danke
Wer nichts macht macht keine Fehler!
Wer keine Fehler macht kann nichts daraus lernen!
Wer nichts lernen kann kann sich nicht weiterentwickeln!
Wer sich nicht entwickelt geht unter!

25. Oktober 2017, 08:40:49
Antwort #4
Offline

uwitzsch


Hallo Sven
Zugriffsbeschränkungen haben wir nicht. Die Anlage lief schon einige Stunden im Automatikbetrieb, bevor es zu diesen Fehlern kam. Das Programm ist absolut sauber gelaufen. Die Anlage ist so gut wie neu. Heute gegen 11 Uhr kommt ein Techniker von ABB, bin mal gespannt woran es liegt. Werde auf jeden Fall schreiben, an was es gelegen hat.
MfG Uwe

Heute um 21:18:44
Antwort #5

Werbung

Gast

25. Oktober 2017, 10:15:52
Antwort #5
Offline

Robiman

Global Moderator
die Meldung sagt da doch einiges, da wird auch angegeben welche Routine den Fehler verursacht...
siehe Doku
aber wie schon oben gesagt ohne das Programm zu kennen ist da eine genauerer Aussage schwer möglich
40277, Rückgängig abgebrochen
Beschreibung
Task arg
Die Programmabarbeitung wurde während der Verarbeitung
der UNDO-Anweisungen angehalten.
UNDO wurde nicht vollständig ausgeführt.
Während UNDO angehalten wurde, wurde die Routine arg
ausgeführt.
Empfohlene Aktionen
Wenn die Verarbeitung von UNDO zu lange dauert,
zeitaufwendige
Instruktionen wie TPWrite, aus der UNDO-Klausel entfernen.
Wenn die Verarbeitung nicht zu enden scheint, Schleifen in den
UNDO-Anweisungen überprüfen.














  • gefällt mir    Danke

25. Oktober 2017, 23:13:45
Antwort #6
Offline

uwitzsch



Fehler ist behoben
Hallo zusammen, heute war der nette ABB-Techniker bei uns und hat sich des Problems angenommen. Der Fehler ist ihm in seiner 20ig jährigen Tätigkeit noch nicht untergekommen. Verursacht wurde der Fehler von der Robware und nicht von einen Programm. Da er den Fehler nicht lokalisieren konnte, hat er das System neu aufgesetzt. Die Anlage läuft seit ca. 16 Uhr wieder. Backup und Logdateien gehen zu ABB und werden analysiert, bin mal gespannt was die Ursache war.
MfG Uwe


Teile per facebook Teile per linkedin Teile per pinterest Teile per reddit Teile per twitter
 

über das Roboterforum

Nutzungsbedingungen Impressum Datenschutzerklärung

Sponsoren des Roboterforums

ROBTEC GmbH