Roboterprofis für Ihren Erfolg
Roboterprogrammierer auf Stundenbasis engagieren
jetzt Preise und verfügbare Roboterprogrammierer anfragen

Autor Thema: [offen] B&R analoges Ausgangsmodul  (Gelesen 606 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline he4142

  • Forum Mitglied LV 14
  • *
  • Beiträge: 168
  • Bewertet: 0
[offen] B&R analoges Ausgangsmodul
« am: 25. Oktober 2016, 11:53:05 »
Kollegen,
hat jemand eine Ahnung wie ich ein AO 4622 Ausgangsmodul von B&R zum Laufen bekommen?
Habe schon zig Varianten versucht, aber es funktioniert nicht. Wieviele Ausgangsbyte muss ich dafür definieren??
  • finde ich gut    Danke, das hat mir geholfen    brauche Hilfe    da stimmt was nicht    Lesenswert

Offline dust2

  • Forum Mitglied LV 14
  • *
  • Beiträge: 178
  • Bewertet: +12
Re: B&R analoges Ausgangsmodul
« am: 30. Oktober 2016, 18:32:03 »
1. Buskoppler erstmal mit nur einem digitalen Modul zum Laufen bringen 
2. Buskoppler mit nur dem analogen Ausgangsmodul bestücken und Multimeter an Ausgang, ggf. bei Profibus/ProfiNet neue Konfigurationsdatei erzeugen
3.  in EIO.cfg (hier Beispiel für Ausgang 4...20mA und 12Bit Wandlung )
      -Name "ao1_NomAirPressure" -SignalType "AO" -Device "deinTyp"\
      -DeviceMap "0-15" -Access "All" -EncType "UNSIGNED"  -MaxPhys 20 -MaxBitVal 4096 -MinPhys 4
4. in Robotstudio Analogausgang beschreiben und mit Multimeter prüfen, ggf. die Parameter MaxBitVal ändern (ABB-Doku: Systemparameter)
5. wenn das dann stimmt, ein Digital-Modul wieder rein und nun schauen ob die Analogklemme vorn im Prozessabbild bleibt also bei 0....15 (so ist es bei BECKOFF-egal wo die analogen Klemmen stecken, im Prozeßabbild des Kopplers werden sie immer zuerst-also vor den digitalen Klemmen abgebildet) B&R weiß ich das nicht, einfach probieren!

Grüße dust2
  • finde ich gut    Danke, das hat mir geholfen    brauche Hilfe    da stimmt was nicht    Lesenswert

Offline he4142

  • Forum Mitglied LV 14
  • *
  • Beiträge: 168
  • Bewertet: 0
Re: B&R analoges Ausgangsmodul
« am: 17. November 2016, 06:54:17 »
Hallo,
habe nun nach jeder Menge Versuchen geschafft die beiden Ausgangsmodule alleine zum Laufen zu bringen.
Die bestehenden Module (DI,DO,AI) mit den AO schaffe ich nicht - gebe jetzt auch auf.
Werde mit ein Siemens RIO einbauen.
  • finde ich gut    Danke, das hat mir geholfen    brauche Hilfe    da stimmt was nicht    Lesenswert


clip
Roboter stoppen, wenn Tür offen

Begonnen von Frahmi

7 Antworten
2520 Aufrufe
Letzter Beitrag 02. Juli 2018, 14:39:28
von Frahmi
xx
analoges Sensorsignal über Profibus-Messverstärker einlesen

Begonnen von KMAN

2 Antworten
1578 Aufrufe
Letzter Beitrag 13. Juni 2008, 12:11:21
von KMAN
xx
Irb 2400 Auto Stop offen

Begonnen von Jeff

2 Antworten
2171 Aufrufe
Letzter Beitrag 16. Oktober 2008, 23:19:53
von Jeff
xx
Fehlermeldung Endlagenschalter DRV1 offen meldung 20214

Begonnen von roboprog

1 Antworten
2057 Aufrufe
Letzter Beitrag 09. Mai 2012, 10:42:46
von Robiman
xx
ABB S4+ "Allgemeiner Stop offen" 20206

Begonnen von gewinner

1 Antworten
1246 Aufrufe
Letzter Beitrag 15. Mai 2016, 09:19:33
von Martl
 

über das Roboterforum

Nutzungsbedingungen Impressum
Sitemap