23. Juli 2019, 09:00:53
Roboterforum.de - Die Industrieroboter- Anwender und Experten Community

[gelöst] Automatik-Start von Extern


normal_post Autor Thema: [gelöst] Automatik-Start von Extern  (Gelesen 5740 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

28. Juli 2005, 15:35:15
Gelesen 5740 mal
Offline

markus007ABB


Hallo !
Ich habe früher schon einige s4 Controller programmiert, bei denen ich den Roboter mit der externen SPS gestartet habe.
Das ganze ging so: Schlüsselschalter auf AUTO und mit dem Systemeingang -OKFehlerdialog- die Meldung BA Automatik ... quittieren , mit SPS SysIn-Motore ein- auf "1" setzten und dann SysIn-Start Programm- auf "1" setzen und dann lief das ding.
Seit neuestem kann ich aber mit dem Systemeingang -OKFehlerdialog- den dialog "Betriebsart von Hand nach Auto gewechselt" nichtmehr quittieren.
Von ABB wurde ich bis jetzt immer nur "Blödsinn" erzählt (ging noch nie usw.).
Kann mir von euch da vielleicht jemand weiterhelfen ??

gruß Markus
« Letzte Änderung: 17. Mai 2019, 11:17:47 von Sven Weyer »
  • gefällt mir    Danke

Heute um 09:00:53
Antwort #1

Werbung

Gast

28. Juli 2005, 16:49:40
Antwort #1
Offline

Sven Weyer

Global Moderator
Hallöchen,
wir Starten unsere Roboter auch von extern aber dafür müssen diese im Automatik sein. So wie Du es beschrieben hast haben wir es noch nie gemacht. Daher kann ich Dir nicht bestätigen das es bei S4 so funktioniert hat. Weiß nur das bei S4c und S4c+ die Fehlerquittierung funktioniert aber der Dialog beim umschalten der Betriebsart ist ja auch keine Fehlermeldung. Somit würde ich schon nachvollziehen können das es dort nicht geht, oder nicht mehr geht.
Und das die Jungs von ABB-Deutschland es nicht wissen muß nicht zwangsläufig heißen das es nicht funktioniert hat.
Wer ist eigentlich auf diese Idee gekommen mit der Bestätigung des Fehlerdialogs diese Abfrage zu bestätigen?  :kopfkratz:

Bis denne
  • gefällt mir    Danke
Wer nichts macht macht keine Fehler!
Wer keine Fehler macht kann nichts daraus lernen!
Wer nichts lernen kann kann sich nicht weiterentwickeln!
Wer sich nicht entwickelt geht unter!

28. Juli 2005, 21:21:32
Antwort #2
Offline

burlibua


Unsere Roboter werden nach Automatik umschalten Ok Bestätigen  mit Systemeingang "MotorOnStart" gestartet  da gabs noch nie Probleme

mfG Burlibua
  • gefällt mir    Danke

29. Juli 2005, 07:31:50
Antwort #3
Offline

markus007ABB


Hallo !

Tja, was nützt mir denn eigentlich ein Start von extern wenn ich dann sowiso wieder auf dem PHG herumarbeiten muss (OK-bestätigen) diese Frage stellte ich auch ABB - mit der Antwort: Tja es wäre doch ohnehinn besser den Roboter nicht von Extern zu Starten.

Danke für eure Antwort ! :danke:
  • gefällt mir    Danke

29. Juli 2005, 19:24:01
Antwort #4
Offline

Sven Weyer

Global Moderator
Hallo markus007ABB,
die Antwort von ABB ist natürlich "sehr einleuchtend". Finde ich wirklich sauber  :uglyhammer_2:

Aber jetzt zum eigentlichen Thema. Wir benutzen Ihn hauptsächlich um mehrere Roboter in einer Zelle zu starten. Wenn Du zum Beispiel zwei oder drei Roboter in einer Zelle hast ist es recht easy alle in Automatik zu bringen und dann nach dem alle Sicherheitskreise geschlossen sind die Anlage über einen Starttaster zu starten. Desweiteren ist dies erforderlich wenn ich die Zelle betrete. Sprich den Sicherheitskreis öffne wird der Roboter je nach Sicherheitsbeschaltung hardwaremäßig "Schach-Matt" gesetzt. So nun müßte der Bediener, ohne Start von extern, nach dem der Sicherheitskreis wieder i.O. ist den Roboter seperat starten. Tja aber mit dieser Funktion braucht der Bediener sich nicht mehr um den Roboter zu kümmen sondern betätigt nur noch den Automatik-Starttaster der Anlage. Über die Übergeordnete SPS wird der (die) Roboter dann automatisch gestartet. Ist doch viel besser für den Bediener nicht wahr?

Bis denne
  • gefällt mir    Danke
Wer nichts macht macht keine Fehler!
Wer keine Fehler macht kann nichts daraus lernen!
Wer nichts lernen kann kann sich nicht weiterentwickeln!
Wer sich nicht entwickelt geht unter!

Heute um 09:00:53
Antwort #5

Werbung

Gast

30. Juli 2005, 16:50:55
Antwort #5
Offline

burlibua


Hey markus

Eine kleine Info : In deiner Variante wäre es möglich wenn du gerade in der Zelle mit dem PHG programmierst / teachst, kann wenn jemand auf Automatik umschaltet die Zelle starten.  Wenn du dabei noch eine
uneinsichtige Zelle hast oder die Schutztür während Automatik verriegelt ist könnts Probleme geben.  Wenn ich in Hand 100% Taktzeitänderungen mache und in der Zelle bin, habe ich immer ein ungutes Gefühl bei offener Schutztür  (einladend) -- da mache ich die Schutztür zu

mfG Burlibua

  • gefällt mir    Danke

01. August 2005, 18:34:45
Antwort #6

Andreas Wollmann

Gast
Zitat
Seit neuestem kann ich aber mit dem Systemeingang -OKFehlerdialog- den dialog "Betriebsart von Hand nach Auto gewechselt" nichtmehr quittieren.
Ich habe hier eine M97A-Steuerung von 1997 stehen.
Und sie kann es auch nicht.
  • gefällt mir    Danke

02. August 2005, 14:45:45
Antwort #7
Offline

maddin


Das Umschalten von Handbetrieb auf Automatikbetrieb muß über das PHG bestätigt werden.
Das war meiner Ansicht nach schon immer so (bei mir S4C und S4C+) .

Wäre mir neu daß dieses Umschalten auch extern bestätigt werden könnte......
  • gefällt mir    Danke


Teile per facebook Teile per linkedin Teile per pinterest Teile per reddit Teile per twitter
 

über das Roboterforum

Nutzungsbedingungen Impressum Datenschutzerklärung

Sponsoren des Roboterforums

ROBTEC GmbH